summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-07-08 11:22:05 +0000
committerThomas Kahle <tomka@gentoo.org>2011-07-08 11:22:05 +0000
commitcb06bb83311d81cf944a02dfa16118fae413f6a0 (patch)
tree9d9427d642db300ce6a274fafe1a0bc3a2d7534a /sci-mathematics
parentFix docs installation (bug #374369 by Chris Mayo) and version bump. (diff)
downloadgentoo-2-cb06bb83311d81cf944a02dfa16118fae413f6a0.tar.gz
gentoo-2-cb06bb83311d81cf944a02dfa16118fae413f6a0.tar.bz2
gentoo-2-cb06bb83311d81cf944a02dfa16118fae413f6a0.zip
Bump to 2.7
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/normaliz/ChangeLog10
-rw-r--r--sci-mathematics/normaliz/files/normaliz-2.7-respect-flags.patch42
-rw-r--r--sci-mathematics/normaliz/normaliz-2.7.ebuild54
3 files changed, 104 insertions, 2 deletions
diff --git a/sci-mathematics/normaliz/ChangeLog b/sci-mathematics/normaliz/ChangeLog
index e421a06d816b..78e2abea42ed 100644
--- a/sci-mathematics/normaliz/ChangeLog
+++ b/sci-mathematics/normaliz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/normaliz
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.4 2010/12/20 12:25:36 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.5 2011/07/08 11:22:05 tomka Exp $
+
+*normaliz-2.7 (08 Jul 2011)
+
+ 08 Jul 2011; Thomas Kahle <tomka@gentoo.org> +normaliz-2.7.ebuild,
+ +files/normaliz-2.7-respect-flags.patch:
+ Bump to 2.7
20 Dec 2010; Markos Chandras <hwoarang@gentoo.org> normaliz-2.5-r1.ebuild:
Stable on amd64 wrt bug #348318
diff --git a/sci-mathematics/normaliz/files/normaliz-2.7-respect-flags.patch b/sci-mathematics/normaliz/files/normaliz-2.7-respect-flags.patch
new file mode 100644
index 000000000000..27c4935a3edc
--- /dev/null
+++ b/sci-mathematics/normaliz/files/normaliz-2.7-respect-flags.patch
@@ -0,0 +1,42 @@
+diff -U 3 -dHrN Normaliz2.7.orig/source/Makefile Normaliz2.7/source/Makefile
+--- Normaliz2.7.orig/source/Makefile 2011-07-08 13:02:49.000000000 +0200
++++ Normaliz2.7/source/Makefile 2011-07-08 13:04:45.000000000 +0200
+@@ -17,14 +17,14 @@
+ $(MAKE) --directory=libnormaliz libnormaliz.o
+
+ normaliz: $(SOURCES) $(HEADERS) libnormaliz/libnormaliz.o
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz.cpp libnormaliz/libnormaliz.o $(GMPFLAGS) -o normaliz
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) Normaliz.cpp libnormaliz/libnormaliz.o $(GMPFLAGS) -o normaliz
+
+ normaliz1: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
+
+
+ normaliz-pg: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -pg Normaliz-impl.cpp $(GMPFLAGS) -o normaliz-pg
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) -pg Normaliz-impl.cpp $(GMPFLAGS) -o normaliz-pg
+
+ clean:
+ $(MAKE) --directory=libnormaliz clean
+diff -U 3 -dHrN Normaliz2.7.orig/source/Makefile.configuration Normaliz2.7/source/Makefile.configuration
+--- Normaliz2.7.orig/source/Makefile.configuration 2011-07-08 13:02:49.000000000 +0200
++++ Normaliz2.7/source/Makefile.configuration 2011-07-08 13:03:26.000000000 +0200
+@@ -1,10 +1,8 @@
+ ##
+ ## Makefile configuration for normaliz
+ ##
+-CXX = g++
+ CXXFLAGS += -Wall
+ CXXFLAGS += -pedantic -Wno-long-long
+-CXXFLAGS += -O3 -funroll-loops
+ #CXXFLAGS += -g
+ #CXXFLAGS += -pg
+
+@@ -15,6 +13,5 @@
+ CXXFLAGS += -fopenmp
+ endif
+
+-NORMFLAGS = -static
+ GMPFLAGS = -lgmpxx -lgmp
+
diff --git a/sci-mathematics/normaliz/normaliz-2.7.ebuild b/sci-mathematics/normaliz/normaliz-2.7.ebuild
new file mode 100644
index 000000000000..13c5d5d19b0d
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-2.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.7.ebuild,v 1.1 2011/07/08 11:22:05 tomka Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MYP="Normaliz${PV}"
+
+DESCRIPTION="tool for computations in affine monoids and more"
+HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
+SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/${MYP}/${MYP}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras openmp"
+
+RDEPEND="dev-libs/gmp[-nocxx]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MYP}
+
+src_prepare () {
+ epatch "${FILESDIR}/${P}-respect-flags.patch"
+
+ if use openmp && tc-has-openmp; then
+ export OPENMP=yes
+ else
+ export OPENMP=no
+ fi
+}
+
+src_compile(){
+ emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source || die
+}
+
+src_install() {
+ dobin source/normaliz || die
+ dodoc doc/"${MYP}Documentation.pdf" || die
+ if use extras; then
+ elog "You have selected to install extras which consist of Macaulay2"
+ elog "and Singular packages. These have been installed into "
+ elog "/usr/share/${PN}, and cannot be used without additional setup. Please refer"
+ elog "to the homepages of the respective projects for additional information."
+ elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
+ elog "copies of these interface packages. Usually you don't need normaliz's versions."
+ insinto "/usr/share/${PN}"
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+}