summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 12:51:38 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 12:51:38 +0000
commit9aa5b7ca9a8ea5d0326b156c2bf952d9deeb95c7 (patch)
tree5daa38b70f367728649201e1a2cf88b15e2a68b7 /sci-misc/gato
parentRemove app-emulation/libvirt from dependencies. Use elog information instead (diff)
downloadgentoo-2-9aa5b7ca9a8ea5d0326b156c2bf952d9deeb95c7.tar.gz
gentoo-2-9aa5b7ca9a8ea5d0326b156c2bf952d9deeb95c7.tar.bz2
gentoo-2-9aa5b7ca9a8ea5d0326b156c2bf952d9deeb95c7.zip
Version Bump, QA cleanup
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/gato')
-rw-r--r--sci-misc/gato/ChangeLog8
-rw-r--r--sci-misc/gato/files/gato-0.99c-python.patch17
-rw-r--r--sci-misc/gato/gato-0.99c.ebuild17
-rw-r--r--sci-misc/gato/gato-1.02.ebuild61
4 files changed, 74 insertions, 29 deletions
diff --git a/sci-misc/gato/ChangeLog b/sci-misc/gato/ChangeLog
index 55adb1593368..7bb59a80cfc3 100644
--- a/sci-misc/gato/ChangeLog
+++ b/sci-misc/gato/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/gato
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.12 2010/06/04 16:20:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.13 2010/06/24 12:51:38 jlec Exp $
+
+*gato-1.02 (24 Jun 2010)
+
+ 24 Jun 2010; Justin Lecher <jlec@gentoo.org> gato-0.99c.ebuild,
+ -files/gato-0.99c-python.patch, +gato-1.02.ebuild:
+ Version Bump, QA cleanup
04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gato-0.99c.ebuild:
diff --git a/sci-misc/gato/files/gato-0.99c-python.patch b/sci-misc/gato/files/gato-0.99c-python.patch
deleted file mode 100644
index 01fea326a86c..000000000000
--- a/sci-misc/gato/files/gato-0.99c-python.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- Gato/Gato.py 2008-01-27 14:10:49.000000000 +0100
-+++ Gato-patched/Gato.py 2008-01-27 14:12:37.000000000 +0100
-@@ -1,4 +1,5 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python
-+
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
---- Gato/Gred.py 2008-01-27 14:17:02.000000000 +0100
-+++ Gato-patched/Gred.py 2008-01-27 14:17:25.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
diff --git a/sci-misc/gato/gato-0.99c.ebuild b/sci-misc/gato/gato-0.99c.ebuild
index 95545640aa97..6e2f355105af 100644
--- a/sci-misc/gato/gato-0.99c.ebuild
+++ b/sci-misc/gato/gato-0.99c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.6 2010/06/04 16:26:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.7 2010/06/24 12:51:38 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -18,11 +18,9 @@ SRC_URI="http://gato.sourceforge.net/Download/${MY_PN}-${MY_PV}.tar.gz
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc"
-DEPEND=""
-RDEPEND=""
S="${WORKDIR}/${MY_PN}"
@@ -32,8 +30,6 @@ pkg_setup() {
}
src_prepare() {
- # convert to python >=2.4
- epatch "${FILESDIR}"/${P}-python.patch
# change TKinter call to avoid crashing of X
sed -i \
-e 's:self.overrideredirect(1):self.overrideredirect(0):' \
@@ -49,9 +45,8 @@ src_install() {
python_convert_shebangs -r 2 "${ED}"
# create symlinks
- dodir /usr/bin
- dosym ${instdir}/Gato.py /usr/bin/gato
- dosym ${instdir}/Gred.py /usr/bin/gred
+ dosym ${instdir}/Gato.py /usr/bin/gato || die
+ dosym ${instdir}/Gred.py /usr/bin/gred || die
# install data files
insinto /usr/share/${PN}
@@ -61,9 +56,9 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize gato
+ python_mod_optimize ${PN}
}
pkg_postrm() {
- python_mod_cleanup gato
+ python_mod_cleanup ${PN}
}
diff --git a/sci-misc/gato/gato-1.02.ebuild b/sci-misc/gato/gato-1.02.ebuild
new file mode 100644
index 000000000000..44b2fbf40560
--- /dev/null
+++ b/sci-misc/gato/gato-1.02.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-1.02.ebuild,v 1.1 2010/06/24 12:51:38 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+
+inherit eutils python
+
+MY_PN="Gato"
+MY_PV=$(echo ${PV} | tr '[:lower:]' '[:upper:]')
+
+DESCRIPTION="Graph Animation Toolbox"
+HOMEPAGE="http://gato.sourceforge.net/"
+SRC_URI="http://gato.sourceforge.net/Download/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # change TKinter call to avoid crashing of X
+ sed -i \
+ -e 's:self.overrideredirect(1):self.overrideredirect(0):' \
+ "${S}"/GatoDialogs.py || die "failed to patch GatoDialogs.py"
+}
+
+src_install() {
+ # install python code
+ local instdir=$(python_get_sitedir)/${PN}
+ insinto ${instdir}
+ doins *.py || die "Failed to install python files"
+ fperms 755 ${instdir}/{Gato,Gred}.py
+ python_convert_shebangs -r 2 "${ED}"
+
+ # create symlinks
+ dosym ${instdir}/Gato.py /usr/bin/gato || die
+ dosym ${instdir}/Gred.py /usr/bin/gred || die
+
+ # install data files
+ insinto /usr/share/${PN}
+ doins BFS.* DFS.* sample.cat || die "failed to data files"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}