summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-28 22:00:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-28 22:00:09 +0000
commitcf862812bef95c38813c7bf89ef3c5d72b6d5256 (patch)
treedc263eb4eda6d73b5fce460fc69d9f5928a5e906 /sci-misc/gt-itm
parentAdd amd64 keyword. (diff)
downloadgentoo-2-cf862812bef95c38813c7bf89ef3c5d72b6d5256.tar.gz
gentoo-2-cf862812bef95c38813c7bf89ef3c5d72b6d5256.tar.bz2
gentoo-2-cf862812bef95c38813c7bf89ef3c5d72b6d5256.zip
Fixup to more modern standards, and confirmed to build against amd64 as well.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/gt-itm')
-rw-r--r--sci-misc/gt-itm/ChangeLog8
-rw-r--r--sci-misc/gt-itm/gt-itm-19961004.ebuild32
2 files changed, 22 insertions, 18 deletions
diff --git a/sci-misc/gt-itm/ChangeLog b/sci-misc/gt-itm/ChangeLog
index e021c395ce37..2fef47c78957 100644
--- a/sci-misc/gt-itm/ChangeLog
+++ b/sci-misc/gt-itm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/gt-itm
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gt-itm/ChangeLog,v 1.4 2007/02/09 05:26:57 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gt-itm/ChangeLog,v 1.5 2009/09/28 22:00:09 robbat2 Exp $
+
+ 28 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> gt-itm-19961004.ebuild:
+ Fixup to more modern standards, and confirmed to build against amd64 as
+ well.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sci-misc/gt-itm/gt-itm-19961004.ebuild b/sci-misc/gt-itm/gt-itm-19961004.ebuild
index 88a048752cf1..29db9fffb1c5 100644
--- a/sci-misc/gt-itm/gt-itm-19961004.ebuild
+++ b/sci-misc/gt-itm/gt-itm-19961004.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gt-itm/gt-itm-19961004.ebuild,v 1.2 2005/08/24 16:45:23 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gt-itm/gt-itm-19961004.ebuild,v 1.3 2009/09/28 22:00:09 robbat2 Exp $
DESCRIPTION="A collection of routines to generate and analyze graphs using a wide variety of models for internetwork topology"
HOMEPAGE="http://www.cc.gatech.edu/fac/Ellen.Zegura/graphs.html
@@ -10,7 +10,7 @@ SRC_URI="http://www.cc.gatech.edu/fac/Ellen.Zegura/gt-itm/gt-itm.tar.gz
LICENSE="as-is BSD"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE=""
DEPEND="dev-util/sgb"
@@ -20,36 +20,36 @@ S2="${WORKDIR}/sgb2ns"
src_unpack() {
unpack sgb2ns.tar.gz
- mkdir ${S}
- cd ${S}
+ mkdir "${S}"
+ cd "${S}"
unpack gt-itm.tar.gz
- sed -r -e '/^[[:alnum:]]+\.o:/d' -e 's|LIBS = -lm -lgb.*|LIBS = -lm -lgb|' -i ${S}/src/Makefile
+ sed -r -e '/^[[:alnum:]]+\.o:/d' -e 's|LIBS = -lm -lgb.*|LIBS = -lm -lgb|' -i "${S}"/src/Makefile
sed -r -e '/^SYS = -DSYSV/d' -e 's|LIBS = -lm -lgb.*|LIBS = -lm -lgb|' -i ${S2}/Makefile || die
- rm -f ${S}/lib/*
+ rm -f "${S}"/lib/*
- find ${S}/sample-graphs/ -perm +111 -type f -name 'Run*' \
+ find "${S}"/sample-graphs/ -perm +111 -type f -name 'Run*' \
| xargs -r -n1 sed -re 's|(\.\./)+bin/||g' -i || die
- sed -e 's|sys/types.h|sys/param.h|' -i ${S}/src/geog.c
- sed -e '162 s/connected $/connected \\/' -i ${S}/src/eval.c
+ sed -e 's|sys/types.h|sys/param.h|' -i "${S}"/src/geog.c
+ sed -e '162 s/connected $/connected \\/' -i "${S}"/src/eval.c
}
src_compile() {
- cd ${S}/src
+ cd "${S}"/src
emake CFLAGS="${CFLAGS} -I../include" || die
- cd ${S2}
+ cd "${S2}"
emake CFLAGS="${CFLAGS} -I\$(IDIR) -L\$(LDIR)" || die
}
src_install() {
- dobin ${S}/bin/*
- dodoc ${S}/README ${S}/docs/*
- cp -pPR ${S}/sample-graphs ${D}/usr/share/doc/${PF}
+ dobin "${S}"/bin/*
+ dodoc "${S}"/README "${S}"/docs/*
+ cp -pPR "${S}"/sample-graphs "${D}"/usr/share/doc/${PF}
- cd ${S2}
+ cd "${S2}"
dodoc *.tcl *.gb
newdoc README README.sgb2ns