summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-07-21 08:12:51 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-07-21 08:12:51 +0000
commiteb8a5ebcd42118ab769fa0d5e83df97c6dc8a49c (patch)
treee110857dc4529684054dcbb3cc3021cd2a964864 /sci-misc
parentFix compilation with glibc-2.10, bug 273988 (diff)
downloadgentoo-2-eb8a5ebcd42118ab769fa0d5e83df97c6dc8a49c.tar.gz
gentoo-2-eb8a5ebcd42118ab769fa0d5e83df97c6dc8a49c.tar.bz2
gentoo-2-eb8a5ebcd42118ab769fa0d5e83df97c6dc8a49c.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/gri/ChangeLog7
-rw-r--r--sci-misc/gri/gri-2.12.19.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/sci-misc/gri/ChangeLog b/sci-misc/gri/ChangeLog
index c76a8360a8a7..5e95d45c2eda 100644
--- a/sci-misc/gri/ChangeLog
+++ b/sci-misc/gri/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/gri
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/ChangeLog,v 1.26 2009/02/13 20:52:35 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/ChangeLog,v 1.27 2009/07/21 08:12:51 fauli Exp $
+
+*gri-2.12.19 (21 Jul 2009)
+
+ 21 Jul 2009; Christian Faulhammer <fauli@gentoo.org> +gri-2.12.19.ebuild:
+ version bump
13 Feb 2009; Patrick Kursawe <phosphan@gentoo.org> gri-2.12.16-r1.ebuild,
gri-2.12.18.ebuild:
diff --git a/sci-misc/gri/gri-2.12.19.ebuild b/sci-misc/gri/gri-2.12.19.ebuild
new file mode 100644
index 000000000000..26457e0d4c1d
--- /dev/null
+++ b/sci-misc/gri/gri-2.12.19.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/gri-2.12.19.ebuild,v 1.1 2009/07/21 08:12:51 fauli Exp $
+
+EAPI=2
+
+inherit eutils elisp-common
+
+DESCRIPTION="language for scientific graphics programming"
+HOMEPAGE="http://gri.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gri/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc emacs examples"
+RESTRICT="test"
+
+DEPEND=">=sci-libs/netcdf-3.5.0
+ virtual/latex-base
+ media-gfx/imagemagick
+ virtual/ghostscript
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}"
+
+SITEFILE="50gri-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.12.18-postscript.patch
+}
+
+src_compile() {
+ VARTEXFONTS="${T}/fonts" emake || die
+ if use emacs; then
+ elisp-compile src/*.el || die
+ fi
+}
+
+src_install() {
+ # Replace PREFIX now and correct paths in the startup message.
+ sed -e s,PREFIX/share/gri/doc/,/usr/share/doc/${P}/, -i "${S}/src/startup.msg"
+
+ einstall || die
+
+ # license text not necessary
+ rm "${D}"/usr/share/gri/doc/license.txt
+
+ # install target installs it always and in the wrong location
+ # remove it here and call elisp-install in case of USE=emacs below
+ rm -rf "${D}"/usr/share/emacs
+
+ if ! use doc; then
+ sed -e "s/Manual at.*//" -i "${D}"/usr/share/gri/startup.msg
+ rm "${D}"/usr/share/gri/doc/cmdrefcard.ps
+ rm "${D}"/usr/share/gri/doc/refcard.ps
+ rm -rf "${D}"/usr/share/gri/doc/html
+ fi
+ if ! use examples; then
+ sed -e "s/Examples at.*//" -i "${D}"/usr/share/gri/startup.msg
+ rm -rf "${D}"/usr/share/gri/doc/examples
+ fi
+
+ dodoc README
+
+ #move docs to the proper place
+ mv "${D}"/usr/share/gri/doc/* "${D}/usr/share/doc/${PF}"
+ rmdir "${D}/usr/share/gri/doc/"
+
+ if use emacs; then
+ cd src
+ elisp-install ${PN} *.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}