summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-10-18 04:55:28 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-10-18 04:55:28 +0000
commitdcaef3c29ca3e1202b2c1331dda09dadeefc44ec (patch)
tree9e6808b5f2623e0ed45a02ad7477f04be4b5c127 /sci-physics/abinit
parentStable x86; checksums in wx..what's next, latex in wx (diff)
downloadgentoo-2-dcaef3c29ca3e1202b2c1331dda09dadeefc44ec.tar.gz
gentoo-2-dcaef3c29ca3e1202b2c1331dda09dadeefc44ec.tar.bz2
gentoo-2-dcaef3c29ca3e1202b2c1331dda09dadeefc44ec.zip
Bump. This is the first release in the 5.x series officially considered ready for production use.
(Portage version: 2.1.2_pre3-r2)
Diffstat (limited to 'sci-physics/abinit')
-rw-r--r--sci-physics/abinit/ChangeLog10
-rw-r--r--sci-physics/abinit/abinit-5.2.3.ebuild102
-rw-r--r--sci-physics/abinit/files/5.2.3-change-default-directories.patch24
-rw-r--r--sci-physics/abinit/files/5.2.3-fix-64bit-detection.patch12
-rw-r--r--sci-physics/abinit/files/digest-abinit-5.2.33
5 files changed, 150 insertions, 1 deletions
diff --git a/sci-physics/abinit/ChangeLog b/sci-physics/abinit/ChangeLog
index 8a0d4bf2841b..a4fe94051886 100644
--- a/sci-physics/abinit/ChangeLog
+++ b/sci-physics/abinit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-physics/abinit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/ChangeLog,v 1.4 2006/07/30 16:28:23 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/ChangeLog,v 1.5 2006/10/18 04:55:28 dberkholz Exp $
+
+*abinit-5.2.3 (18 Oct 2006)
+
+ 18 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/5.2.3-fix-64bit-detection.patch,
+ +files/5.2.3-change-default-directories.patch, +abinit-5.2.3.ebuild:
+ Bump. This is the first release in the 5.x series officially considered
+ ready for production use.
07 Jul 2006; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Update to my new email address.
diff --git a/sci-physics/abinit/abinit-5.2.3.ebuild b/sci-physics/abinit/abinit-5.2.3.ebuild
new file mode 100644
index 000000000000..f60412591754
--- /dev/null
+++ b/sci-physics/abinit/abinit-5.2.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-5.2.3.ebuild,v 1.1 2006/10/18 04:55:28 dberkholz Exp $
+
+inherit fortran toolchain-funcs
+
+DESCRIPTION="Find total energy, charge density and electronic structure using density functional theory"
+HOMEPAGE="http://www.abinit.org/"
+SRC_URI="ftp://ftp.abinit.org/pub/abinitio/ABINIT_v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+#IUSE="mpi netcdf test"
+IUSE="mpi test"
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+# Doesn't build with 4.1-20060210
+# netcdf? ( sci-libs/netcdf )
+DEPEND="${RDEPEND}"
+
+# F90 code, g77 won't work
+FORTRAN="gfortran ifc"
+
+pkg_setup() {
+ fortran_pkg_setup
+
+ # Doesn't compile with gcc-4.0, only >=4.1
+ local diemsg="Requires gcc-4.1 or newer"
+ if [[ "${FORTRANC}" = "gfortran" ]]; then
+ if [[ $(gcc-major-version) -eq 4 ]] \
+ && [[ $(gcc-minor-version) -lt 1 ]]; then
+ die "${diemsg}"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-change-default-directories.patch
+ epatch "${FILESDIR}"/${PV}-fix-64bit-detection.patch
+
+ # Yea for breaking compatibility with no ChangeLog entry in 2.60
+ if has_version '>=sys-devel/autoconf-2.60'; then
+ sed -i -e "s:_AC_SRCPATHS:_AC_SRCDIRS:g" config/m4/init.m4
+ fi
+
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-install-type=debian \
+ --disable-config-file \
+ --disable-library-search \
+ $(use_enable mpi) \
+ --with-blas-prefix=/usr \
+ --with-lapack-prefix=/usr \
+ --with-c-optflags="${CFLAGS}" \
+ --with-fortran-optflags="${FFLAGS}" \
+ --with-fortran-ldflags='-lpthread' \
+ FC="${FORTRANC}" \
+ CC="$(tc-getCC)" \
+ || die "configure failed"
+# $(use_enable netcdf) \
+
+ emake || die "make failed"
+}
+
+src_test() {
+ einfo "The tests take quite a while, on the order of 2-3 hours"
+ einfo "on a dual Athlon 2000+."
+ cd "${S}"/tests
+ emake tests_dev
+
+ local REPORT
+ for REPORT in $(find . -name *fl*); do
+ elog "Results for ${REPORT%%/*} tests"
+ while read line; do
+ elog "${line}"
+ done \
+ < <(cat ${REPORT} )
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use test; then
+ dodoc tests/summary_tests.tar.gz
+ fi
+
+ dodoc KNOWN_PROBLEMS README
+}
+
+pkg_postinst() {
+ if use test; then
+ elog "The test results will be installed as summary_tests.tar.gz."
+ fi
+}
diff --git a/sci-physics/abinit/files/5.2.3-change-default-directories.patch b/sci-physics/abinit/files/5.2.3-change-default-directories.patch
new file mode 100644
index 000000000000..e5350661f702
--- /dev/null
+++ b/sci-physics/abinit/files/5.2.3-change-default-directories.patch
@@ -0,0 +1,24 @@
+diff -urN abinit-5.2.3.orig/config/m4/init.m4 abinit-5.2.3/config/m4/init.m4
+--- abinit-5.2.3.orig/config/m4/init.m4 2006-10-17 21:09:23.000000000 -0700
++++ abinit-5.2.3/config/m4/init.m4 2006-10-17 21:09:12.000000000 -0700
+@@ -197,9 +197,9 @@
+
+ debian)
+ abinit_prefix="/usr"
+- abinit_bindir="/usr/lib/abinit/${ABINIT_VERSION_BASE}/bin"
++ abinit_bindir="/usr/bin"
+ abinit_datdir="/usr/share/abinit"
+- abinit_docdir="/usr/share/doc/abinit/${ABINIT_VERSION_BASE}"
++ abinit_docdir="/usr/share/doc/abinit-${ABINIT_VERSION_BASE}"
+ abinit_libdir="/usr/lib/abinit/${ABINIT_VERSION_BASE}/lib"
+ abinit_incdir="/usr/include/abinit/${ABINIT_VERSION_BASE}"
+ abinit_mandir="/usr/share/man"
+@@ -299,7 +299,7 @@
+ fi
+ ABINIT_VERSION_BUILD=`date '+%Y%m%d'`
+
+- ABINIT_VERSION_BASE="${ABINIT_VERSION_MAJOR}.${ABINIT_VERSION_MINOR}"
++ ABINIT_VERSION_BASE="${ABINIT_VERSION_MAJOR}.${ABINIT_VERSION_MINOR}.${ABINIT_VERSION_MICRO}"
+
+ dnl Make numbers available to source files
+ AC_DEFINE_UNQUOTED(ABINIT_VERSION,"${ABINIT_VERSION}",
diff --git a/sci-physics/abinit/files/5.2.3-fix-64bit-detection.patch b/sci-physics/abinit/files/5.2.3-fix-64bit-detection.patch
new file mode 100644
index 000000000000..baa6d38b369f
--- /dev/null
+++ b/sci-physics/abinit/files/5.2.3-fix-64bit-detection.patch
@@ -0,0 +1,12 @@
+diff -urN abinit-5.2.3.orig/config/m4/init.m4 abinit-5.2.3/config/m4/init.m4
+--- abinit-5.2.3.orig/config/m4/init.m4 2006-10-17 21:05:17.000000000 -0700
++++ abinit-5.2.3/config/m4/init.m4 2006-10-17 21:07:10.000000000 -0700
+@@ -39,7 +39,7 @@
+ alpha*|powerpc*)
+ abi_cpu_model="${target_cpu}"
+ abi_cpu_64bits=`echo "${abi_cpu_model}" | grep '64$'`
+- if test abi_cpu_64bits = ""; then
++ if test "${abi_cpu_64bits}" = ""; then
+ abi_cpu_64bits="no"
+ abi_cpu_bits="32"
+ else
diff --git a/sci-physics/abinit/files/digest-abinit-5.2.3 b/sci-physics/abinit/files/digest-abinit-5.2.3
new file mode 100644
index 000000000000..8d7ab4b83fed
--- /dev/null
+++ b/sci-physics/abinit/files/digest-abinit-5.2.3
@@ -0,0 +1,3 @@
+MD5 cef5eddf687dfaf8fc1b548c61456991 abinit-5.2.3.tar.gz 21074280
+RMD160 efc2b86ef7c800c1d63801b751e6d8b5272903ac abinit-5.2.3.tar.gz 21074280
+SHA256 9ea727cc45b97f1d3a65d4739792cc37abaf762aba118b26183e900a9eab3fe6 abinit-5.2.3.tar.gz 21074280