summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-02 13:51:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-02 13:51:50 +0000
commit544fbfad764dc909fad62c6ca7fe27d318b3fa07 (patch)
tree03a34056ec9e0803846326eec80a02aa65a46e87 /sci-physics/camfr
parentPass --with-default-audiosink=autoaudiosink and --with-default-visualizer=goo... (diff)
downloadgentoo-2-544fbfad764dc909fad62c6ca7fe27d318b3fa07.tar.gz
gentoo-2-544fbfad764dc909fad62c6ca7fe27d318b3fa07.tar.bz2
gentoo-2-544fbfad764dc909fad62c6ca7fe27d318b3fa07.zip
Added gcc-4.3 patch, make it blas/lapack implementation more independent, run tests without X (close bug #229753) and some dep cleaning
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics/camfr')
-rw-r--r--sci-physics/camfr/ChangeLog7
-rw-r--r--sci-physics/camfr/camfr-20070717.ebuild45
-rw-r--r--sci-physics/camfr/files/camfr-20070717-gcc43.patch12
3 files changed, 46 insertions, 18 deletions
diff --git a/sci-physics/camfr/ChangeLog b/sci-physics/camfr/ChangeLog
index cdfeac2a8079..eec5f806f443 100644
--- a/sci-physics/camfr/ChangeLog
+++ b/sci-physics/camfr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/camfr
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.7 2008/05/05 21:55:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.8 2008/07/02 13:51:49 bicatali Exp $
+
+ 02 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/camfr-20070717-gcc43.patch, camfr-20070717.ebuild:
+ Added gcc-4.3 patch, make it blas/lapack implementation more independent,
+ run tests without X (close bug #229753) and some dep cleaning
05 May 2008; Sébastien Fabbro <bicatali@gentoo.org> -files/SConstruct,
-files/machine_cfg.py, -files/throw_patch.diff, -camfr-1.2.ebuild:
diff --git a/sci-physics/camfr/camfr-20070717.ebuild b/sci-physics/camfr/camfr-20070717.ebuild
index 26a7199baeaf..363439298a1c 100644
--- a/sci-physics/camfr/camfr-20070717.ebuild
+++ b/sci-physics/camfr/camfr-20070717.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717.ebuild,v 1.1 2007/08/21 20:39:12 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717.ebuild,v 1.2 2008/07/02 13:51:49 bicatali Exp $
-inherit eutils distutils fortran python
+inherit eutils distutils fortran
DESCRIPTION="Full vectorial Maxwell solver based on eigenmode expansion"
HOMEPAGE="http://camfr.sourceforge.net/"
@@ -13,44 +13,55 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="virtual/python
- dev-python/numpy
- sci-libs/scipy
- >=dev-python/matplotlib-0.90.1
- >=dev-libs/boost-1.30.2
- >=dev-python/imaging-1.1.4
+RDEPEND="sci-libs/scipy
+ dev-python/matplotlib
+ dev-libs/boost
dev-libs/blitz
+ dev-python/imaging
virtual/lapack"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
dev-util/scons"
-FORTAN="gfortran g77"
-
-S=${WORKDIR}/${P/-/_}
+S="${WORKDIR}/${P/-/_}"
pkg_setup() {
- if ! built_with_use dev-lang/python tk \
- || ! built_with_use dev-python/imaging tk ; then
+ if ! built_with_use dev-lang/python tk || \
+ ! built_with_use dev-python/imaging tk ; then
eerror "Python and/or imaging don't have Tk support enabled."
eerror "Set the tk USE flag and reinstall python and imaging before continuing."
die
fi
+ FORTRAN="gfortran g77 ifc"
fortran_pkg_setup
}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
cp machine_cfg.py{.gentoo,} || die
+ sed -i -e '/^library_dirs/d' -e '/^libs/d' machine_cfg.py || die
+ local lapack_libs=
+ for x in $(pkg-config --libs-only-l lapack); do
+ lapack_libs="${lapack_libs}, \"${x/-l/}\""
+ done
+ cat <<-EOF >> machine_cfg.py
+ library_dirs = ["$(pkg-config --libs-only-L lapack | sed -e 's/-L/')"]
+ libs = ["boost_python", "blitz"${lapack_libs}]
+ EOF
}
src_test() {
- PYTHONPATH=.:visualisation ${python} testsuite/camfr_test.py \
- || die "tests failed"
+ # trick to avoid X in testing (bug #229753)
+ echo "backend : Agg" > matplotlibrc
+ PYTHONPATH=".:visualisation" ${python} testsuite/camfr_test.py \
+qq || die "tests failed"
+ rm -f matplotlibrc
}
src_install() {
distutils_src_install
- dodoc docs/camfr.pdf || die
+ dodoc docs/camfr.pdf || die "doc install failed"
}
diff --git a/sci-physics/camfr/files/camfr-20070717-gcc43.patch b/sci-physics/camfr/files/camfr-20070717-gcc43.patch
new file mode 100644
index 000000000000..dd10cc25bdaa
--- /dev/null
+++ b/sci-physics/camfr/files/camfr-20070717-gcc43.patch
@@ -0,0 +1,12 @@
+--- camfr/primitives/section/sectiondisp.cpp~ 2007-07-18 09:48:46.000000000 +0100
++++ camfr/primitives/section/sectiondisp.cpp 2008-07-02 11:18:24.000000000 +0100
+@@ -20,7 +20,8 @@
+ using std::cout;
+ using std::cerr;
+ using std::endl;
+-
++#include <complex>
++using std::abs;
+ #include "../../util/vectorutil.h"
+
+ /////////////////////////////////////////////////////////////////////////////