summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2014-01-06 02:12:07 +0000
committerBenda XU <heroxbd@gentoo.org>2014-01-06 02:12:07 +0000
commit82632921cd7e6fcbcc10ad2fb415f6541e9e2823 (patch)
tree0e69808d147e5a676bc2de51f07569adfcd73808 /sci-physics/geant
parentEAPI bump. (diff)
downloadgentoo-2-82632921cd7e6fcbcc10ad2fb415f6541e9e2823.tar.gz
gentoo-2-82632921cd7e6fcbcc10ad2fb415f6541e9e2823.tar.bz2
gentoo-2-82632921cd7e6fcbcc10ad2fb415f6541e9e2823.zip
backport upstream SetNavigatorForTracking inline function fix, credits Oliver Freyermuth for reporting bug 496678
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-physics/geant')
-rw-r--r--sci-physics/geant/ChangeLog9
-rw-r--r--sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch60
-rw-r--r--sci-physics/geant/geant-4.10.00.ebuild8
3 files changed, 72 insertions, 5 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 0457303f8142..4f6cc11e91e7 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/geant
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.77 2013/12/20 06:07:41 heroxbd Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.78 2014/01/06 02:12:06 heroxbd Exp $
+
+ 06 Jan 2014; Benda Xu <heroxbd@gentoo.org>
+ +files/geant-4.10.0-TrackingNavigator.patch, geant-4.10.00.ebuild:
+ backport upstream SetNavigatorForTracking inline function fix, credits Oliver
+ Freyermuth for reporting bug 496678
*geant-4.10.00 (20 Dec 2013)
diff --git a/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch b/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch
new file mode 100644
index 000000000000..e3cc8d6594a5
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch
@@ -0,0 +1,60 @@
+accepted upstream. to be removed in the next minor release.
+
+https://bugs.gentoo.org/show_bug.cgi?id=496678
+http://bugzilla-geant4.kek.jp/show_bug.cgi?id=1537
+
+diff -Naur geant4.10.00/source/geometry/navigation/include/G4TransportationManager.hh geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.hh
+--- geant4.10.00/source/geometry/navigation/include/G4TransportationManager.hh 2013-12-05 10:28:54.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.hh 2013-12-12 01:40:12.341428809 +0100
+@@ -68,7 +68,7 @@
+ // Accessors for field handling
+
+ inline G4Navigator* GetNavigatorForTracking() const;
+- inline void SetNavigatorForTracking( G4Navigator* newNavigator );
++ void SetNavigatorForTracking( G4Navigator* newNavigator );
+ // Accessors for the navigator for tracking
+
+ inline void SetWorldForTracking(G4VPhysicalVolume* theWorld);
+diff -Naur geant4.10.00/source/geometry/navigation/include/G4TransportationManager.icc geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.icc
+--- geant4.10.00/source/geometry/navigation/include/G4TransportationManager.icc 2013-12-05 10:28:54.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.icc 2013-12-12 01:40:12.341428809 +0100
+@@ -59,6 +59,7 @@
+ fNavigators[0]->SetWorldVolume(theWorld);
+ }
+
++/*
+ // ----------------------------------------------------------------------------
+ // SetNavigatorForTracking()
+ //
+@@ -70,6 +71,7 @@
+ {
+ fNavigators[0] = newNavigator;
+ }
++*/
+
+ // ----------------------------------------------------------------------------
+ // GetPropagatorInField()
+diff -Naur geant4.10.00/source/geometry/navigation/src/G4TransportationManager.cc geant4.10.00-mod/source/geometry/navigation/src/G4TransportationManager.cc
+--- geant4.10.00/source/geometry/navigation/src/G4TransportationManager.cc 2013-12-05 10:28:56.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/src/G4TransportationManager.cc 2013-12-12 01:40:12.345428679 +0100
+@@ -124,6 +124,20 @@
+ }
+ }
+
++
++// ----------------------------------------------------------------------------
++// SetNavigatorForTracking()
++//
++// Set the active navigator for tracking, always
++// the first in the collection of registered navigators.
++//
++void G4TransportationManager::SetNavigatorForTracking(G4Navigator* newNavigator)
++{
++ fNavigators[0] = newNavigator;
++ fActiveNavigators[0] = newNavigator;
++ fPropagatorInField->SetNavigatorForPropagating(newNavigator);
++}
++
+ // ----------------------------------------------------------------------------
+ // ClearNavigators()
+ //
diff --git a/sci-physics/geant/geant-4.10.00.ebuild b/sci-physics/geant/geant-4.10.00.ebuild
index a6001415687b..227daa95f8ba 100644
--- a/sci-physics/geant/geant-4.10.00.ebuild
+++ b/sci-physics/geant/geant-4.10.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.10.00.ebuild,v 1.1 2013/12/20 06:07:41 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.10.00.ebuild,v 1.2 2014/01/06 02:12:06 heroxbd Exp $
EAPI=5
@@ -40,7 +40,9 @@ PDEPEND="
S="${WORKDIR}/${MYP}"
-PATCHES=( "${FILESDIR}"/${PN}-4.10.0-no-examples.patch )
+PATCHES=( "${FILESDIR}"/${PN}-4.10.0-no-examples.patch
+ "${FILESDIR}"/${PN}-4.10.0-TrackingNavigator.patch # 496678
+ )
src_configure() {
local mycmakeargs=(