summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-14 08:12:45 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-14 08:12:45 +0000
commit29d14ec4599642b8fbf414c19a9b3163619f39ce (patch)
treea12dceae5c5af94a1f698ec36e7b70f4ebc99739 /sci-physics/hepmc
parentImport from sunrise, I will proxy flow in this case. (diff)
downloadgentoo-2-29d14ec4599642b8fbf414c19a9b3163619f39ce.tar.gz
gentoo-2-29d14ec4599642b8fbf414c19a9b3163619f39ce.tar.bz2
gentoo-2-29d14ec4599642b8fbf414c19a9b3163619f39ce.zip
Fix for compilation with gcc-4.6, #363539
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/ChangeLog6
-rw-r--r--sci-physics/hepmc/files/hepmc-2.06.04-gcc46.patch28
-rw-r--r--sci-physics/hepmc/hepmc-2.06.03.ebuild7
-rw-r--r--sci-physics/hepmc/hepmc-2.06.04.ebuild15
4 files changed, 49 insertions, 7 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
index 44d1e0044d2d..baf35b597980 100644
--- a/sci-physics/hepmc/ChangeLog
+++ b/sci-physics/hepmc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/hepmc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.25 2011/02/18 17:10:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.26 2011/04/14 08:12:45 jlec Exp $
+
+ 14 Apr 2011; Justin Lecher <jlec@gentoo.org> hepmc-2.06.03.ebuild,
+ hepmc-2.06.04.ebuild, +files/hepmc-2.06.04-gcc46.patch:
+ Fix for compilation with gcc-4.6, #363539
18 Feb 2011; Jeroen Roovers <jer@gentoo.org> hepmc-2.06.03.ebuild:
Stable for HPPA (bug #354011).
diff --git a/sci-physics/hepmc/files/hepmc-2.06.04-gcc46.patch b/sci-physics/hepmc/files/hepmc-2.06.04-gcc46.patch
new file mode 100644
index 000000000000..9b19cf70ba9a
--- /dev/null
+++ b/sci-physics/hepmc/files/hepmc-2.06.04-gcc46.patch
@@ -0,0 +1,28 @@
+ HepMC/GenEvent.h | 1 +
+ HepMC/GenVertex.h | 1 +
+ 2 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/HepMC/GenEvent.h b/HepMC/GenEvent.h
+index 72374cb..d10b9a0 100644
+--- a/HepMC/GenEvent.h
++++ b/HepMC/GenEvent.h
+@@ -137,6 +137,7 @@ namespace HepMC {
+ #include <vector>
+ #include <algorithm>
+ #include <iostream>
++#include <cstddef>
+
+ namespace HepMC {
+
+diff --git a/HepMC/GenVertex.h b/HepMC/GenVertex.h
+index 2f3d4de..fc3bf63 100644
+--- a/HepMC/GenVertex.h
++++ b/HepMC/GenVertex.h
+@@ -29,6 +29,7 @@
+ #include <vector>
+ #include <set>
+ #include <algorithm>
++#include <cstddef>
+
+ namespace HepMC {
+
diff --git a/sci-physics/hepmc/hepmc-2.06.03.ebuild b/sci-physics/hepmc/hepmc-2.06.03.ebuild
index cab77f156926..c00e70239c98 100644
--- a/sci-physics/hepmc/hepmc-2.06.03.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.03.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.03.ebuild,v 1.6 2011/02/18 17:10:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.03.ebuild,v 1.7 2011/04/14 08:12:45 jlec Exp $
EAPI=2
+inherit eutils
+
MYP=HepMC-${PV}
DESCRIPTION="Event Record for Monte Carlo Generators"
@@ -21,6 +23,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.06.04-gcc46.patch
+}
src_configure() {
# use MeV over GeV and mm over cm
local length_conf="MM"
diff --git a/sci-physics/hepmc/hepmc-2.06.04.ebuild b/sci-physics/hepmc/hepmc-2.06.04.ebuild
index 4a19abdd3756..0df6948e492f 100644
--- a/sci-physics/hepmc/hepmc-2.06.04.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.04.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.04.ebuild,v 1.2 2011/02/13 17:36:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.04.ebuild,v 1.3 2011/04/14 08:12:45 jlec Exp $
-EAPI=3
+EAPI=4
+
+inherit eutils
MYP=HepMC-${PV}
@@ -21,6 +23,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+}
+
src_configure() {
# use MeV over GeV and mm over cm
local length_conf="MM"
@@ -34,7 +40,7 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ emake
if use doc; then
cd doc
doxygen doxygen.conf || die "doc building failed"
@@ -46,9 +52,8 @@ src_install() {
DESTDIR="${ED}" \
INSTALLDIR="${EPREFIX}/usr/share/doc/${PF}/examples" \
doc_installdir="${EPREFIX}/usr/share/doc/${PF}" \
- install || die "emake install failed"
+ install
- dodoc README AUTHORS ChangeLog
insinto /usr/share/doc/${PF}
if use doc; then
doins -r doc/html doc/*.pdf || die