summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-11-20 08:25:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-11-20 08:25:12 +0000
commitd4308b15d300a9fd03c38baddbab1e001c0f68d4 (patch)
tree3bca1d201c2edc33b38a293560dcf7aca24e6994 /sci-physics/pythia
parentVersion bump (diff)
downloadgentoo-2-d4308b15d300a9fd03c38baddbab1e001c0f68d4.tar.gz
gentoo-2-d4308b15d300a9fd03c38baddbab1e001c0f68d4.tar.bz2
gentoo-2-d4308b15d300a9fd03c38baddbab1e001c0f68d4.zip
Version bumps
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/pythia')
-rw-r--r--sci-physics/pythia/ChangeLog9
-rw-r--r--sci-physics/pythia/pythia-6.4.24.ebuild69
-rw-r--r--sci-physics/pythia/pythia-8.1.45.ebuild90
3 files changed, 167 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 1464c85be8c5..5d2c133d9705 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.31 2010/08/26 16:28:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.32 2010/11/20 08:25:12 bicatali Exp $
+
+*pythia-8.1.45 (20 Nov 2010)
+*pythia-6.4.24 (20 Nov 2010)
+
+ 20 Nov 2010; Sébastien Fabbro <bicatali@gentoo.org> +pythia-6.4.24.ebuild,
+ +pythia-8.1.45.ebuild:
+ Version bumps
*pythia-8.1.42 (26 Aug 2010)
diff --git a/sci-physics/pythia/pythia-6.4.24.ebuild b/sci-physics/pythia/pythia-6.4.24.ebuild
new file mode 100644
index 000000000000..7716c5227b3d
--- /dev/null
+++ b/sci-physics/pythia/pythia-6.4.24.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.24.ebuild,v 1.1 2010/11/20 08:25:12 bicatali Exp $
+
+EAPI=2
+inherit versionator autotools
+
+MV=$(get_major_version)
+MY_PN=${PN}${MV}
+DOC_PV=0613
+EX_PV=6.4.18
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://projects.hepforge.org/pythia6/"
+
+# pythia6 from root is needed for some files to interface pythia6 with root.
+# To produce a split version on mirror do, replace the 6.4.x by the current version
+# svn export http://svn.hepforge.org/pythia6/tags/v_6_4_x/ pythia-6.4.x
+# tar cjf pythia-6.4.x.tar.bz2
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ ftp://root.cern.ch/root/pythia6.tar.gz
+ doc? ( http://home.thep.lu.se/~torbjorn/pythia/lutp${DOC_PV}man2.pdf )
+ examples? ( mirror://gentoo/${PN}-${EX_PV}-examples.tar.bz2 )"
+
+LICENSE="public-domain"
+SLOT="6"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples static-libs"
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp ../pythia6/tpythia6_called_from_cc.F .
+ cp ../pythia6/pythia6_common_address.c .
+ cat > configure.ac <<-EOF
+ AC_INIT(${PN},${PV})
+ AM_INIT_AUTOMAKE
+ AC_PROG_F77
+ AC_PROG_LIBTOOL
+ AC_CHECK_LIB(m,sqrt)
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ echo >> Makefile.am "lib_LTLIBRARIES = libpythia6.la"
+ echo >> Makefile.am "libpythia6_la_SOURCES = \ "
+ # replace wildcard from makefile to ls in shell
+ for f in py*.f struct*.f up*.f fh*.f; do
+ echo >> Makefile.am " ${f} \\"
+ done
+ echo >> Makefile.am " ssmssm.f sugra.f visaje.f pdfset.f \\"
+ echo >> Makefile.am " tpythia6_called_from_cc.F pythia6_common_address.c"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc update_notes.txt README
+ insinto /usr/share/doc/${PF}/
+ if use doc; then
+ doins "${DISTDIR}"/lutp${DOC_PV}man2.pdf || die
+ fi
+ if use examples; then
+ doins -r "${WORKDIR}"/examples || die
+ fi
+}
diff --git a/sci-physics/pythia/pythia-8.1.45.ebuild b/sci-physics/pythia/pythia-8.1.45.ebuild
new file mode 100644
index 000000000000..df37efcf3c07
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.45.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.45.ebuild,v 1.1 2010/11/20 08:25:12 bicatali Exp $
+
+EAPI=2
+
+inherit eutils versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples +hepmc static-libs"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION=/usr
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk
+ cat > config.mk <<-EOF
+ SHAREDLIBS = yes
+ LDFLAGSSHARED = -shared ${LDFLAGS}
+ LDFLAGLIBNAME = -Wl,-soname
+ SHAREDSUFFIX = so
+ EOF
+ if ! use static-libs; then
+ sed -i \
+ -e '/targets.*\.a/d' \
+ -e 's/+=\(.*libpythia8\)/=\1/' \
+ Makefile || die
+ sed -i \
+ -e 's:\.a:\.so:g' \
+ -e 's:$(LIBDIRARCH):$(LIBDIR):g' \
+ examples/Makefile || die
+ fi
+}
+
+src_test() {
+ cd "${S}"/examples
+ # use emake for parallel instead of long runmains
+ emake \
+ $(ls main0{1..9}*.cc | sed -e 's/.cc//') \
+ || die "emake tests failed"
+ for i in main0{1..9}*.exe; do
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31 main32 || die "emake tests for hepmc failed"
+ ./main31.exe > main31.exe.out || die
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so || die "shared lib install failed"
+ if use static-libs; then
+ dolib.a lib/archive/* || die "static lib install failed"
+ fi
+
+ insinto /usr/include/${PN}
+ doins include/* || die "headers install failed"
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc || die "xmldoc install failed"
+ echo PYTHIA8DATA=/usr/share/${PN}/xmldoc >> 99pythia8
+ doenvd 99pythia8
+
+ insinto /usr/share/doc/${PF}
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ doins worksheet.pdf || die "doc install failed"
+ mv htmldoc html
+ doins -r html || die "html doc install failed"
+ fi
+ if use examples; then
+ doins -r examples || die "examples install failed"
+ fi
+}