summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-27 18:12:33 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-27 18:12:33 +0000
commit0861e25a9114f2687c966eb00eabb90a7662533b (patch)
tree9a8946082f2646960de01a6f4592f140810a93d5 /sci-physics
parentarm stable, bug #419473 (diff)
downloadgentoo-2-0861e25a9114f2687c966eb00eabb90a7662533b.tar.gz
gentoo-2-0861e25a9114f2687c966eb00eabb90a7662533b.tar.bz2
gentoo-2-0861e25a9114f2687c966eb00eabb90a7662533b.zip
html docs are built with doxygen if doc flag is set, bug #421827, thanks Vitaly
(Portage version: 2.2.01.20430-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/ChangeLog6
-rw-r--r--sci-physics/bullet/bullet-2.80.ebuild21
2 files changed, 22 insertions, 5 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
index d9c1cca7220f..a9fdd205ac2f 100644
--- a/sci-physics/bullet/ChangeLog
+++ b/sci-physics/bullet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/bullet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.27 2012/05/22 17:28:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.28 2012/06/27 18:12:33 bicatali Exp $
+
+ 27 Jun 2012; Sebastien Fabbro <fabbros@gentoo.org> bullet-2.80.ebuild:
+ html docs are built with doxygen if doc flag is set, bug #421827, thanks
+ Vitaly
*bullet-2.80 (22 May 2012)
diff --git a/sci-physics/bullet/bullet-2.80.ebuild b/sci-physics/bullet/bullet-2.80.ebuild
index 9f22f9f12dc3..b214a9721df0 100644
--- a/sci-physics/bullet/bullet-2.80.ebuild
+++ b/sci-physics/bullet/bullet-2.80.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.80.ebuild,v 1.1 2012/05/22 17:28:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.80.ebuild,v 1.2 2012/06/27 18:12:33 bicatali Exp $
EAPI=4
@@ -15,17 +15,23 @@ SRC_URI="http://bullet.googlecode.com/files/${MYP}.tgz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc double-precision examples extras"
RDEPEND="virtual/opengl
media-libs/freeglut"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
PATCHES=( "${FILESDIR}"/${PN}-2.78-soversion.patch )
S="${WORKDIR}/${MYP}"
+src_prepare() {
+ # allow to generate docs
+ sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
+}
+
src_configure() {
mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
@@ -40,9 +46,16 @@ src_configure() {
cmake-utils_src_configure
}
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen || die
+ fi
+}
+
src_install() {
cmake-utils_src_install
- use doc && dodoc *.pdf
+ use doc && dodoc *.pdf && dohtml -r html
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins -r Extras Demos