summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:14:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:14:47 +0000
commit08907bc951abdede3279cd52f5da4072e2097ae3 (patch)
treebb8ce76d5254b6709654d744a38374ff48c0cc40 /sci-physics
parentNew series of patches from Debian, more compatible with gfortran and better t... (diff)
downloadgentoo-2-08907bc951abdede3279cd52f5da4072e2097ae3.tar.gz
gentoo-2-08907bc951abdede3279cd52f5da4072e2097ae3.tar.bz2
gentoo-2-08907bc951abdede3279cd52f5da4072e2097ae3.zip
New series of patches from Debian, more compatible with gfortran and better tests. Much ebuild cleaning.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant/ChangeLog11
-rw-r--r--sci-physics/geant/geant-3.21.14-r1.ebuild74
-rw-r--r--sci-physics/geant/metadata.xml12
3 files changed, 89 insertions, 8 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 2cf149244d09..40db7ac0fe68 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/geant
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.1 2007/08/24 21:43:26 bicatali Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.2 2008/03/11 12:14:47 bicatali Exp $
+
+*geant-3.21.14-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-3.21.14-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
*geant-3.21.14 (24 Aug 2007)
diff --git a/sci-physics/geant/geant-3.21.14-r1.ebuild b/sci-physics/geant/geant-3.21.14-r1.ebuild
new file mode 100644
index 000000000000..edb772c3eeae
--- /dev/null
+++ b/sci-physics/geant/geant-3.21.14-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-3.21.14-r1.ebuild,v 1.1 2008/03/11 12:14:47 bicatali Exp $
+
+DEB_PN=geant321
+DEB_PV=${PV}.dfsg
+DEB_PR=8
+DEB_P=${DEB_PN}_${DEB_PV}
+
+inherit eutils multilib fortran
+
+DESCRIPTION="CERN's detector description and simulation Tool"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/geant/index.html"
+
+LICENSE="GPL-2 LGPL-2 BSD"
+SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/motif
+ virtual/lapack
+ dev-lang/cfortran
+ sci-physics/cernlib
+ sci-physics/paw"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+KEYWORDS="~amd64 ~x86"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${DEB_P}-${DEB_PR}".diff
+ rm -f ${DEB_P}-${DEB_PR}.diff
+ cd "${S}"
+ cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ Makefile || "sed'ing the Makefile failed"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch || die "debian patch failed"
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h
+}
+
+src_compile() {
+ # create local LaTeX cache directory
+ mkdir -p .texmf-var
+ emake -j1 cernlib-indep cernlib-arch || die "emake failed"
+}
+
+src_test_() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"/debian
+ dodoc changelog README.* deadpool.txt NEWS copyright || die "dodoc failed"
+ newdoc add-ons/README README.add-ons || die "newdoc failed"
+}
diff --git a/sci-physics/geant/metadata.xml b/sci-physics/geant/metadata.xml
index 54e13262758b..513adf0f9ef8 100644
--- a/sci-physics/geant/metadata.xml
+++ b/sci-physics/geant/metadata.xml
@@ -3,11 +3,11 @@
<pkgmetadata>
<herd>sci-physics</herd>
<longdescription lang="en">
-Geant simulates the passage of subatomic particles through matter, for
-instance, particle detectors. For maximum flexibility, Geant
-simulations are performed by linking Fortran code supplied by the user
-with the Geant libraries, then running the resulting executable.
-
-This package includes gxint, the script used to perform this linking step.
+ Geant simulates the passage of subatomic particles through matter, for
+ instance, particle detectors. For maximum flexibility, Geant
+ simulations are performed by linking Fortran code supplied by the user
+ with the Geant libraries, then running the resulting executable.
+
+ This package includes gxint, the script used to perform this linking step.
</longdescription>
</pkgmetadata>