summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-14 01:53:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-14 01:53:05 +0000
commit35b7fb1371b038dabfd3092f94558b69d1aad1c8 (patch)
treee7c18f1eca6f7c43cf3d54d4f9d8a236f6564324 /sci-physics
parentRemove old. (diff)
downloadgentoo-2-35b7fb1371b038dabfd3092f94558b69d1aad1c8.tar.gz
gentoo-2-35b7fb1371b038dabfd3092f94558b69d1aad1c8.tar.bz2
gentoo-2-35b7fb1371b038dabfd3092f94558b69d1aad1c8.zip
Version bump, and switching to cmake. Libraries have names with first letter upcase. Removed threads flag since only use (an autodetected) for PS3
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/ChangeLog9
-rw-r--r--sci-physics/bullet/bullet-2.75.ebuild54
2 files changed, 62 insertions, 1 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
index 0c315cd8870f..18afa8897a3a 100644
--- a/sci-physics/bullet/ChangeLog
+++ b/sci-physics/bullet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/bullet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.7 2009/06/24 04:59:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.8 2009/09/14 01:53:05 bicatali Exp $
+
+*bullet-2.75 (14 Sep 2009)
+
+ 14 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org> +bullet-2.75.ebuild:
+ Version bump, and switching to cmake. Libraries have names with first
+ letter upcase. Removed threads flag since only use (an autodetected) for
+ PS3
24 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org> bullet-2.74.ebuild,
+files/bullet-2.74-missing-header.patch:
diff --git a/sci-physics/bullet/bullet-2.75.ebuild b/sci-physics/bullet/bullet-2.75.ebuild
new file mode 100644
index 000000000000..c5c4a4019fad
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.75.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.75.ebuild,v 1.1 2009/09/14 01:53:05 bicatali Exp $
+
+EAPI=2
+inherit eutils cmake-utils
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.bulletphysics.com/"
+SRC_URI="http://bullet.googlecode.com/files/${P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="virtual/glut"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ rm -f Extras/CDTestFramework/AntTweakBar/lib/libAntTweakBar.so
+ sed -i \
+ -e 's:DESTINATION lib:DESTINATION lib${LIB_SUFFIX}:g' \
+ src/*/CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs="
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_DEMOS=OFF
+ -DBUILD_EXTRAS=OFF"
+ cmake-utils_src_configure
+ sed -e 's|@prefix@|${ROOT}usr|' \
+ -e 's|@exec_prefix@|${prefix}|' \
+ -e "s|@libdir@|\${exec_prefix}/$(get_libdir)|" \
+ -e "s|@PACKAGE_VERSION@|${PV}|" \
+ -e 's|Libs:.*$|Libs:-L${libdir} -lBulletDynamics -lBulletCollision -lLinearMath -lBulletSoftBody|' \
+ bullet.pc.in > bullet.pc || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins bullet.pc || die
+ dodoc README ChangeLog AUTHORS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Extras Demos || die
+ fi
+}