summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-04 15:44:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-04 15:44:06 +0000
commita010a223b7eb1880e4992ab79692917c840723f5 (patch)
tree5084fdf522eed8d3a7a27ca91b04be11e75a64d9 /sci-physics
parentfixed sandbox violation on DRI systems (diff)
downloadgentoo-2-a010a223b7eb1880e4992ab79692917c840723f5.tar.gz
gentoo-2-a010a223b7eb1880e4992ab79692917c840723f5.tar.bz2
gentoo-2-a010a223b7eb1880e4992ab79692917c840723f5.zip
fixed postgres link
(Portage version: 2.2.01.21938-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/ChangeLog6
-rw-r--r--sci-physics/root/root-5.34.07.ebuild18
2 files changed, 15 insertions, 9 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 6a3d46d1f1f8..8cc98604110d 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.117 2013/05/29 16:39:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.118 2013/06/04 15:44:06 bicatali Exp $
+
+ 28 May 2013; Andrew Savchenko <bircoph@gmail.com> +root-5.34.07.ebuild:
+ Fix build with USE="postgres": Gentoo doesn't provide
+ /usr/include/postgresql symlink anymore.
29 May 2013; Justin Lecher <jlec@gentoo.org> root-5.34.07.ebuild,
metadata.xml:
diff --git a/sci-physics/root/root-5.34.07.ebuild b/sci-physics/root/root-5.34.07.ebuild
index 87c56060d310..f20f6ed90c36 100644
--- a/sci-physics/root/root-5.34.07.ebuild
+++ b/sci-physics/root/root-5.34.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.07.ebuild,v 1.2 2013/05/29 16:39:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.07.ebuild,v 1.3 2013/06/04 15:44:06 bicatali Exp $
EAPI=5
@@ -41,7 +41,12 @@ IUSE="+X afs avahi -c++0x doc emacs examples fits fftw graphviz htmldoc
kerberos ldap +math mpi mysql odbc +opengl openmp oracle postgres prefix
pythia6 pythia8 python qt4 +reflex ruby ssl xinetd xml xrootd"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ !X? ( !opengl !qt4 )
+ htmldoc? ( doc )
+ mpi? ( math !openmp )
+ openmp? ( math !mpi )
+ python? ( ${PYTHON_REQUIRED_USE} )"
CDEPEND="
app-arch/xz-utils
@@ -107,12 +112,6 @@ RDEPEND="${CDEPEND}
PDEPEND="htmldoc? ( ~app-doc/root-docs-${PV} )"
-REQUIRED_USE="
- !X? ( !opengl !qt4 )
- htmldoc? ( doc )
- mpi? ( math !openmp )
- openmp? ( math !mpi )"
-
S="${WORKDIR}/${PN}"
pkg_setup() {
@@ -208,6 +207,8 @@ src_prepare() {
}
src_configure() {
+ local myconfflags=""
+ use postgres && myconfflags+=" --with-pgsql-incdir=$(pg_config --includedir)"
# the configure script is not the standard autotools
./configure \
--prefix="${EPREFIX}"/usr \
@@ -272,6 +273,7 @@ src_configure() {
$(use_enable ssl) \
$(use_enable xml) \
$(use_enable xrootd) \
+ ${myconfflags} \
${EXTRA_ECONF} \
|| die "configure failed"
}