summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-24 17:47:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-24 17:47:27 +0000
commitb74c0044a41048189af57e630bbd64dab161fbed (patch)
treedc3a12db4200170085f579868d92bf5d190d9680 /sci-physics
parentVersion bump, also fix gcc-4.7 and glib-2.32 compilation, and create user/gro... (diff)
downloadgentoo-2-b74c0044a41048189af57e630bbd64dab161fbed.tar.gz
gentoo-2-b74c0044a41048189af57e630bbd64dab161fbed.tar.bz2
gentoo-2-b74c0044a41048189af57e630bbd64dab161fbed.zip
Now depend on system siscone. Fix bug #427698
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/fastjet/ChangeLog9
-rw-r--r--sci-physics/fastjet/fastjet-3.0.3-r1.ebuild (renamed from sci-physics/fastjet/fastjet-3.0.3.ebuild)13
-rw-r--r--sci-physics/fastjet/files/fastjet-3.0.3-system-siscone.patch73
3 files changed, 88 insertions, 7 deletions
diff --git a/sci-physics/fastjet/ChangeLog b/sci-physics/fastjet/ChangeLog
index 075d8db73204..d25b855aabb3 100644
--- a/sci-physics/fastjet/ChangeLog
+++ b/sci-physics/fastjet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/fastjet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.3 2012/06/27 18:49:32 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.4 2012/07/24 17:47:27 bicatali Exp $
+
+*fastjet-3.0.3-r1 (24 Jul 2012)
+
+ 24 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +fastjet-3.0.3-r1.ebuild,
+ +files/fastjet-3.0.3-system-siscone.patch, -fastjet-3.0.3.ebuild:
+ Now depend on system siscone. Fix bug #427698
*fastjet-3.0.3 (27 Jun 2012)
@@ -24,4 +30,3 @@
Remove unused eutils.eclass, shorten DESC, add missing license, sort
KEYWORDS, add static-libs, docs IUSE, add dependency on doxygen for [doc],
build only shared libs by default, install documentation
-
diff --git a/sci-physics/fastjet/fastjet-3.0.3.ebuild b/sci-physics/fastjet/fastjet-3.0.3-r1.ebuild
index af987763c162..5eb69cebaa20 100644
--- a/sci-physics/fastjet/fastjet-3.0.3.ebuild
+++ b/sci-physics/fastjet/fastjet-3.0.3-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.3.ebuild,v 1.1 2012/06/27 18:49:32 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.3-r1.ebuild,v 1.1 2012/07/24 17:47:27 bicatali Exp $
EAPI=4
+AUTOTOOLS_AUTORECONF=yes
inherit autotools-utils fortran-2 flag-o-matic
DESCRIPTION="Fast implementation of several recombination jet algorithms"
@@ -12,13 +13,15 @@ SRC_URI="${HOMEPAGE}/repo/${P}.tar.gz"
LICENSE="GPL-2 QPL"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cgal doc examples +plugins static-libs"
RDEPEND="cgal? ( sci-mathematics/cgal )"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- plugins? ( virtual/fortran )"
+ doc? ( app-doc/doxygen[dot] )
+ plugins? ( virtual/fortran sci-physics/siscone )"
+
+PATCHES=( "${FILESDIR}"/${P}-system-siscone.patch )
pkg_setup() {
use plugins && fortran-2_pkg_setup
@@ -26,7 +29,7 @@ pkg_setup() {
src_configure() {
use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
- myeconfargs+=(
+ local myeconfargs=(
$(use_enable cgal)
$(use_enable plugins allplugins)
$(use_enable plugins allcxxplugins)
diff --git a/sci-physics/fastjet/files/fastjet-3.0.3-system-siscone.patch b/sci-physics/fastjet/files/fastjet-3.0.3-system-siscone.patch
new file mode 100644
index 000000000000..c81d86174a7b
--- /dev/null
+++ b/sci-physics/fastjet/files/fastjet-3.0.3-system-siscone.patch
@@ -0,0 +1,73 @@
+diff -Nur fastjet-3.0.3.orig/configure.ac fastjet-3.0.3/configure.ac
+--- fastjet-3.0.3.orig/configure.ac 2012-06-25 15:15:32.000000000 +0100
++++ fastjet-3.0.3/configure.ac 2012-07-24 18:39:11.000000000 +0100
+@@ -252,6 +252,11 @@
+ fi
+
+ dnl SISCone
++AC_ARG_WITH(bundle-siscone,
++ [ --with-bundle-siscone Build the bundled SISCone library [default=no]],
++ [bundle_siscone=$withval],
++ [bundle_siscone=no])
++AM_CONDITIONAL(BUNDLE_SISCONE, test x$bundle_siscone != xno)
+ ACX_CHECK_PLUGIN(SISCone, siscone, SISCONE, yes,
+ [CONFIG_LIBS_PLUGINS=${CONFIG_LIBS_PLUGINS}" -lsiscone_spherical -lsiscone"
+ CONFIG_LIBS_PLUGINS_STATIC=${CONFIG_LIBS_PLUGINS_STATIC}" \${installationdir}/lib/libsiscone.a \${installationdir}/lib/libsiscone_spherical.a"])
+diff -Nur fastjet-3.0.3.orig/example/Makefile.am fastjet-3.0.3/example/Makefile.am
+--- fastjet-3.0.3.orig/example/Makefile.am 2012-06-13 15:14:58.000000000 +0100
++++ fastjet-3.0.3/example/Makefile.am 2012-07-24 18:26:15.000000000 +0100
+@@ -43,7 +43,7 @@
+ 03_plugin_CXXFLAGS = $(AM_CXXFLAGS) $(CGAL_CPPFLAGS) -I$(srcdir)/../include
+ 03_plugin_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ 03_plugin_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ else
+ EXTRA_DIST += 03-plugin.cc
+ endif
+@@ -125,7 +125,7 @@
+ fastjet_areas_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ if BUILD_PLUGIN_SISCONE
+ fastjet_areas_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+
+ fastjet_timing_plugins_SOURCES = fastjet_timing_plugins.cc CmdLine.cc
+@@ -135,7 +135,7 @@
+ fastjet_timing_plugins_LDADD += ../tools/libfastjettools.la
+ if BUILD_PLUGIN_SISCONE
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+ if BUILD_PLUGIN_CDFCONES
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/CDFCones
+diff -Nur fastjet-3.0.3.orig/plugins/SISCone/Makefile.am fastjet-3.0.3/plugins/SISCone/Makefile.am
+--- fastjet-3.0.3.orig/plugins/SISCone/Makefile.am 2012-06-13 15:14:51.000000000 +0100
++++ fastjet-3.0.3/plugins/SISCone/Makefile.am 2012-07-24 18:36:56.000000000 +0100
+@@ -1,11 +1,22 @@
+-SUBDIRS = siscone fastjet .
++SUBDIRS = fastjet .
+
+ if MONOLITHIC_PLUGINS
+ noinst_LTLIBRARIES = libSISConePlugin.la
+ else
+ lib_LTLIBRARIES = libSISConePlugin.la
+ endif
+-libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/siscone -I$(srcdir)/../../include
++libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/../../include
++
++if BUNDLE_SISCONE
++SUBDIRS += siscone
++libSISConePlugin_la_CXXFLAGS += -I$(srcdir)/siscone
++libSISConePlugin_la_LIBADD = \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/libsiscone.la \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++else
++libSISConePlugin_la_LIBADD = -lsiscone -lsiscone_spherical
++endif
++
+ libSISConePlugin_la_SOURCES = SISConePlugin.cc SISConeSphericalPlugin.cc
+
+ EXTRA_DIST = makefile.static