summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-10-09 13:48:49 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-10-09 13:48:49 +0000
commitc77ff3d66cbebabfb82a8bde839c5b3635ae82f4 (patch)
tree2b923595e00a10c19d9104d6ae4a343ab616b4a3 /sci-physics
parentStable for HPPA (bug #485190). (diff)
downloadgentoo-2-c77ff3d66cbebabfb82a8bde839c5b3635ae82f4.tar.gz
gentoo-2-c77ff3d66cbebabfb82a8bde839c5b3635ae82f4.tar.bz2
gentoo-2-c77ff3d66cbebabfb82a8bde839c5b3635ae82f4.zip
version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso++/ChangeLog8
-rw-r--r--sci-physics/espresso++/espresso++-1.6.0.ebuild (renamed from sci-physics/espresso++/espresso++-1.4.0.ebuild)34
-rw-r--r--sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch65
3 files changed, 91 insertions, 16 deletions
diff --git a/sci-physics/espresso++/ChangeLog b/sci-physics/espresso++/ChangeLog
index 524e35592683..267db04f82d3 100644
--- a/sci-physics/espresso++/ChangeLog
+++ b/sci-physics/espresso++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/espresso++
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.5 2013/01/26 02:30:51 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.6 2013/10/09 13:48:49 ottxor Exp $
+
+*espresso++-1.6.0 (09 Oct 2013)
+
+ 09 Oct 2013; Christoph Junghans <ottxor@gentoo.org> +espresso++-1.6.0.ebuild,
+ +files/espresso++-1.6.0-multilib.patch, -espresso++-1.4.0.ebuild:
+ version bump
*espresso++-1.4.0 (26 Jan 2013)
diff --git a/sci-physics/espresso++/espresso++-1.4.0.ebuild b/sci-physics/espresso++/espresso++-1.6.0.ebuild
index c16433866157..9275fe4a08ea 100644
--- a/sci-physics/espresso++/espresso++-1.4.0.ebuild
+++ b/sci-physics/espresso++/espresso++-1.6.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/espresso++-1.4.0.ebuild,v 1.1 2013/01/26 02:30:51 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/espresso++-1.6.0.ebuild,v 1.1 2013/10/09 13:48:49 ottxor Exp $
EAPI=5
-PYTHON_DEPEND="2:2.6"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit cmake-utils python
+inherit cmake-utils multilib python-single-r1
DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
HOMEPAGE="https://www.espresso-pp.de"
@@ -18,31 +18,35 @@ if [[ ${PV} = 9999 ]]; then
else
SRC_URI="https://espressopp.mpip-mainz.mpg.de/Download/${PN//+/p}-${PV}.tgz"
S="${WORKDIR}/${PN//+/p}-${PV}"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ PATCHES=( "${FILESDIR}/${P}-multilib.patch" )
fi
CMAKE_REMOVE_MODULES_LIST="FindBoost"
+EHP_OPTS="--config hostfingerprints.hg.berlios.de=f4:79:d2:17:f8:0c:9b:c2:6e:65:60:2a:49:0e:09:79:85:6d:4b:e3"
+EHG_CLONE_CMD="hg clone ${EHG_QUIET_CMD_OPT} ${EHP_OPTS} --pull --noupdate"
+EHG_PULL_CMD="hg pull ${EHG_QUIET_CMD_OPT} ${EHP_OPTS}"
LICENSE="GPL-3 !system-boost? ( Boost-1.0 )"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
IUSE="-system-boost"
-RDEPEND="
- system-boost? ( dev-libs/boost[python,mpi] )
- virtual/mpi
- "
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ system-boost? ( dev-libs/boost[python,mpi,${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS NEWS README )
-pkg_setup() {
- python_set_active_version 2
-}
-
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use system-boost EXTERNAL_BOOST)
- )
+ mycmakeargs=( $(cmake-utils_use system-boost EXTERNAL_BOOST) -DLIB="$(get_libdir)" )
cmake-utils_src_configure
}
+
+src_install() {
+ cmake-utils_src_install
+ rm "${ED}/usr/bin/ESPRC" || die
+ rmdir "${ED}/usr/bin" || die
+}
diff --git a/sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch b/sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch
new file mode 100644
index 000000000000..a66988b1bc82
--- /dev/null
+++ b/sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch
@@ -0,0 +1,65 @@
+# HG changeset patch
+# User Christoph Junghans <christoph.junghans@gmail.com>
+# Date 1381325052 -7200
+# Node ID bcdda52214df0c007e44ec8d5045b0e68b142227
+# Parent 65da1a6110e59322efa1bb5eaff596baf9f07d5d
+added LIB variable
+
+diff -r 65da1a6110e5 -r bcdda52214df CMakeLists.txt
+--- a/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -29,6 +29,9 @@
+ option(BUILD_SHARED_LIBS "Build shared libs" ON)
+ option(BUILD_STANDALONE "Builds pypresso an standalone binary" OFF)
+ option(BUILD_PYTHON_MODULE "Builds epresso as python module" ON)
++if (NOT DEFINED LIB)
++ set(LIB "lib")
++endif(NOT DEFINED LIB)
+
+ if(NOT BUILD_STANDALONE AND NOT BUILD_PYTHON_MODULE)
+ message(FATAL_ERROR "You need to enable pypresso or the python module")
+diff -r 65da1a6110e5 -r bcdda52214df contrib/boost/CMakeLists.txt
+--- a/contrib/boost/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/contrib/boost/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -21,4 +21,4 @@
+
+ add_library(espresso_boost ${BOOST_SOURCES})
+ target_link_libraries(espresso_boost ${PYTHON_LIBRARIES} ${VAMPIRTRACE_LIBRARIES} ${MPI_LIBRARIES} ${RT_LIBRARIES})
+-install(TARGETS espresso_boost LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
++install(TARGETS espresso_boost LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION lib)
+diff -r 65da1a6110e5 -r bcdda52214df contrib/mpi4py/CMakeLists.txt
+--- a/contrib/mpi4py/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/contrib/mpi4py/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -12,4 +12,4 @@
+ target_link_libraries(dl ${PYTHON_LIBRARIES} ${VAMPIRTRACE_LIBRARIES} ${MPI_LIBRARIES})
+ set_target_properties(dl PROPERTIES PREFIX "" SUFFIX ".so")
+
+-install(TARGETS MPI LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION lib)
++install(TARGETS MPI LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${LIB})
+diff -r 65da1a6110e5 -r bcdda52214df src/CMakeLists.txt
+--- a/src/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/src/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -70,11 +70,11 @@
+ add_library(espresso_common ${ESPRESSO_SOURCES})
+ target_link_libraries(espresso_common pylogger ${BOOST} ${PYTHON_LIBRARIES}
+ ${VAMPIRTRACE_LIBRARIES} ${MPI_LIBRARIES} ${FFTW3_LIBRARIES})
+-install(TARGETS espresso_common LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
++install(TARGETS espresso_common LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION lib)
+
+ add_library(pylogger esutil/PyLogger.cpp)
+ target_link_libraries(pylogger ${BOOST})
+-install(TARGETS pylogger LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
++install(TARGETS pylogger LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION lib)
+
+ if(BUILD_STANDALONE)
+ add_executable(pypresso main/pypresso.cpp)
+diff -r 65da1a6110e5 -r bcdda52214df src/pymodule/CMakeLists.txt
+--- a/src/pymodule/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/src/pymodule/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -5,5 +5,5 @@
+ add_dependencies(_espresso scripts)
+ #python libs have not prefix (default would be 'lib')
+ set_target_properties(_espresso PROPERTIES PREFIX "" SUFFIX ".so")
+- install(TARGETS _espresso LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION lib)
++ install(TARGETS _espresso LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${LIB})
+ endif(BUILD_PYTHON_MODULE)