summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-07-13 16:46:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-07-13 16:46:54 +0000
commitcab287edf2dd26cc4e6d838930e1b713a570c3bb (patch)
tree381cb4f1315e1aff3840304e9b1075b583f7400b /sci-physics
parentBump (diff)
downloadgentoo-2-cab287edf2dd26cc4e6d838930e1b713a570c3bb.tar.gz
gentoo-2-cab287edf2dd26cc4e6d838930e1b713a570c3bb.tar.bz2
gentoo-2-cab287edf2dd26cc4e6d838930e1b713a570c3bb.zip
Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog8
-rw-r--r--sci-physics/clhep/clhep-2.0.4.7.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index 3b6bd9e9b263..cfcf89e6bb2b 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.25 2010/05/25 21:16:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.26 2010/07/13 16:46:54 bicatali Exp $
+
+*clhep-2.0.4.7 (13 Jul 2010)
+
+ 13 Jul 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +clhep-2.0.4.7.ebuild:
+ Bump
25 May 2010; Pacho Ramos <pacho@gentoo.org> clhep-2.0.4.6.ebuild:
stable amd64, bug 318457
diff --git a/sci-physics/clhep/clhep-2.0.4.7.ebuild b/sci-physics/clhep/clhep-2.0.4.7.ebuild
new file mode 100644
index 000000000000..d8c6872951d8
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.0.4.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.4.7.ebuild,v 1.1 2010/07/13 16:46:54 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
+LICENSE="public-domain"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+IUSE="exceptions"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ for d in $(find . -name configure.in); do
+ # respect user flags and fix some compilers stuff
+ sed -i \
+ -e 's:^g++):*g++):g' \
+ -e 's:^icc):icc|icpc):g' \
+ -e '/AM_CXXFLAGS=/s:-O ::g' \
+ ${d} || die
+ # need to rebuild because original configurations
+ # have buggy detection
+ done
+ for d in $(find . -name Makefile.am | xargs grep -l ": %\.cc"); do
+ sed -i \
+ -e 's|: %\.cc|: %\.cc \$(shareddir)|' \
+ -e 's|all-local: \$(shareddir)|all-local: |' \
+ ${d} || die
+ # fixing parallel build
+ done
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable exceptions)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog || die
+}