summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-06-13 21:23:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-06-13 21:23:23 +0000
commitd19f0ae11ab172dcd86a3ea726472b02d32ebe89 (patch)
tree8bd740dc537e2273afa8d98e3d1d1028f5caa5e9 /sci-physics
parentAdded ~mips, bug 342513 (diff)
downloadgentoo-2-d19f0ae11ab172dcd86a3ea726472b02d32ebe89.tar.gz
gentoo-2-d19f0ae11ab172dcd86a3ea726472b02d32ebe89.tar.bz2
gentoo-2-d19f0ae11ab172dcd86a3ea726472b02d32ebe89.zip
Version bumps
(Portage version: 2.1.10.2/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/ChangeLog9
-rw-r--r--sci-physics/pythia/pythia-6.4.25.ebuild67
-rw-r--r--sci-physics/pythia/pythia-8.1.50.ebuild88
3 files changed, 163 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index a08098b432ed..349605a351de 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.39 2011/06/07 16:10:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.40 2011/06/13 21:23:23 bicatali Exp $
+
+*pythia-8.1.50 (13 Jun 2011)
+*pythia-6.4.25 (13 Jun 2011)
+
+ 13 Jun 2011; Sébastien Fabbro <bicatali@gentoo.org> +pythia-6.4.25.ebuild,
+ +pythia-8.1.50.ebuild:
+ Version bumps
07 Jun 2011; Jeroen Roovers <jer@gentoo.org> pythia-6.4.24.ebuild,
pythia-8.1.45.ebuild:
diff --git a/sci-physics/pythia/pythia-6.4.25.ebuild b/sci-physics/pythia/pythia-6.4.25.ebuild
new file mode 100644
index 000000000000..72e9d952e66b
--- /dev/null
+++ b/sci-physics/pythia/pythia-6.4.25.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.25.ebuild,v 1.1 2011/06/13 21:23:23 bicatali Exp $
+
+EAPI=4
+inherit versionator autotools
+
+MV=$(get_major_version)
+MY_PN=${PN}${MV}
+DOC_PV=0613
+EX_PV=6.4.18
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://projects.hepforge.org/pythia6/"
+
+# pythia6 from root is needed for some files to interface pythia6 with root.
+# To produce a split version on mirror do, replace the 6.4.x by the current version
+# svn export http://svn.hepforge.org/pythia6/tags/v_6_4_x/ pythia-6.4.x
+# tar cjf pythia-6.4.x.tar.bz2
+SRC_URI="http://dev.gentoo.org/~bicatali/${P}.tar.bz2
+ ftp://root.cern.ch/root/pythia6.tar.gz
+ doc? ( http://home.thep.lu.se/~torbjorn/pythia/lutp${DOC_PV}man2.pdf )
+ examples? ( mirror://gentoo/${PN}-${EX_PV}-examples.tar.bz2 )"
+
+LICENSE="public-domain"
+SLOT="6"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+DEPEND="virtual/fortran"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp ../pythia6/tpythia6_called_from_cc.F .
+ cp ../pythia6/pythia6_common_address.c .
+ cat > configure.ac <<-EOF
+ AC_INIT(${PN},${PV})
+ AM_INIT_AUTOMAKE
+ AC_PROG_F77
+ LT_INIT
+ AC_CHECK_LIB(m,sqrt)
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ echo >> Makefile.am "lib_LTLIBRARIES = libpythia6.la"
+ echo >> Makefile.am "libpythia6_la_SOURCES = \ "
+ # replace wildcard from makefile to ls in shell
+ for f in py*.f struct*.f up*.f fh*.f; do
+ echo >> Makefile.am " ${f} \\"
+ done
+ echo >> Makefile.am " ssmssm.f sugra.f visaje.f pdfset.f \\"
+ echo >> Makefile.am " tpythia6_called_from_cc.F pythia6_common_address.c"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc update_notes.txt
+ use doc && dodoc "${DISTDIR}"/lutp${DOC_PV}man2.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r "${WORKDIR}"/examples || die
+ fi
+}
diff --git a/sci-physics/pythia/pythia-8.1.50.ebuild b/sci-physics/pythia/pythia-8.1.50.ebuild
new file mode 100644
index 000000000000..fa8bfaea8274
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.50.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.50.ebuild,v 1.1 2011/06/13 21:23:23 bicatali Exp $
+
+EAPI=4
+
+inherit eutils versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +hepmc static-libs"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION="${EPREFIX}/usr"
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk
+ cat > config.mk <<-EOF
+ SHAREDLIBS = yes
+ LDFLAGSSHARED = -shared ${LDFLAGS}
+ LDFLAGLIBNAME = -Wl,-soname
+ SHAREDSUFFIX = so
+ EOF
+ if ! use static-libs; then
+ sed -i \
+ -e '/targets.*\.a/d' \
+ -e 's/+=\(.*libpythia8\)/=\1/' \
+ Makefile || die
+ sed -i \
+ -e 's:\.a:\.so:g' \
+ -e 's:$(LIBDIRARCH):$(LIBDIR):g' \
+ examples/Makefile || die
+ fi
+}
+
+src_test() {
+ cd "${S}"/examples
+ # use emake for parallel instead of long runmains
+ emake main0{1..9}
+ for i in main0{1..9}*.exe; do
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31 main32
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./main31.exe > main31.exe.out || die
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so
+ use static-libs && dolib.a lib/archive/*
+
+ insinto /usr/include/${PN}
+ doins include/*
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc
+ echo "PYTHIA8DATA=${EROOT}usr/share/${PN}/xmldoc" >> 99pythia8
+ doenvd 99pythia8
+
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ dodoc worksheet.pdf
+ dohtml -r htmldoc/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "examples install failed"
+ fi
+}