summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-03 14:49:46 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-03 14:49:46 +0000
commit470c92358bd40fca46f9eff2d48506c675a293d2 (patch)
tree8291ba408f5c1b9fa05be79ac7d018a4b628faa2 /sci-visualization/epix
parentStable on hppa. See bug #135076. (diff)
downloadgentoo-2-470c92358bd40fca46f9eff2d48506c675a293d2.tar.gz
gentoo-2-470c92358bd40fca46f9eff2d48506c675a293d2.tar.bz2
gentoo-2-470c92358bd40fca46f9eff2d48506c675a293d2.zip
Bump to the most recent version which compiles fine with gcc-4.1 (see bug #135266).
(Portage version: 2.1_rc3-r4)
Diffstat (limited to 'sci-visualization/epix')
-rw-r--r--sci-visualization/epix/ChangeLog9
-rw-r--r--sci-visualization/epix/epix-1.0.7.ebuild37
-rw-r--r--sci-visualization/epix/files/digest-epix-1.0.02
-rw-r--r--sci-visualization/epix/files/digest-epix-1.0.73
-rw-r--r--sci-visualization/epix/files/epix-doc-gentoo.patch36
5 files changed, 86 insertions, 1 deletions
diff --git a/sci-visualization/epix/ChangeLog b/sci-visualization/epix/ChangeLog
index a89cf8c86ded..2cf2f748463c 100644
--- a/sci-visualization/epix/ChangeLog
+++ b/sci-visualization/epix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/epix
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/ChangeLog,v 1.2 2006/02/16 19:20:46 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/ChangeLog,v 1.3 2006/06/03 14:49:46 markusle Exp $
+
+*epix-1.0.7 (03 Jun 2006)
+
+ 03 Jun 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/epix-doc-gentoo.patch, +epix-1.0.7.ebuild:
+ Bump to the most recent version which compiles fine with gcc-4.1
+ (see bug #135266).
29 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+epix-1.0.0.ebuild:
diff --git a/sci-visualization/epix/epix-1.0.7.ebuild b/sci-visualization/epix/epix-1.0.7.ebuild
new file mode 100644
index 000000000000..ccfdd435aee4
--- /dev/null
+++ b/sci-visualization/epix/epix-1.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.0.7.ebuild,v 1.1 2006/06/03 14:49:46 markusle Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
+HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
+SRC_URI="http://mathcs.holycross.edu/~ahwang/epix/${P}_complete.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/tetex"
+
+RDEPEND="app-shells/bash
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-doc-gentoo.patch
+ sed -e "s:/doc/${PN}:/doc/${P}:" -i Makefile.in doc/Makefile.in \
+ samples/Makefile.in
+}
+
+src_compile() {
+ econf || die "failed to configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}
diff --git a/sci-visualization/epix/files/digest-epix-1.0.0 b/sci-visualization/epix/files/digest-epix-1.0.0
index f2370639b6a7..6ac29f120745 100644
--- a/sci-visualization/epix/files/digest-epix-1.0.0
+++ b/sci-visualization/epix/files/digest-epix-1.0.0
@@ -1 +1,3 @@
MD5 7138e8084e0dbd2f2c6899835812e5a9 epix-1.0.0_complete.tar.bz2 172151
+RMD160 2527927aa361db58bdc2e058e83d1e66baad2f83 epix-1.0.0_complete.tar.bz2 172151
+SHA256 460c2e939e03f55b76f608e3b653c7c8bc099f66aad29920e268c377155bd3da epix-1.0.0_complete.tar.bz2 172151
diff --git a/sci-visualization/epix/files/digest-epix-1.0.7 b/sci-visualization/epix/files/digest-epix-1.0.7
new file mode 100644
index 000000000000..4a2818e636bd
--- /dev/null
+++ b/sci-visualization/epix/files/digest-epix-1.0.7
@@ -0,0 +1,3 @@
+MD5 3c9231795968d9a230d3af129480e1a7 epix-1.0.7_complete.tar.bz2 273787
+RMD160 db2f5db97af679d013060f8061e9b5262038f824 epix-1.0.7_complete.tar.bz2 273787
+SHA256 97f20c2be145c9794ea57955215f6d9245a6d7d0afe45908c90f3ec1ed42e41d epix-1.0.7_complete.tar.bz2 273787
diff --git a/sci-visualization/epix/files/epix-doc-gentoo.patch b/sci-visualization/epix/files/epix-doc-gentoo.patch
new file mode 100644
index 000000000000..08672ad68878
--- /dev/null
+++ b/sci-visualization/epix/files/epix-doc-gentoo.patch
@@ -0,0 +1,36 @@
+diff -Naur epix-1.0.7-old/Makefile.in epix-1.0.7/Makefile.in
+--- epix-1.0.7-old/Makefile.in 2006-05-19 17:33:19.000000000 -0400
++++ epix-1.0.7/Makefile.in 2006-06-03 10:05:47.000000000 -0400
+@@ -242,7 +242,7 @@
+ #
+ man_MANS = epix.1 elaps.1 flix.1 laps.1
+ EPIX_CONFFILES = bash_completions epix.ebuild epix.el epix.spec
+-EPIX_NOTEFILES = AUTHORS BUGS ChangeLog COPYING INSTALL NEWS POST-INSTALL \
++EPIX_NOTEFILES = AUTHORS BUGS ChangeLog NEWS POST-INSTALL \
+ README README-changes README-porting THANKS VERSION
+
+ EXTRA_DIST = $(bin_SCRIPTS) $(man_MANS) $(EPIX_CONFFILES) $(EPIX_NOTEFILES)
+@@ -889,9 +889,8 @@
+ # Extra things to install
+ install-data-local:
+ @echo; echo "Installing notes and configuration files"
+- ./mkinstalldirs $(DESTDIR)$(docdir)/notes $(DESTDIR)$(docdir)/config
+- $(INSTALL_DATA) $(EPIX_NOTEFILES) $(DESTDIR)$(docdir)/notes
+- $(INSTALL_DATA) $(EPIX_CONFFILES) $(DESTDIR)$(docdir)/config
++ ./mkinstalldirs $(DESTDIR)$(docdir)
++ $(INSTALL_DATA) $(EPIX_NOTEFILES) $(DESTDIR)$(docdir)
+
+ # This is being installed by install-exec, but should not be executable
+ install-exec-local: install-pkglibDATA
+diff -Naur epix-1.0.7-old/samples/Makefile.in epix-1.0.7/samples/Makefile.in
+--- epix-1.0.7-old/samples/Makefile.in 2006-05-19 17:33:19.000000000 -0400
++++ epix-1.0.7/samples/Makefile.in 2006-06-03 10:04:16.000000000 -0400
+@@ -145,7 +145,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ docdir = $(datadir)/doc/epix
+-EPIXFLAGS = --no-defaults -I.. -L.. -lepix -v
++EPIXFLAGS = --no-defaults -I.. -L.. -lepix
+ XPS := $(wildcard *.xp)
+ EEPICS = $(XPS:.xp=.eepic)
+ CLEANFILES = *~ *.dvi *.log *.out *.ilg sample_src.tar sample.pdf sample.ps \