summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-05-03 18:08:28 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-05-03 18:08:28 +0000
commit244c97b929b5b24bce93468c99831d333d809f93 (patch)
tree0198c56ade66f4868146f71c1adb0a8f5edce441 /sci-visualization/extrema
parent1.1.0 amd64 stable wrt #220137. fix test suite for both versions. (diff)
downloadgentoo-2-244c97b929b5b24bce93468c99831d333d809f93.tar.gz
gentoo-2-244c97b929b5b24bce93468c99831d333d809f93.tar.bz2
gentoo-2-244c97b929b5b24bce93468c99831d333d809f93.zip
Initial import.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-visualization/extrema')
-rw-r--r--sci-visualization/extrema/ChangeLog10
-rw-r--r--sci-visualization/extrema/Manifest4
-rw-r--r--sci-visualization/extrema/extrema-4.3.5.ebuild55
-rw-r--r--sci-visualization/extrema/metadata.xml10
4 files changed, 79 insertions, 0 deletions
diff --git a/sci-visualization/extrema/ChangeLog b/sci-visualization/extrema/ChangeLog
new file mode 100644
index 000000000000..7f3b4f010b95
--- /dev/null
+++ b/sci-visualization/extrema/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-visualization/extrema
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/ChangeLog,v 1.1 2008/05/03 18:08:28 grozin Exp $
+
+*extrema-4.3.5 (04 May 2008)
+
+ 04 May 2008; Andrey Grozin <grozin@gentoo.org> +metadata.xml,
+ +extrema-4.3.5.ebuild:
+ Initial import.
+
diff --git a/sci-visualization/extrema/Manifest b/sci-visualization/extrema/Manifest
new file mode 100644
index 000000000000..13f77609a615
--- /dev/null
+++ b/sci-visualization/extrema/Manifest
@@ -0,0 +1,4 @@
+DIST extrema-4.3.5.tar.gz 6267856 RMD160 1a226a9e442f7c8007e7f9b7f8ec63e3919d2529 SHA1 ef1986293d530fc4372b32be3250e1538c2509ca SHA256 70a8db93e12c571724899f48abec5ecaf577fb039e7cb6360db0a93b7d64f433
+EBUILD extrema-4.3.5.ebuild 1389 RMD160 101483bdfdbefb0235a3b70a4440b14d100e3d5f SHA1 a02cfe267634d38a906ce052b1195803be7df8ca SHA256 0088f83cba4909ff0c6b1fa2382584ba3402725d30a33eeb551a998b824bced2
+MISC ChangeLog 264 RMD160 a88aa43cc1a7353a7895c7e4e9e0fefc9d60b45c SHA1 7771f9f1703490980e21915431858d57c1a0ce73 SHA256 61d5b07f26b1a2a5d56a3999c3f0a23a5e807b082684b6b599ea5094efa2ecc4
+MISC metadata.xml 575 RMD160 5caa41391cb1bc18964be1137955dfa8f78bcbc6 SHA1 4f26d103d5de06c43cf07cf2378830811d19437f SHA256 c32b9b72b2e710e3b6a23b15fd74ab5e9f2611762057425cd28ee5e4f1cc823e
diff --git a/sci-visualization/extrema/extrema-4.3.5.ebuild b/sci-visualization/extrema/extrema-4.3.5.ebuild
new file mode 100644
index 000000000000..6287eed28e26
--- /dev/null
+++ b/sci-visualization/extrema/extrema-4.3.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/extrema-4.3.5.ebuild,v 1.1 2008/05/03 18:08:28 grozin Exp $
+
+WX_GTK_VER="2.8"
+inherit eutils fdo-mime wxwidgets
+
+DESCRIPTION="Interactive data analysis and visualization tool"
+HOMEPAGE="http://exsitewebware.com/extrema/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="doc examples"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DEPEND=">=x11-libs/wxGTK-2.8.7
+ dev-util/desktop-file-utils"
+
+src_compile() {
+ # extrema cannot be compiled with versions of minuit
+ # available in portage
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ # The upstream Makefile is mostly OK, but for a few files
+ # cp to a hard-coded directory is used, ignoring $(DESTDIR)
+ # This problem is solved by einstall
+ einstall || die "einstall failed"
+
+ make_desktop_entry ${PN}
+ dodir /usr/share/icons/hicolor
+ tar xjf extrema_icons.tar.bz2 -C "${D}usr/share/icons/hicolor"
+ dosym /usr/share/icons/hicolor/48x48/apps/extrema.png /usr/share/pixmaps/extrema.png
+
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins Scripts/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-visualization/extrema/metadata.xml b/sci-visualization/extrema/metadata.xml
new file mode 100644
index 000000000000..e8eff4831cce
--- /dev/null
+++ b/sci-visualization/extrema/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Extrema is a powerful visualization and data analysis tool that enables researchers to quickly distill their large, complex data sets into meaningful information. Its flexibility, sophistication, and power allow you to easily develop your own commands and create highly customized graphs.</longdescription>
+</pkgmetadata>