summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-19 18:51:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-19 18:51:00 +0000
commitc4cd2251456f33ed7cb29e780b8197722fa023d1 (patch)
tree5998695f62ab790515b1c85ce1932398ab3b888b /sci-visualization/fityk
parentx86 stable wrt bug #299574 (diff)
downloadgentoo-2-c4cd2251456f33ed7cb29e780b8197722fa023d1.tar.gz
gentoo-2-c4cd2251456f33ed7cb29e780b8197722fa023d1.tar.bz2
gentoo-2-c4cd2251456f33ed7cb29e780b8197722fa023d1.zip
Version Bump, Python ABIs fixes #316249 thanks Arfrever for helping me, EAPI=3
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/fityk')
-rw-r--r--sci-visualization/fityk/ChangeLog7
-rw-r--r--sci-visualization/fityk/fityk-0.9.2.ebuild100
2 files changed, 106 insertions, 1 deletions
diff --git a/sci-visualization/fityk/ChangeLog b/sci-visualization/fityk/ChangeLog
index 22bb4b75084e..bc4c926375e8 100644
--- a/sci-visualization/fityk/ChangeLog
+++ b/sci-visualization/fityk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/fityk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/fityk/ChangeLog,v 1.10 2010/04/12 17:05:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/fityk/ChangeLog,v 1.11 2010/05/19 18:51:00 jlec Exp $
+
+*fityk-0.9.2 (19 May 2010)
+
+ 19 May 2010; Justin Lecher <jlec@gentoo.org> +fityk-0.9.2.ebuild:
+ Version Bump, Python ABIs fixes #316249, EAPI=3
*fityk-0.9.1 (12 Apr 2010)
diff --git a/sci-visualization/fityk/fityk-0.9.2.ebuild b/sci-visualization/fityk/fityk-0.9.2.ebuild
new file mode 100644
index 000000000000..87888487aaf8
--- /dev/null
+++ b/sci-visualization/fityk/fityk-0.9.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/fityk/fityk-0.9.2.ebuild,v 1.1 2010/05/19 18:51:00 jlec Exp $
+
+EAPI="3"
+
+WX_GTK_VER="2.8"
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python wxwidgets
+
+DESCRIPTION="General-purpose nonlinear curve fitting and data analysis"
+HOMEPAGE="http://www.unipress.waw.pl/fityk/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gnuplot lua readline python wxwidgets"
+
+CDEPEND=">=sci-libs/xylib-0.6
+ lua? ( dev-lang/lua )
+ readline? ( sys-libs/readline )
+ wxwidgets? ( x11-libs/wxGTK:2.8 )"
+
+DEPEND="${CDEPEND}
+ dev-libs/boost
+ >=sys-devel/libtool-2.2"
+
+RDEPEND="${CDEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ has_version "<dev-libs/boost-1.37" && \
+ sed -i -e 's:impl/directives.hpp:directives.ipp:g' \
+ "${S}/src/optional_suffix.h"
+
+ sed '/^LTLIBRARIES/s:$(pyexec_LTLIBRARIES)::g' \
+ -i swig/Makefile.in
+ if use python; then
+ echo '#!/bin/sh' > config/py-compile
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-xyconvert \
+ $(use_enable lua) \
+ $(use_enable python) \
+ $(use_enable wxwidgets GUI) \
+ $(use_with doc) \
+ $(use_with examples samples) \
+ $(use_with readline)
+}
+
+src_compile() {
+ default
+ if use python; then
+ python_copy_sources swig
+ compilation() {
+ emake \
+ PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ PYTHON_LDFLAGS="$(python_get_library -l)" \
+ PYTHON_SITE_PKG="$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ _fityk.la
+ }
+ python_execute_function -s --source-dir swig compilation
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir swig installation
+ python_clean_installation_image
+ fi
+ dodoc NEWS README TODO || die
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+}