summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-05-21 08:51:32 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-05-21 08:51:32 +0000
commit7f8a7975ca0332b4a70fca5c263c7db655afe73e (patch)
tree507d719fe705d40922cb3e3097e152e8fc8b26a2 /sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild
parentFixed encoding in ChangeLog (diff)
downloadgentoo-2-7f8a7975ca0332b4a70fca5c263c7db655afe73e.tar.gz
gentoo-2-7f8a7975ca0332b4a70fca5c263c7db655afe73e.tar.bz2
gentoo-2-7f8a7975ca0332b4a70fca5c263c7db655afe73e.zip
Version bump. fdo-mime_desktop_database_update added
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild')
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild114
1 files changed, 114 insertions, 0 deletions
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild
new file mode 100644
index 000000000000..6dca543d6526
--- /dev/null
+++ b/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild,v 1.1 2008/05/21 08:51:31 grozin Exp $
+
+EAPI="1"
+inherit eutils multilib qt4 fdo-mime
+
+DESCRIPTION="Qt based clone of the Origin plotting package"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+SRC_URI="http://soft.proindependent.com/src/${P}.tar.bz2
+ doc? ( mirror://gentoo/${P}-manual-en.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="python doc bindist"
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+CDEPEND=">=x11-libs/qwt-5.1
+ >=x11-libs/qwtplot3d-0.2.7
+ >=dev-cpp/muParser-1.28
+ >=sci-libs/liborigin-20080225
+ !bindist? ( sci-libs/gsl )
+ bindist? ( <sci-libs/gsl-1.10 )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ python? ( >=dev-python/sip-4.5.2 )"
+
+RDEPEND="${CDEPEND}
+ python? ( >=dev-lang/python-2.5
+ dev-python/PyQt4
+ dev-python/pygsl
+ sci-libs/scipy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-pro.patch
+ epatch "${FILESDIR}"/${P}-fitplugins.patch
+
+ sed -i \
+ -e '/manual/d'\
+ -e '/3rd/d' \
+ qtiplot.pro || die "sed qtiplot.pro failed"
+ sed -i \
+ -e '/manual/d' \
+ -e "s:doc/${PN}:doc/${PF}:" \
+ qtiplot/qtiplot.pro || die " sed for qtiplot/qtiplot.pro failed"
+
+ if ! use python; then
+ sed -i \
+ -e '/^SCRIPTING_LANGS += Python/d' \
+ -e '/sipcmd/d' \
+ qtiplot/qtiplot.pro || die "sed for python option failed"
+ fi
+
+ # the lib$$suff did not work in the fitRational*.pro files
+ sed -i \
+ -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
+ fitPlugins/fit*/fitRational*.pro \
+ || die "sed fitRational* failed"
+
+ for l in ${LANGS}; do
+ if ! use linguas_${l}; then
+ sed -i \
+ -e "s:translations/qtiplot_${l}.ts::" \
+ -e "s:translations/qtiplot_${l}.qm::" \
+ qtiplot/qtiplot.pro || die
+ fi
+ done
+}
+
+src_compile() {
+ eqmake4 || die "eqmake4 failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+ rm -f "${D}"/usr/share/${PN}/translations/*.ts
+
+ newicon qtiplot_logo.png qtiplot.png
+ make_desktop_entry qtiplot QtiPlot qtiplot
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r "${WORKDIR}"/qtiplot-manual-en/* \
+ || die "install manual failed"
+ rm -rf "${D}"/usr/share/doc/${PF}/html/*/.svn
+ fi
+}
+
+pkg_postinst() {
+ if use doc; then
+ elog "On the first start, do Help -> Choose Help Folder"
+ elog "and select /usr/share/doc/${PF}/html"
+ elog "Also do View -> Preferences, in the tab File Locations"
+ elog "set Python Configuration Files to /usr/share/${PN}"
+ elog "and Translations to /usr/share/${PN}/translations"
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}