summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-01-29 20:20:53 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-01-29 20:20:53 +0000
commit15c0643efc851dd7be778608ee8516e6446f02fb (patch)
treeb776cfb31c880965be9f99362a912bd89b2a4ec0 /sci-visualization/spectromatic/spectromatic-1.0.ebuild
parentMoved media-gfx/scigraphica to sci-visualization/scigraphica (diff)
downloadgentoo-2-15c0643efc851dd7be778608ee8516e6446f02fb.tar.gz
gentoo-2-15c0643efc851dd7be778608ee8516e6446f02fb.tar.bz2
gentoo-2-15c0643efc851dd7be778608ee8516e6446f02fb.zip
Moved from media-gfx/spectromatic to sci-visualization/spectromatic.
Diffstat (limited to 'sci-visualization/spectromatic/spectromatic-1.0.ebuild')
-rw-r--r--sci-visualization/spectromatic/spectromatic-1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-visualization/spectromatic/spectromatic-1.0.ebuild b/sci-visualization/spectromatic/spectromatic-1.0.ebuild
new file mode 100644
index 000000000000..d9cf875f380a
--- /dev/null
+++ b/sci-visualization/spectromatic/spectromatic-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0.ebuild,v 1.1 2006/01/29 20:20:53 cryos Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P="spectromatic_1.0-1"
+DESCRIPTION="Little program that generates spectrograms (time-frequency analysis images) from mono or stereo wave files."
+HOMEPAGE="http://ieee.uow.edu.au/~daniel/software/spectromatic/"
+SRC_URI="http://ieee.uow.edu.au/~daniel/software/spectromatic/dist/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+
+DEPEND=">=sci-libs/gsl-1.2
+ >=media-libs/libpng-1.2.4"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-stringliteral.patch
+}
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dobin spectromatic
+ doman spectromatic.1
+ dodoc COPYING README || die
+}