summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 13:29:11 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 13:29:11 +0000
commit07cc8a6835885b23b71e8da981b3d1d3b7733694 (patch)
treec1a56fa9748cad65d9116f4accb82a44ec8855da /sci-visualization
parentAdd a patch to handle ncurses[tinfo] (diff)
downloadgentoo-2-07cc8a6835885b23b71e8da981b3d1d3b7733694.tar.gz
gentoo-2-07cc8a6835885b23b71e8da981b3d1d3b7733694.tar.bz2
gentoo-2-07cc8a6835885b23b71e8da981b3d1d3b7733694.zip
sci-visualization/spectromatic: Punt base.eclass
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/spectromatic/ChangeLog8
-rw-r--r--sci-visualization/spectromatic/metadata.xml4
-rw-r--r--sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild15
3 files changed, 19 insertions, 8 deletions
diff --git a/sci-visualization/spectromatic/ChangeLog b/sci-visualization/spectromatic/ChangeLog
index 21f62209cc23..8a34e37cdd9e 100644
--- a/sci-visualization/spectromatic/ChangeLog
+++ b/sci-visualization/spectromatic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/spectromatic
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.12 2012/08/07 02:33:07 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.13 2014/01/06 13:29:11 jlec Exp $
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> spectromatic-1.0-r2.ebuild,
+ metadata.xml:
+ Punt base.eclass
07 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+files/spectromatic-1.0-waveheaderstruct-amd64.patch,
diff --git a/sci-visualization/spectromatic/metadata.xml b/sci-visualization/spectromatic/metadata.xml
index cbca6963eeed..df3ad6ba7d06 100644
--- a/sci-visualization/spectromatic/metadata.xml
+++ b/sci-visualization/spectromatic/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
Spectromatic is a program for generating spectrograms from audio
files. Spectrograms are a form of simple time-frequency analysis which
lets you see how the distribution of energy at different frequencies
diff --git a/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild b/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild
index 7e696e4cf506..db5d1e2f64e2 100644
--- a/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild
+++ b/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild
@@ -1,27 +1,30 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild,v 1.5 2012/08/07 02:33:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild,v 1.6 2014/01/06 13:29:11 jlec Exp $
EAPI=4
-inherit base toolchain-funcs
+inherit eutils toolchain-funcs
MY_P=${PN}_${PV}-1
DESCRIPTION="Generates time-frequency analysis images from wav files"
HOMEPAGE="http://ieee.uow.edu.au/~daniel/software/spectromatic/"
SRC_URI="http://ieee.uow.edu.au/~daniel/software/spectromatic/dist/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND="media-libs/libpng
+RDEPEND="
+ media-libs/libpng:0
sci-libs/gsl"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( README )
+
PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
"${FILESDIR}"/${P}-stringliteral.patch
@@ -32,3 +35,7 @@ pkg_setup() {
tc-export CC
export TOPLEVEL_HOME="${EROOT}/usr"
}
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+}