summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-06-27 16:59:06 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-06-27 16:59:06 +0000
commit429818a1ce4733e36206f92c30cd8d57819291b5 (patch)
tree5bf13492bb7142b07af4c341b48c0be356c80294 /sci-visualization
parentRe-add ~alpha wrt #183038 (diff)
downloadgentoo-2-429818a1ce4733e36206f92c30cd8d57819291b5.tar.gz
gentoo-2-429818a1ce4733e36206f92c30cd8d57819291b5.tar.bz2
gentoo-2-429818a1ce4733e36206f92c30cd8d57819291b5.zip
add new libggi patch, provided by KIMURA Masaru <hiyuh.root@gmail.com> in bug 183427
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gnuplot/ChangeLog7
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-4.2.0-libggi.patch68
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.2.0.ebuild8
3 files changed, 81 insertions, 2 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index 97d327a6d72b..8c1c4ecab4c2 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.19 2007/06/26 21:28:38 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.20 2007/06/27 16:59:06 opfer Exp $
+
+ 27 Jun 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/gnuplot-4.2.0-libggi.patch, gnuplot-4.2.0.ebuild:
+ add new libggi patch, provided by KIMURA Masaru <hiyuh.root@gmail.com> in
+ bug 183427
26 Jun 2007; Christian Faulhammer <opfer@gentoo.org>
-files/gnuplot-3.8j-amd64.diff, -gnuplot-4.2_rc1.ebuild,
diff --git a/sci-visualization/gnuplot/files/gnuplot-4.2.0-libggi.patch b/sci-visualization/gnuplot/files/gnuplot-4.2.0-libggi.patch
new file mode 100644
index 000000000000..94b0beecdebf
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-4.2.0-libggi.patch
@@ -0,0 +1,68 @@
+--- gnuplot-4.2.0/term/ggi.trm.orig 2007-06-27 14:37:05.000000000 +0900
++++ gnuplot-4.2.0/term/ggi.trm 2007-06-27 14:53:54.000000000 +0900
+@@ -116,9 +116,9 @@
+ } GGI_vertex_t;
+
+ TERM_PUBLIC long int GGI_SetTime(const struct timeval* current);
+-TERM_PUBLIC int GGI_from_keysym __PROTO((uint32 keysym));
+-TERM_PUBLIC int GGI_from_button __PROTO((uint32 button));
+-TERM_PUBLIC int GGI_y __PROTO((sint32 y));
++TERM_PUBLIC int GGI_from_keysym __PROTO((uint32_t keysym));
++TERM_PUBLIC int GGI_from_button __PROTO((uint32_t button));
++TERM_PUBLIC int GGI_y __PROTO((int32_t y));
+ TERM_PUBLIC int GGI_dispatch_event __PROTO((const ggi_event* event));
+ TERM_PUBLIC int GGI_eventually_update_modifiers __PROTO((const ggi_event* event, const int add));
+ TERM_PUBLIC int GGI_waitforinput __PROTO((void));
+@@ -134,13 +134,13 @@
+ TERM_PUBLIC void GGI_save_puts __PROTO((GGI_vertex_t* v, const int tag));
+ TERM_PUBLIC void GGI_set_vertex __PROTO((GGI_vertex_t* v, const int x, const int y, const char* str, const int tag));
+ TERM_PUBLIC void GGI_abort_zooming __PROTO((void));
+-TERM_PUBLIC void GGI_put_tmptext __PROTO((int, const char str[]));
+-TERM_PUBLIC void GGI_relative __PROTO((int r[2]));
++TERM_PUBLIC void GGI_put_tmptext __PROTO((int, const char *str));
++TERM_PUBLIC void GGI_relative __PROTO((int *r));
+ TERM_PUBLIC void GGI_clear_hline __PROTO((int x1, int x2, int y));
+ TERM_PUBLIC void GGI_clear_vline __PROTO((int y1, int y2, int x));
+ TERM_PUBLIC void GGI_draw_hline __PROTO((int x1, int x2, int y));
+ TERM_PUBLIC void GGI_draw_vline __PROTO((int y1, int y2, int x));
+-TERM_PUBLIC void GGI_set_clipboard __PROTO((const char[]));
++TERM_PUBLIC void GGI_set_clipboard __PROTO((const char *s));
+ #endif /* USE_MOUSE */
+
+ TERM_PUBLIC int GGI_make_palette __PROTO((t_sm_palette*));
+@@ -645,7 +645,7 @@
+
+ /* translate ggi keysym to gnuplot keysym */
+ TERM_PUBLIC int
+-GGI_from_keysym(uint32 keysym)
++GGI_from_keysym(uint32_t keysym)
+ {
+ switch (keysym) {
+ case GIIUC_BackSpace:
+@@ -811,7 +811,7 @@
+ }
+
+ TERM_PUBLIC int
+-GGI_from_button(uint32 button)
++GGI_from_button(uint32_t button)
+ {
+ switch (button) {
+ case GII_PBUTTON_LEFT:
+@@ -827,7 +827,7 @@
+ }
+
+ TERM_PUBLIC int
+-GGI_y(sint32 y)
++GGI_y(int32_t y)
+ {
+ return GGIymax - y;
+ }
+@@ -1363,7 +1363,7 @@
+ }
+
+ TERM_PUBLIC void
+-GGI_set_clipboard(const char s[])
++GGI_set_clipboard(const char *s)
+ {
+ /* XXX: not implemented */
+ (void) s; /* avoid -Wunused */
diff --git a/sci-visualization/gnuplot/gnuplot-4.2.0.ebuild b/sci-visualization/gnuplot/gnuplot-4.2.0.ebuild
index 96d1d2343c4b..fac80263934f 100644
--- a/sci-visualization/gnuplot/gnuplot-4.2.0.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.0.ebuild,v 1.3 2007/06/19 06:18:02 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.0.ebuild,v 1.4 2007/06/27 16:59:06 opfer Exp $
inherit eutils elisp-common wxwidgets
@@ -46,6 +46,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-libggi.patch
+}
+
src_compile() {
# See bug #156427.
if use tetex ; then