summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-12 11:41:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-12 11:41:54 +0000
commit4a9c73ede2eb9c4596867d4b429961e5034525b0 (patch)
treeff4bd1260a466a853bfa42b41fa73bcee3ffa3d4 /sci-visualization
parentamd64 stable wrt bug #193401 (diff)
downloadgentoo-2-4a9c73ede2eb9c4596867d4b429961e5034525b0.tar.gz
gentoo-2-4a9c73ede2eb9c4596867d4b429961e5034525b0.tar.bz2
gentoo-2-4a9c73ede2eb9c4596867d4b429961e5034525b0.zip
Fixed installation of plugins, fixed non-installation of python scripts, translations, some cleanup
(Portage version: 2.1.4.3)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/qtiplot/ChangeLog9
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.2-systemlibs.patch2
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.2-r1.ebuild100
3 files changed, 109 insertions, 2 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index 7c6569b4ede4..39714bffd1ca 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.14 2008/01/14 18:20:41 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.15 2008/02/12 11:41:53 bicatali Exp $
+
+*qtiplot-0.9.2-r1 (12 Feb 2008)
+
+ 12 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/qtiplot-0.9.2-systemlibs.patch, +qtiplot-0.9.2-r1.ebuild:
+ Fixed installation of plugins, fixed non-installation of python scripts,
+ translations, some cleanup
14 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
files/qtiplot-0.9.2-systemlibs.patch, qtiplot-0.9.2.ebuild:
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.2-systemlibs.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.2-systemlibs.patch
index 0bf440077a6a..74f518ca66e8 100644
--- a/sci-visualization/qtiplot/files/qtiplot-0.9.2-systemlibs.patch
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.2-systemlibs.patch
@@ -84,7 +84,7 @@
#dynamically link against GSL installed system-wide
-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
-+unix:LIBS += $$(system pkg-config --libs gsl)
++unix:LIBS += $$system(pkg-config --libs gsl)
target.path=/usr/lib$${libsuff}/qtiplot/plugins
INSTALLS += target
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.2-r1.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..95a85cd2a7a7
--- /dev/null
+++ b/sci-visualization/qtiplot/qtiplot-0.9.2-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.2-r1.ebuild,v 1.1 2008/02/12 11:41:53 bicatali Exp $
+
+inherit eutils multilib qt4 python
+
+DESCRIPTION="Qt based clone of the Origin plotting package"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+SRC_URI="http://soft.proindependent.com/src/${P}.tar.bz2
+ doc? ( mirror://gentoo/${P}-manual-en.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python doc"
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+CDEPEND=">=x11-libs/qwt-5.0.2
+ >=x11-libs/qwtplot3d-0.2.7
+ >=dev-cpp/muParser-1.28
+ >=sci-libs/liborigin-20071119
+ >=sci-libs/gsl-1.10"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ python? ( >=dev-python/sip-4.5.2 )"
+
+RDEPEND="${CDEPEND}
+ python? ( >=dev-lang/python-2.5
+ dev-python/PyQt4
+ dev-python/pygsl
+ sci-libs/scipy )"
+
+QT4_BUILT_WITH_USE_CHECK="qt3support"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-systemlibs.patch
+ if ! use python; then
+ sed -i \
+ -e '/^SCRIPTING_LANGS += Python/d' \
+ -e '/sipcmd/d' \
+ ${PN}/${PN}.pro || die "sed for python option failed"
+ fi
+
+ # the lib$$suff did not work in the fitRational*.pro files
+ sed -i \
+ -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
+ fitPlugins/fit*/fitRational*.pro \
+ || die "sed fitRational* failed"
+}
+
+src_compile() {
+ eqmake4 ${PN}.pro || die "eqmake4 failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+
+ newicon qtiplot_logo.png qtiplot.png
+ make_desktop_entry qtiplot QtiPlot qtiplot "Education;Science;Math;Qt"
+ doman qtiplot.1 || die "doman failed"
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${WORKDIR}"/manual-en || die "install manual failed"
+ fi
+
+ for l in ${LANGS}; do
+ if use linguas_${l}; then
+ insinto /usr/share/${PN}/translations
+ doins ${PN}/translations/*${l}*.qm || die "install ${l} failed"
+ fi
+ done
+
+ if use python; then
+ cd "${S}"/${PN}
+ insinto /etc
+ doins qtiplotrc.py || die
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins qtiUtil.py || die
+ fi
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize \
+ "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/qtiUtil.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup \
+ "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/qtiUtil*
+}