summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-29 13:38:31 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-29 13:38:31 +0000
commit56e0e54e6820b9ad07d17f8ebda33b4fde759e06 (patch)
tree292d79cddcbf4fae0265ff7c6686947ab7ca9f06 /sci-visualization
parentversion bump wrt #401163 (diff)
downloadgentoo-2-56e0e54e6820b9ad07d17f8ebda33b4fde759e06.tar.gz
gentoo-2-56e0e54e6820b9ad07d17f8ebda33b4fde759e06.tar.bz2
gentoo-2-56e0e54e6820b9ad07d17f8ebda33b4fde759e06.zip
Version BUmp
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/quickplot/ChangeLog10
-rw-r--r--sci-visualization/quickplot/metadata.xml4
-rw-r--r--sci-visualization/quickplot/quickplot-0.10.2.ebuild38
-rw-r--r--sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild10
-rw-r--r--sci-visualization/quickplot/quickplot-0.8.15.ebuild12
5 files changed, 59 insertions, 15 deletions
diff --git a/sci-visualization/quickplot/ChangeLog b/sci-visualization/quickplot/ChangeLog
index bcc9827dd312..e60a982d73d9 100644
--- a/sci-visualization/quickplot/ChangeLog
+++ b/sci-visualization/quickplot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/quickplot
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.13 2011/07/20 16:08:03 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.14 2012/01/29 13:38:31 jlec Exp $
+
+*quickplot-0.10.2 (29 Jan 2012)
+
+ 29 Jan 2012; Justin Lecher <jlec@gentoo.org> quickplot-0.8.13-r1.ebuild,
+ quickplot-0.8.15.ebuild, +quickplot-0.10.2.ebuild, metadata.xml:
+ Version BUmp
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #70723
diff --git a/sci-visualization/quickplot/metadata.xml b/sci-visualization/quickplot/metadata.xml
index 6b26bc1ae6e4..403c74ee6503 100644
--- a/sci-visualization/quickplot/metadata.xml
+++ b/sci-visualization/quickplot/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription>
+ <herd>sci</herd>
+ <longdescription>
Quickplot is a fast interactive 2D plotter with infinite zooming, value
picking, pipe input, and unlimited plots displayed. Quickplot is meant for
looking at your data quickly and of secondary importance is making static
diff --git a/sci-visualization/quickplot/quickplot-0.10.2.ebuild b/sci-visualization/quickplot/quickplot-0.10.2.ebuild
new file mode 100644
index 000000000000..a0db96c12a36
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.10.2.ebuild,v 1.1 2012/01/29 13:38:31 jlec Exp $
+
+EAPI=4
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A fast interactive 2D plotter"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/libsndfile
+ >=sys-libs/readline-0.6.2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
+ mv "${D}"/usr/share/applications/quickplot*.desktop \
+ "${D}"/usr/share/applications/quickplot.desktop || die
+}
diff --git a/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild b/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
index 5ebd4d261276..c6760faf464b 100644
--- a/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
+++ b/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild,v 1.5 2011/03/02 19:35:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild,v 1.6 2012/01/29 13:38:31 jlec Exp $
EAPI="1"
inherit eutils
-DESCRIPTION="A fast interactive 2D plotter."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+DESCRIPTION="A fast interactive 2D plotter"
HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-IUSE="sndfile"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc x86"
+IUSE="sndfile"
RDEPEND="
dev-cpp/gtkmm:2.4
diff --git a/sci-visualization/quickplot/quickplot-0.8.15.ebuild b/sci-visualization/quickplot/quickplot-0.8.15.ebuild
index 978e136c34ae..1af4d18473fe 100644
--- a/sci-visualization/quickplot/quickplot-0.8.15.ebuild
+++ b/sci-visualization/quickplot/quickplot-0.8.15.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.15.ebuild,v 1.2 2011/03/02 19:35:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.15.ebuild,v 1.3 2012/01/29 13:38:31 jlec Exp $
EAPI=2
-inherit eutils autotools
+inherit autotools eutils
-DESCRIPTION="A fast interactive 2D plotter."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+DESCRIPTION="A fast interactive 2D plotter"
HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-IUSE="sndfile"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="sndfile"
RDEPEND="
dev-cpp/gtkmm:2.4