summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-03-26 13:17:07 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-03-26 13:17:07 +0000
commit87db9ef5c63daddad8f03a78c6f276c5e4f8ae0d (patch)
tree4636b0ce84f1d7fca375d66bd206a9db416fe1f1 /sci-visualization
parentmad64 stable (diff)
downloadgentoo-2-87db9ef5c63daddad8f03a78c6f276c5e4f8ae0d.tar.gz
gentoo-2-87db9ef5c63daddad8f03a78c6f276c5e4f8ae0d.tar.bz2
gentoo-2-87db9ef5c63daddad8f03a78c6f276c5e4f8ae0d.zip
Added check for imagemagick's hdri useflag which breaks compilation (see bug #214058).
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/opendx/ChangeLog7
-rw-r--r--sci-visualization/opendx/opendx-4.3.2-r1.ebuild10
-rw-r--r--sci-visualization/opendx/opendx-4.4.4.ebuild10
3 files changed, 24 insertions, 3 deletions
diff --git a/sci-visualization/opendx/ChangeLog b/sci-visualization/opendx/ChangeLog
index 79c59528a0fa..2f6e551b3d26 100644
--- a/sci-visualization/opendx/ChangeLog
+++ b/sci-visualization/opendx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/opendx
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.9 2008/02/28 15:53:25 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.10 2008/03/26 13:17:07 markusle Exp $
+
+ 26 Mar 2008; Markus Dittrich <markusle@gentoo.org> opendx-4.3.2-r1.ebuild,
+ opendx-4.4.4.ebuild:
+ Added check for imagemagick's hdri useflag which breaks compilation
+ (see bug #214058).
28 Feb 2008; Markus Dittrich <markusle@gentoo.org>
+files/20-opendx-revdep, opendx-4.3.2-r1.ebuild, opendx-4.4.4.ebuild:
diff --git a/sci-visualization/opendx/opendx-4.3.2-r1.ebuild b/sci-visualization/opendx/opendx-4.3.2-r1.ebuild
index f0350f2d06d8..6d17c7038fbf 100644
--- a/sci-visualization/opendx/opendx-4.3.2-r1.ebuild
+++ b/sci-visualization/opendx/opendx-4.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.3.2-r1.ebuild,v 1.6 2008/02/28 15:53:25 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.3.2-r1.ebuild,v 1.7 2008/03/26 13:17:07 markusle Exp $
# Set SMP="no" to force disable of SMP compilation.
# Set SMP="yes" to force enable of SMP compilation.
@@ -54,6 +54,14 @@ smp_check() {
linux_chkconfig_present SMP
}
+pkg_setup() {
+ if use imagemagick; then
+ if built_with_use media-gfx/imagemagick hdri; then
+ die "Please re-emerge imagemagick with USE=\"-hdri\" or compilation will fail"
+ fi
+ fi
+}
+
src_compile() {
if has_version '>=sys-kernel/linux-headers-2.6.19' ; then
diff --git a/sci-visualization/opendx/opendx-4.4.4.ebuild b/sci-visualization/opendx/opendx-4.4.4.ebuild
index e2a6d28c1cfb..58eb08adeded 100644
--- a/sci-visualization/opendx/opendx-4.4.4.ebuild
+++ b/sci-visualization/opendx/opendx-4.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.4.4.ebuild,v 1.2 2008/02/28 15:53:25 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.4.4.ebuild,v 1.3 2008/03/26 13:17:07 markusle Exp $
# Set SMP="no" to force disable of SMP compilation.
# Set SMP="yes" to force enable of SMP compilation.
@@ -55,6 +55,14 @@ smp_check() {
linux_chkconfig_present SMP
}
+pkg_setup() {
+ if use imagemagick; then
+ if built_with_use media-gfx/imagemagick hdri; then
+ die "Please re-emerge imagemagick with USE=\"-hdri\" or compilation will fail"
+ fi
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"