summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-11-03 16:48:30 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-11-03 16:48:30 +0000
commitd7e4815b8879354a67691607c6ca1c51c0b3ba8e (patch)
treec5a237916f1b58d8c49cdaf25c41b3b6c19964d0 /sci-visualization
parentKDE SC 4.5.3 Version bump (diff)
downloadgentoo-2-d7e4815b8879354a67691607c6ca1c51c0b3ba8e.tar.gz
gentoo-2-d7e4815b8879354a67691607c6ca1c51c0b3ba8e.tar.bz2
gentoo-2-d7e4815b8879354a67691607c6ca1c51c0b3ba8e.zip
Added a patch by Kacper Kowalik to fix 2 buffer overflows, many thanks. Removed an old version.
(Portage version: 2.2.0_alpha3/cvs/Linux i686)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gle/ChangeLog8
-rw-r--r--sci-visualization/gle/files/gle-4.2.3-parallel.patch21
-rw-r--r--sci-visualization/gle/files/gle-4.2.3b-overflows.patch26
-rw-r--r--sci-visualization/gle/gle-4.2.3.ebuild108
-rw-r--r--sci-visualization/gle/gle-4.2.3b.ebuild5
5 files changed, 36 insertions, 132 deletions
diff --git a/sci-visualization/gle/ChangeLog b/sci-visualization/gle/ChangeLog
index 5dbc4e24f2a6..7e780ff05b78 100644
--- a/sci-visualization/gle/ChangeLog
+++ b/sci-visualization/gle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/gle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.12 2010/10/30 10:48:16 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.13 2010/11/03 16:48:30 grozin Exp $
+
+ 04 Nov 2010; Andrey Grozin <grozin@gentoo.org> -gle-4.2.3.ebuild,
+ -files/gle-4.2.3-parallel.patch, gle-4.2.3b.ebuild,
+ +files/gle-4.2.3b-overflows.patch:
+ Added a patch by Kacper Kowalik to fix 2 buffer overflows, many thanks.
+ Removed an old version.
*gle-4.2.3b (30 Oct 2010)
diff --git a/sci-visualization/gle/files/gle-4.2.3-parallel.patch b/sci-visualization/gle/files/gle-4.2.3-parallel.patch
deleted file mode 100644
index 1eff8c067102..000000000000
--- a/sci-visualization/gle/files/gle-4.2.3-parallel.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/gui/MakefileAC.in.orig 2010-01-06 20:10:04.000000000 +0000
-+++ src/gui/MakefileAC.in 2010-01-06 20:21:15.000000000 +0000
-@@ -84,14 +84,14 @@
- qmake:
- $(QMAKE_PROG) $(QMAKE_OPTS)
-
--domake:
-- $(MAKE_PROG)
-+domake: Makefile
-+ $(MAKE)
-
--repmake:
-+repmake: Makefile
- perl ../../platform/autopackage/qt-replace.pl Makefile
-
- doclean:
-- -$(MAKE_PROG) clean
-+ -$(MAKE) clean
- -@$(RM) qgle install_qgle_name_mac Makefile
- -@$(RMDIR) moc
- -@$(RMDIR) objects
diff --git a/sci-visualization/gle/files/gle-4.2.3b-overflows.patch b/sci-visualization/gle/files/gle-4.2.3b-overflows.patch
new file mode 100644
index 000000000000..2a1650707144
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.3b-overflows.patch
@@ -0,0 +1,26 @@
+Fix buffer overflows
+
+http://bugs.gentoo.org/show_bug.cgi?id=338823
+
+--- src/gle/d_svg.cpp
++++ src/gle/d_svg.cpp
+@@ -636,7 +636,7 @@
+ static int init_done;
+ FILE *fptr;
+ char *s;
+- char inbuff[90];
++ char inbuff[200];
+ if (init_done) return;
+ init_done = true;
+
+--- src/gle/d_ps.cpp
++++ src/gle/d_ps.cpp
+@@ -1002,7 +1002,7 @@
+ static int init_done;
+ FILE *fptr;
+ char *s;
+- char inbuff[90];
++ char inbuff[200];
+ if (init_done) return;
+ init_done = true;
+ \ No newline at end of file
diff --git a/sci-visualization/gle/gle-4.2.3.ebuild b/sci-visualization/gle/gle-4.2.3.ebuild
deleted file mode 100644
index 3306862a0ec1..000000000000
--- a/sci-visualization/gle/gle-4.2.3.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.3.ebuild,v 1.1 2010/09/27 10:00:15 grozin Exp $
-
-EAPI=2
-inherit eutils elisp-common qt4 flag-o-matic autotools
-
-DESCRIPTION="Graphics Layout Engine"
-HOMEPAGE="http://glx.sourceforge.net/"
-MY_P=${PN}-graphics-${PV}
-MAN_V=4.2.2
-SRC_URI="mirror://sourceforge/glx/${MY_P}f-src.tar.gz
- doc? ( mirror://sourceforge/glx/${PN}-manual-${MAN_V}.pdf
- mirror://sourceforge/glx/GLEusersguide.pdf )"
-SLOT="0"
-LICENSE="BSD-2 emacs? ( GPL-2 ) qt4? ( GPL-2 )"
-IUSE="X qt4 jpeg png tiff doc emacs vim-syntax"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="sys-libs/ncurses
- X? ( x11-libs/libX11 )
- qt4? ( x11-libs/qt-gui:4 )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )
- tiff? ( media-libs/tiff )
- emacs? ( virtual/emacs )"
-
-RDEPEND="${DEPEND}
- app-text/ghostscript-gpl
- virtual/latex-base
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
-
-S="${WORKDIR}"/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-parallel.patch
- eaclocal
- eautoconf
-}
-
-src_configure() {
- # CPPFLAGS are understood as C++ flags
- append-cppflags ${CXXFLAGS}
- econf \
- --without-rpath \
- --with-manip \
- $(use_with qt4 qt /usr) \
- $(use_with X x) \
- $(use_with jpeg) \
- $(use_with png) \
- $(use_with tiff)
-}
-
-src_compile() {
- emake || die "emake failed"
- if use emacs; then
- cd contrib/editors/highlighting
- mv ${PN}-emacs.el ${PN}-mode.el
- elisp-compile ${PN}-mode.el || die
- fi
-}
-
-src_install() {
- # -jN failed to install some data files
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
- #emake DESTDIR="${D}" install || die "emake install failed"
- rmdir "${D}"/usr/share/doc/gle-graphics || die "rmdir gle-graphics failed"
- dodoc README.txt
-
- if use qt4; then
- newicon src/gui/images/gle_icon.png gle.png
- make_desktop_entry qgle GLE gle
- newdoc src/gui/readme.txt gui_readme.txt
- fi
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins "${DISTDIR}"/${PN}-manual-${MAN_V}.pdf \
- "${DISTDIR}"/GLEusersguide.pdf
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/editors/highlighting/gle-mode.{el,elc} || die
- elisp-site-file-install "${FILESDIR}"/64gle-gentoo.el || die
- fi
-
- if use vim-syntax ; then
- dodir /usr/share/vim/vimfiles/ftplugins \
- /usr/share/vim/vimfiles/indent \
- /usr/share/vim/vimfiles/syntax
- cd contrib/editors/highlighting/vim
- chmod 644 ftplugin/* indent/* syntax/*
- insinto /usr/share/vim/vimfiles/ftplugins
- doins ftplugin/* || die
- insinto /usr/share/vim/vimfiles/indent
- doins indent/* || die
- insinto /usr/share/vim/vimfiles/syntax
- doins syntax/* || die
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-visualization/gle/gle-4.2.3b.ebuild b/sci-visualization/gle/gle-4.2.3b.ebuild
index 5bb87759aef6..3f03504e8b76 100644
--- a/sci-visualization/gle/gle-4.2.3b.ebuild
+++ b/sci-visualization/gle/gle-4.2.3b.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.3b.ebuild,v 1.1 2010/10/30 10:48:16 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.3b.ebuild,v 1.2 2010/11/03 16:48:30 grozin Exp $
EAPI=2
-inherit eutils elisp-common qt4 flag-o-matic autotools
+inherit eutils elisp-common qt4-r2 flag-o-matic autotools
DESCRIPTION="Graphics Layout Engine"
HOMEPAGE="http://glx.sourceforge.net/"
@@ -34,6 +34,7 @@ S="${WORKDIR}"/${MY_P}
src_prepare() {
epatch "${FILESDIR}"/${P}-parallel.patch
+ epatch "${FILESDIR}"/${P}-overflows.patch
eaclocal
eautoconf
}