summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-05 08:42:00 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-05 08:42:00 +0000
commitda5d1f376ae5f683b0a7e7887bcbbed783fd3926 (patch)
treeb049672a02fe3177672c142a24eb81403b38d4fe /sci-visualization
parentEAPI=5 (diff)
downloadgentoo-2-da5d1f376ae5f683b0a7e7887bcbbed783fd3926.tar.gz
gentoo-2-da5d1f376ae5f683b0a7e7887bcbbed783fd3926.tar.bz2
gentoo-2-da5d1f376ae5f683b0a7e7887bcbbed783fd3926.zip
sci-visualization/quickplot: Version Bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/quickplot/ChangeLog7
-rw-r--r--sci-visualization/quickplot/quickplot-0.10.8.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sci-visualization/quickplot/ChangeLog b/sci-visualization/quickplot/ChangeLog
index 2f4bd4d36278..1b321e06b689 100644
--- a/sci-visualization/quickplot/ChangeLog
+++ b/sci-visualization/quickplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/quickplot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.22 2015/02/04 20:37:37 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.23 2015/02/05 08:42:00 jlec Exp $
+
+*quickplot-0.10.8 (05 Feb 2015)
+
+ 05 Feb 2015; Justin Lecher <jlec@gentoo.org> +quickplot-0.10.8.ebuild:
+ Version Bump
04 Feb 2015; Manuel Rüger <mrueg@gentoo.org>
-files/quickplot-0.8.13-gcc43.patch,
diff --git a/sci-visualization/quickplot/quickplot-0.10.8.ebuild b/sci-visualization/quickplot/quickplot-0.10.8.ebuild
new file mode 100644
index 000000000000..35163fdd2485
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.10.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.10.8.ebuild,v 1.1 2015/02/05 08:42:00 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A fast interactive 2D plotter"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/libsndfile
+ >=sys-libs/readline-0.6.2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed '/libquickplot_la_LIBADD/s:$: -lm:g' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
+ mv "${ED}"/usr/share/applications/quickplot*.desktop \
+ "${ED}"/usr/share/applications/quickplot.desktop || die
+}