summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-01 19:05:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-01 19:05:53 +0000
commitdd005f519640f78169d83527b6de81e32cb13b89 (patch)
tree45e88ac843471b2fdd590b44f25f2b004596d7e7 /sci-visualization
parentRevbump with upstream fixes, attempt to fix bug #223433. Remove old. (diff)
downloadgentoo-2-dd005f519640f78169d83527b6de81e32cb13b89.tar.gz
gentoo-2-dd005f519640f78169d83527b6de81e32cb13b89.tar.bz2
gentoo-2-dd005f519640f78169d83527b6de81e32cb13b89.zip
Removed doc building because buggy. Now unzip the bundled docs and link in proper directory, fixing bug #341753. Updated longdescription to reflect mayavi2
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/mayavi/ChangeLog8
-rw-r--r--sci-visualization/mayavi/mayavi-3.4.1.ebuild61
-rw-r--r--sci-visualization/mayavi/metadata.xml21
3 files changed, 49 insertions, 41 deletions
diff --git a/sci-visualization/mayavi/ChangeLog b/sci-visualization/mayavi/ChangeLog
index 1c25875e6d5c..0cf71ec008bd 100644
--- a/sci-visualization/mayavi/ChangeLog
+++ b/sci-visualization/mayavi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/mayavi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/ChangeLog,v 1.19 2011/02/01 01:56:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/ChangeLog,v 1.20 2011/02/01 19:05:53 bicatali Exp $
+
+ 01 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> mayavi-3.4.1.ebuild,
+ metadata.xml:
+ Removed doc building because buggy. Now unzip the bundled docs and link in
+ proper directory, fixing bug #341753. Updated longdescription to reflect
+ mayavi2
01 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-mayavi-1.5-r1.ebuild, -files/mayavi-1.5-tkinter_objects.patch:
diff --git a/sci-visualization/mayavi/mayavi-3.4.1.ebuild b/sci-visualization/mayavi/mayavi-3.4.1.ebuild
index a93d0768fb86..7d32946a72af 100644
--- a/sci-visualization/mayavi/mayavi-3.4.1.ebuild
+++ b/sci-visualization/mayavi/mayavi-3.4.1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/mayavi-3.4.1.ebuild,v 1.2 2011/01/30 23:13:11 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/mayavi-3.4.1.ebuild,v 1.3 2011/02/01 19:05:53 bicatali Exp $
EAPI="3"
PYTHON_DEPEND="2"
-VIRTUALX_REQUIRED="manual"
-inherit distutils eutils virtualx
+inherit distutils eutils
MY_PN="Mayavi"
MY_P="${MY_PN}-${PV}"
@@ -33,12 +32,7 @@ RDEPEND=">=dev-python/apptools-3.4.1
>=sci-libs/vtk-5[python]
qt4? ( dev-python/PyQt4[X,opengl] )"
DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
+ doc? ( app-arch/unzip )"
S="${WORKDIR}"/${MY_P}
@@ -50,45 +44,40 @@ pkg_setup() {
python_pkg_setup
}
-src_prepare() {
- distutils_src_prepare
-
- sed -e "s/self.run_command('build_docs')/pass/" -i setup.py || die "sed setup.py failed"
-}
-
-src_compile() {
- distutils_src_compile
-
+src_unpack() {
+ default
if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- doc_generation() {
- emake html || die "Generation of documentation failed"
- }
- maketype="doc_generation" virtualmake
- popd > /dev/null
+ cd "${S}"/docs
+ # building docs is buggy and requires X
+ # so use the bundled ones
+ unpack ./html.zip
+ rm -rf html/*/_sources
fi
}
+src_prepare() {
+ distutils_src_prepare
+ sed -i \
+ -e "s/self.run_command('gen_docs')/pass/" \
+ -e "s/self.run_command('build_docs')/pass/" \
+ setup.py || die "sed setup.py failed"
+}
+
src_install() {
find -name "*LICENSE*.txt" -delete
distutils_src_install
+ insinto /usr/share/doc/${PF}
if use doc; then
- pushd docs/build/mayavi/html > /dev/null
- insinto /usr/share/doc/${PF}/html/mayavi
- doins -r [a-z]* _downloads _images _static || die "Installation of documentation failed"
- popd > /dev/null
-
- pushd docs/build/tvtk/html > /dev/null
- insinto /usr/share/doc/${PF}/html/tvtk
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
+ doins -r docs/html || die "Installation of documentation failed"
+ dosym /usr/share/doc/${PF}/html/mayavi \
+ $(python_get_sitedir)/enthought/mayavi/html
+ dosym /usr/share/doc/${PF}/html/tvtk \
+ $(python_get_sitedir)/enthought/tvtk/html
fi
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
+ doins -r examples || die "Installation of examples failed"
fi
newicon enthought/mayavi/core/ui/images/m2.png mayavi2.png
diff --git a/sci-visualization/mayavi/metadata.xml b/sci-visualization/mayavi/metadata.xml
index 011c81d389c6..54bc70ee9f0d 100644
--- a/sci-visualization/mayavi/metadata.xml
+++ b/sci-visualization/mayavi/metadata.xml
@@ -3,9 +3,22 @@
<pkgmetadata>
<herd>sci</herd>
<longdescription lang="en">
-MayaVi is a scientific data visualizer. It is written in Python and uses the
-Visualization Toolkit (VTK) for the visualization. An easy to use GUI using
-Tkinter is provided. It is also cross platform and should run on any platform
-where both Python and VTK are available.
+ Mayavi2 is a general purpose, cross-platform tool for 3-D scientific
+ data visualization. Its features include:
+ * Visualization of scalar, vector and tensor data in 2 and 3 dimensions.
+ * Easy scriptability using Python.
+ * Easy extendibility via custom sources, modules, and data filters.
+ * Reading several file formats: VTK (legacy and XML), PLOT3D, etc.
+ * Saving of visualizations.
+ * Saving rendered visualization in a variety of image formats.
+ * Convenient functionality for rapid scientific plotting via mlab
+
+ Mayavi2 has been designed with scriptability and extensibility in
+ mind. Mayavi2 provides a mayavi2 application which is usable by
+ itself. However, Mayavi2 may also be used as a plotting engine, in
+ scripts, like with matplotlib or gnuplot, as well as a library for
+ interactive visualizations in any other application. It may also be
+ used as an Envisage plug-in which allows it to be embedded in other
+ Envisage based applications natively.
</longdescription>
</pkgmetadata>