summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-04-26 13:53:43 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-04-26 13:53:43 +0000
commite29c168aa967f90e2b19bbf7545395c179c19617 (patch)
treea6aca3500310b8254bbaa11eadd277584142d234 /sci-visualization
parentPunt old versions (diff)
downloadgentoo-2-e29c168aa967f90e2b19bbf7545395c179c19617.tar.gz
gentoo-2-e29c168aa967f90e2b19bbf7545395c179c19617.tar.bz2
gentoo-2-e29c168aa967f90e2b19bbf7545395c179c19617.zip
Version bump. Dropped ffmpeg keyword for now since the build fails due to undefined macros in one of the ffmpeg headers.
(Portage version: 2.1.2.4)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/ChangeLog10
-rw-r--r--sci-visualization/paraview/files/digest-paraview-2.6.13
-rw-r--r--sci-visualization/paraview/paraview-2.6.1.ebuild110
3 files changed, 122 insertions, 1 deletions
diff --git a/sci-visualization/paraview/ChangeLog b/sci-visualization/paraview/ChangeLog
index 1fc03038e73f..5f84e7ac32be 100644
--- a/sci-visualization/paraview/ChangeLog
+++ b/sci-visualization/paraview/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-visualization/paraview
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.5 2007/02/20 14:17:05 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.6 2007/04/26 13:53:43 markusle Exp $
+
+*paraview-2.6.1 (24 Apr 2007)
+
+ 24 Apr 2007; Markus Dittrich <markusle@gentoo.org> +paraview-2.6.1.ebuild:
+ Version bump. Dropped ffmpeg keyword for now since the build
+ fails due to undefined macros in one of the ffmpeg headers.
+ Thanks much to Sebastien Fabbro <bicatali@gentoo.org>
+ for his ebuild.
*paraview-2.6.0 (20 Feb 2007)
diff --git a/sci-visualization/paraview/files/digest-paraview-2.6.1 b/sci-visualization/paraview/files/digest-paraview-2.6.1
new file mode 100644
index 000000000000..e5d522c63604
--- /dev/null
+++ b/sci-visualization/paraview/files/digest-paraview-2.6.1
@@ -0,0 +1,3 @@
+MD5 55b3b4a47c7c64e266425a9e7e413ac6 ParaView-2.6.1.tar.gz 75658607
+RMD160 0625a7008d1456cf82e1e20575323c26eba14e34 ParaView-2.6.1.tar.gz 75658607
+SHA256 29c0459b5d829ad8683ffad8ad9bcd4625024f00767ca2a5834542eb59886859 ParaView-2.6.1.tar.gz 75658607
diff --git a/sci-visualization/paraview/paraview-2.6.1.ebuild b/sci-visualization/paraview/paraview-2.6.1.ebuild
new file mode 100644
index 000000000000..ef8b8b8ab481
--- /dev/null
+++ b/sci-visualization/paraview/paraview-2.6.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-2.6.1.ebuild,v 1.1 2007/04/26 13:53:43 markusle Exp $
+
+inherit distutils eutils flag-o-matic toolchain-funcs versionator python
+
+MY_PN="${PN/p/P}"
+MY_PN="${MY_PN/v/V}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ParaView is a powerful scientific data visualization application"
+HOMEPAGE="http://www.paraview.org"
+SRC_URI="http://www.${MY_PN}.org/files/v2.6/${MY_P}.tar.gz"
+
+LICENSE="paraview"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="mpi python hdf5 doc examples threads"
+RDEPEND="hdf5? ( sci-libs/hdf5 )
+ doc? ( app-doc/doxygen )
+ mpi? ( virtual/mpi )
+ python? ( >=dev-lang/python-2.0 )
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ dev-libs/expat
+ sys-libs/zlib
+ media-libs/freetype
+ virtual/opengl
+ dev-lang/tcl
+ dev-lang/tk
+ || ( x11-libs/libXmu virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.3"
+
+PVLIBDIR="$(get_libdir)/${MY_PN}-$(get_version_component_range 1-2)"
+BUILDDIR="${WORKDIR}/build"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir "${BUILDDIR}" || die "Failed to generate build directory"
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.6.0-hdf5-zlib.patch
+ epatch "${FILESDIR}"/${PN}-2.6.0-include.patch
+}
+
+src_compile() {
+ cd "${BUILDDIR}"
+ local CMAKE_VARIABLES=""
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DCMAKE_BACKWARDS_COMPATIBILITY=2.2"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPV_INSTALL_LIB_DIR:PATH=/${PVLIBDIR}"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DCMAKE_SKIP_RPATH:BOOL=YES"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_RPATH:BOOL=NO"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DCMAKE_INSTALL_PREFIX:PATH=/usr"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DBUILD_SHARED_LIBS:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_SYSTEM_JPEG:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_SYSTEM_PNG:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_SYSTEM_TIFF:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_SYSTEM_ZLIB:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_SYSTEM_EXPAT:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DEXPAT_INCLUDE_DIR:PATH=/usr/include"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DEXPAT_LIBRARY=/usr/$(get_libdir)/libexpat.so"
+
+ if use hdf5; then
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPARAVIEW_USE_SYSTEM_HDF5:BOOL=ON"
+ fi
+
+ if use mpi; then
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_MPI:BOOL=ON"
+ fi
+
+ if use python; then
+ python_version
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPARAVIEW_WRAP_PYTHON:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_INCLUDE_PATH:PATH=/usr/include/python${PYVER}"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_LIBRARY:PATH=/usr/$(get_libdir)/libpython${PYVER}.so"
+ fi
+
+ use doc && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DBUILD_DOCUMENTATION:BOOL=ON"
+
+ if use examples; then
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DBUILD_EXAMPLES:BOOL=ON"
+ else
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DBUILD_EXAMPLES:BOOL=OFF"
+ fi
+
+ if use threads; then
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DCMAKE_USE_PTHREADS:BOOL=ON"
+ else
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DCMAKE_USE_PTHREADS:BOOL=OFF"
+ fi
+
+ cmake ${CMAKE_VARIABLES} ${S} \
+ || die "cmake configuration failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ cd "${BUILDDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # set up the environment
+ echo "LDPATH=/usr/${PVLIBDIR}" >> ${T}/40${PN}
+ doenvd ${T}/40${PN}
+}