summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 17:03:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 17:03:33 +0000
commite4a22f9a1f8dfd2b4b9ca4fe975788c6849019bb (patch)
treec91589d14a8ad3bcf732d1ce6e4c9e72e3a624f2 /sci-visualization
parentDelete call to deprecated python_version(). (diff)
downloadgentoo-2-e4a22f9a1f8dfd2b4b9ca4fe975788c6849019bb.tar.gz
gentoo-2-e4a22f9a1f8dfd2b4b9ca4fe975788c6849019bb.tar.bz2
gentoo-2-e4a22f9a1f8dfd2b4b9ca4fe975788c6849019bb.zip
Use Python 2. Delete call to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/pyxplot/ChangeLog6
-rw-r--r--sci-visualization/pyxplot/pyxplot-0.7.1.ebuild14
2 files changed, 15 insertions, 5 deletions
diff --git a/sci-visualization/pyxplot/ChangeLog b/sci-visualization/pyxplot/ChangeLog
index 783281943d1a..7c3949a1d04c 100644
--- a/sci-visualization/pyxplot/ChangeLog
+++ b/sci-visualization/pyxplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/pyxplot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/ChangeLog,v 1.16 2010/02/04 16:55:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/ChangeLog,v 1.17 2010/06/04 17:03:33 arfrever Exp $
+
+ 04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pyxplot-0.7.1.ebuild:
+ Use Python 2. Delete call to deprecated python_version().
04 Feb 2010; Markos Chandras <hwoarang@gentoo.org> pyxplot-0.7.1.ebuild:
Stable on amd64 wrt bug #270481
diff --git a/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild b/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
index e927b64d3462..436bf9aecd4f 100644
--- a/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
+++ b/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild,v 1.3 2010/02/04 16:55:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild,v 1.4 2010/06/04 17:03:33 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
-EAPI=2
inherit eutils python
DESCRIPTION="Gnuplot like graphing program publication-quality figures"
@@ -21,11 +23,15 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
- python_version
sed -i \
-e "s:^\(USRDIR=\).*:\1/usr:g" \
- -e "s:^\(SRCDIR=\).*:\1/usr/$(get_libdir)/python${PYVER}/${PN}:g" \
+ -e "s:^\(SRCDIR=\).*:\1$(python_get_sitedir)/${PN}:g" \
-e 's:^\(MANDIR=\).*:\1${USRDIR}/share/man/man1:g' \
-e "s:^\(DOCDIR=\).*:\1\${USRDIR}/share/doc/${PF}:g" \
-e '/install:/,$s:${\(SRC\|BIN\|DOC\|MAN\)DIR:${DESTDIR}/${\1DIR:g' \