summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjoern Brauel <bjb@gentoo.org>2002-09-21 15:07:18 +0000
committerBjoern Brauel <bjb@gentoo.org>2002-09-21 15:07:18 +0000
commit5f416e0feeb98be60a91039a1d315d16929fcdb0 (patch)
treead194f2e603a40f0e4eb3e240bc0a3855524762a /sys-apps/aboot
parentremoved old versions. cleanout of gnome (diff)
downloadgentoo-2-5f416e0feeb98be60a91039a1d315d16929fcdb0.tar.gz
gentoo-2-5f416e0feeb98be60a91039a1d315d16929fcdb0.tar.bz2
gentoo-2-5f416e0feeb98be60a91039a1d315d16929fcdb0.zip
initial ebuild for the alpha bootloader aboot
Diffstat (limited to 'sys-apps/aboot')
-rw-r--r--sys-apps/aboot/ChangeLog7
-rw-r--r--sys-apps/aboot/aboot-0.9-r1.ebuild76
-rw-r--r--sys-apps/aboot/files/aboot.conf10
-rw-r--r--sys-apps/aboot/files/digest-aboot-0.9-r11
4 files changed, 94 insertions, 0 deletions
diff --git a/sys-apps/aboot/ChangeLog b/sys-apps/aboot/ChangeLog
new file mode 100644
index 000000000000..490a0fa001cf
--- /dev/null
+++ b/sys-apps/aboot/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for sys-kernel/alpha-sources
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+
+*aboot-0.9-r1 (21 Sep 2002)
+ 21 Sep 2002; Bjoern Brauel <bjb@gentoo.org>
+ Added initial ebuild
+
diff --git a/sys-apps/aboot/aboot-0.9-r1.ebuild b/sys-apps/aboot/aboot-0.9-r1.ebuild
new file mode 100644
index 000000000000..c3369781312b
--- /dev/null
+++ b/sys-apps/aboot/aboot-0.9-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Alpha Linux boot loader for srm"
+SRC_URI="http://aboot.sourceforge.net/tarballs/aboot-0.9bpre.tar.bz2"
+HOMEPAGE="http://aboot.sourceforge.net/"
+
+KEYWORDS="alpha"
+SLOT="0"
+LICENSE="gpl-2"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ mv ${WORKDIR}/aboot-0.9bpre ${WORKDIR}/${P}
+
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:/usr/man:/usr/share/man:" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ emake || die
+}
+
+src_install() {
+
+ dodir /{boot,sbin,usr/share/man/man5}
+ make \
+ root=${D} \
+ bindir=${D}/sbin \
+ bootdir=${D}/boot \
+ mandir=${D}/usr/share/man \
+ install
+
+ dodoc COPYING ChangeLog INSTALL README TODO aboot.conf
+
+ dodir /etc
+ insinto /etc
+ newins ${FILESDIR}/aboot.conf aboot.conf.example
+
+}
+
+pkg_postinst() {
+
+ einfo "To make aboot install a new bootloader on your harddisk follow"
+ einfo "these steps:"
+ einfo ""
+ einfo " - edit the file /etc/aboot.conf"
+ einfo " - cd /boot"
+ einfo " - swriteboot -c2 /dev/sda bootlx"
+ einfo " This will install a new bootsector on /dev/sda and aboot will"
+ einfo " use the second partition on this device to lookup kernel and "
+ einfo " initrd (as described in the aboot.conf file)"
+ einfo ""
+ einfo "IMPORTANT :"
+ einfo ""
+ einfo "The partition table of your boot device has to contain "
+ einfo "a BSD-DISKLABEL and the first 12 megabytes of your boot device"
+ einfo "must not be part of a partition as aboot will write its bootloader"
+ einfo "in there and not as with most x86 bootloaders into the "
+ einfo "master boot sector. If your partition table does not reflect this"
+ einfo "you are going to destroy your installation !"
+ einfo "Also note that aboot currently only supports ext2/3 partitions"
+ einfo "to boot from."
+
+}
+
diff --git a/sys-apps/aboot/files/aboot.conf b/sys-apps/aboot/files/aboot.conf
new file mode 100644
index 000000000000..02114138e938
--- /dev/null
+++ b/sys-apps/aboot/files/aboot.conf
@@ -0,0 +1,10 @@
+#
+# aboot default configurations
+#
+0:3/vmlinux.gz ro root=/dev/sda2
+1:3/vmlinux.old.gz ro root=/dev/sda2
+2:3/vmlinux.new.gz ro root=/dev/sda2
+3:3/vmlinux ro root=/dev/sda2
+8:- ro root=/dev/sda2 # fs less boot of raw kernel
+9:0/- ro root=/dev/sda2 # fs less boot of (compressed) ECOFF kernel
+-
diff --git a/sys-apps/aboot/files/digest-aboot-0.9-r1 b/sys-apps/aboot/files/digest-aboot-0.9-r1
new file mode 100644
index 000000000000..63431ca13414
--- /dev/null
+++ b/sys-apps/aboot/files/digest-aboot-0.9-r1
@@ -0,0 +1 @@
+MD5 eabf1163a4bf25c861b30226678c5490 aboot-0.9bpre.tar.bz2 11373