summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-09 03:02:04 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-09 03:02:04 +0000
commitd461c2ec113ee085c4b65362fb85a1d35fde71bc (patch)
tree4478f0c256dca19c09d94854c24d0156bf0374c0 /sys-apps/acl
parentBump (diff)
downloadgentoo-2-d461c2ec113ee085c4b65362fb85a1d35fde71bc.tar.gz
gentoo-2-d461c2ec113ee085c4b65362fb85a1d35fde71bc.tar.bz2
gentoo-2-d461c2ec113ee085c4b65362fb85a1d35fde71bc.zip
Version bump #292842 by Mr. Anderson.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/ChangeLog10
-rw-r--r--sys-apps/acl/acl-2.2.49.ebuild64
-rw-r--r--sys-apps/acl/files/acl-2.2.49-quote-strchr.patch25
3 files changed, 97 insertions, 2 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index 422fd2591fb5..8c5bd14196c0 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/acl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.101 2009/12/29 01:39:03 abcd Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.102 2010/01/09 03:02:04 vapier Exp $
+
+*acl-2.2.49 (09 Jan 2010)
+
+ 09 Jan 2010; Mike Frysinger <vapier@gentoo.org> +acl-2.2.49.ebuild,
+ +files/acl-2.2.49-quote-strchr.patch:
+ Version bump #292842 by Mr. Anderson.
29 Dec 2009; Jonathan Callen <abcd@gentoo.org> acl-2.2.47-r1.ebuild,
+files/acl-2.2.47-search-PATH.patch:
diff --git a/sys-apps/acl/acl-2.2.49.ebuild b/sys-apps/acl/acl-2.2.49.ebuild
new file mode 100644
index 000000000000..42ce465ce038
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.49.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.49.ebuild,v 1.1 2010/01/09 03:02:04 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="access control list utilities, libraries and headers"
+HOMEPAGE="http://savannah.nongnu.org/projects/acl"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.src.tar.gz
+ nfs? ( http://www.citi.umich.edu/projects/nfsv4/linux/acl-patches/2.2.42-2/acl-2.2.42-CITI_NFS4_ALL-2.dif )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="nfs nls"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nfs? ( net-libs/libnfsidmap )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${P}.src.tar.gz
+ cd "${S}"
+ if use nfs ; then
+ cp "${DISTDIR}"/acl-2.2.42-CITI_NFS4_ALL-2.dif . || die
+ sed -i \
+ -e '/^diff --git a.debian.changelog b.debian.changelog/,/^diff --git/d' \
+ acl-2.2.42-CITI_NFS4_ALL-2.dif || die
+ epatch acl-2.2.42-CITI_NFS4_ALL-2.dif
+ fi
+ epatch "${FILESDIR}"/${P}-quote-strchr.patch
+ sed -i \
+ -e '/^as_dummy=/s:=":="$PATH$PATH_SEPARATOR:' \
+ configure # hack PATH with AC_PATH_PROG
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ strip-linguas po
+}
+
+src_compile() {
+ use prefix || EPREFIX=
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir) \
+ --bindir="${EPREFIX}"/bin
+
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-dev install-lib || die
+ prepalldocs
+
+ # move shared libs to /
+ gen_usr_ldscript -a acl
+}
diff --git a/sys-apps/acl/files/acl-2.2.49-quote-strchr.patch b/sys-apps/acl/files/acl-2.2.49-quote-strchr.patch
new file mode 100644
index 000000000000..d2510da24eea
--- /dev/null
+++ b/sys-apps/acl/files/acl-2.2.49-quote-strchr.patch
@@ -0,0 +1,25 @@
+From 7565e4fcb9209782ed02f3caff246cf5ea816674 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 8 Jan 2010 21:28:31 -0500
+Subject: [PATCH] quote: pull in string.h for strchr prototype
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ libmisc/quote.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/libmisc/quote.c b/libmisc/quote.c
+index f98c887..bf8f9eb 100644
+--- a/libmisc/quote.c
++++ b/libmisc/quote.c
+@@ -20,6 +20,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <ctype.h>
++#include <string.h>
+ #include "misc.h"
+
+ const char *quote(const char *str, const char *quote_chars)
+--
+1.6.6
+