summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-18 00:54:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-18 00:54:39 +0000
commit1140f2713558dc42faf82a25d8d0a2e87cbe407f (patch)
tree9a78ae20f6d5474f82b11b6bdb06f1faca81ef4a /sys-apps/busybox
parentFix permission of $DATADIR (again) bug #95320 (diff)
downloadgentoo-2-1140f2713558dc42faf82a25d8d0a2e87cbe407f.tar.gz
gentoo-2-1140f2713558dc42faf82a25d8d0a2e87cbe407f.tar.bz2
gentoo-2-1140f2713558dc42faf82a25d8d0a2e87cbe407f.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog7
-rw-r--r--sys-apps/busybox/busybox-1.01.ebuild241
-rw-r--r--sys-apps/busybox/files/digest-busybox-1.012
3 files changed, 249 insertions, 1 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 86ddf8241a3e..20c2f2c5b217 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.72 2005/08/03 01:31:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.73 2005/08/18 00:54:39 vapier Exp $
+
+*busybox-1.01 (18 Aug 2005)
+
+ 18 Aug 2005; Mike Frysinger <vapier@gentoo.org> +busybox-1.01.ebuild:
+ Version bump.
*busybox-1.1_pre20050802 (03 Aug 2005)
diff --git a/sys-apps/busybox/busybox-1.01.ebuild b/sys-apps/busybox/busybox-1.01.ebuild
new file mode 100644
index 000000000000..53f8cef04973
--- /dev/null
+++ b/sys-apps/busybox/busybox-1.01.ebuild
@@ -0,0 +1,241 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.01.ebuild,v 1.1 2005/08/18 00:54:39 vapier Exp $
+
+inherit eutils
+
+#SNAPSHOT=20040726
+SNAPSHOT=""
+
+DESCRIPTION="Utilities for rescue and embedded systems"
+HOMEPAGE="http://www.busybox.net/"
+if [[ -n ${SNAPSHOT} ]] ; then
+ MY_P=${PN}
+ SRC_URI="http://www.busybox.net/downloads/snapshots/${PN}-${SNAPSHOT}.tar.bz2"
+else
+ MY_P=${PN}-${PV/_/-}
+ SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.bz2"
+fi
+SRC_URI="${SRC_URI} mirror://gentoo/${PN}-1.00-e2fsprogs.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug static savedconfig netboot floppyboot make-symlinks"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+# <pebenito> then eventually turning on selinux would mean
+# adding a dep: selinux? ( sys-libs/libselinux )
+
+busybox_set_env() {
+ type -p ${CHOST}-ar > /dev/null && export CROSS=${CHOST}-
+ # Don't let KBUILD_OUTPUT mess us up #88088
+ unset KBUILD_OUTPUT
+}
+
+busybox_config_option() {
+ case $1 in
+ y) sed -i -e "s:.*CONFIG_$2.*set:CONFIG_$2=y:g" .config;;
+ n) sed -i -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" .config;;
+ Y) echo "CONFIG_$2=y" >> .config;;
+ N) echo "CONFIG_$2=n" >> .config;;
+ *) use $1 \
+ && busybox_config_option y $2 \
+ || busybox_config_option n $2
+ return 0
+ ;;
+ esac
+ einfo $(grep "CONFIG_$2[= ]" .config)
+}
+
+src_unpack() {
+ busybox_set_env
+ unpack ${A}
+ cd "${S}"
+
+ # patches for 1.00 go here.
+ epatch "${FILESDIR}"/1.00/busybox-read-timeout.patch
+ epatch "${FILESDIR}"/1.00/readlink-follow.patch
+ epatch "${FILESDIR}"/1.00/bash-tests.patch
+ epatch "${FILESDIR}"/1.00/standalone.patch
+ epatch "${FILESDIR}"/1.00/nice.patch
+ epatch "${FILESDIR}"/1.00/printenv.patch
+ epatch "${FILESDIR}"/1.00/sum.patch
+ epatch "${FILESDIR}"/1.00/bb.patch
+ epatch "${WORKDIR}"/${PN}-1.00-e2fsprogs.patch
+
+ # check for a busybox config before making one of our own.
+ # if one exist lets return and use it.
+ # fine grained config control for user defined busybox configs.
+ # [package]-[version]-[revision].config
+ # [package]-[version].config
+ # [package].config
+
+ if use savedconfig ; then
+ [[ -r .config ]] && rm .config
+ for conf in ${PN}-${PV}-${PR} ${PN}-${PV} ${PN}; do
+ configfile=${ROOT}/etc/${PN}/${CHOST}/${conf}.config
+ [[ -r ${configfile} ]] || configfile=/etc/${PN}/${CHOST}/${conf}.config
+ if [[ -r ${configfile} ]] ; then
+ cp ${configfile} ${S}/.config
+ break
+ fi
+ done
+ if [[ -r ${S}/.config ]] ; then
+ einfo "Found your ${configfile} and using it."
+ return 0
+ fi
+ fi
+ if use netboot ; then
+ cp "${FILESDIR}"/config-netboot .config
+ sed -i \
+ -e '/DEFAULT_SCRIPT/s:/share/udhcpc/default.script:/lib/udhcpc.script:' \
+ networking/udhcp/libbb_udhcp.h \
+ || die "fixing netboot/udhcpc"
+ elif use floppyboot ; then
+ cp "${FILESDIR}"/config-floppyboot .config
+ fi
+
+ # setup the config file
+ make allyesconfig > /dev/null
+ busybox_config_option n DMALLOC
+ busybox_config_option n FEATURE_SUID_CONFIG
+
+ # If these are not set and we are using a uclibc/busybox setup
+ # all calls to system() will fail.
+ busybox_config_option y FEATURE_SH_IS_ASH
+ busybox_config_option n FEATURE_SH_IS_NONE
+
+ busybox_config_option static STATIC
+ busybox_config_option debug DEBUG
+ use debug \
+ && busybox_config_option Y NO_DEBUG_LIB \
+ && busybox_config_option N DMALLOC \
+ && busybox_config_option N EFENCE
+
+ # 1.00-pre5 uses the old selinux api which is no longer maintained
+ #busybox_config_option selinux SELINUX
+ busybox_config_option n SELINUX
+
+ # default a bunch of uncommon options to off
+ for opt in LOCALE_SUPPORT TFTP FTP{GET,PUT} IPCALC TFTP HUSH \
+ LASH MSH INETD DPKG RPM2CPIO RPM FOLD LOGNAME OD CRONTAB \
+ UUDECODE UUENCODE SULOGIN DC
+ do
+ busybox_config_option n ${opt}
+ done
+
+ make oldconfig > /dev/null
+}
+
+src_compile() {
+ busybox_set_env
+ emake -j1 CROSS="${CROSS}" depend || die "depend failed"
+ emake CROSS="${CROSS}" busybox || die "build failed"
+ if ! use static ; then
+ mv busybox{,.bak}
+ local failed=0
+ emake -j1 \
+ LDFLAGS="${LDFLAGS} -static" \
+ CROSS="${CROSS}" \
+ busybox || failed=1
+ if [[ ${failed} == 1 ]] ; then
+ if has_version '<sys-libs/glibc-2.3.5' ; then
+ eerror "Your glibc has broken static support, ignorning static build failure."
+ eerror "See http://bugs.gentoo.org/show_bug.cgi?id=94879"
+ cp busybox.bak bb
+ else
+ die "static build failed"
+ fi
+ else
+ mv busybox bb
+ fi
+ mv busybox{.bak,}
+ fi
+}
+
+src_install() {
+ busybox_set_env
+
+ into /
+ dobin busybox
+ use static \
+ && dosym busybox /bin/bb \
+ || dobin bb
+
+ if use make-symlinks ; then
+ if [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
+ ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
+ ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
+ ewarn "If you are creating a binary only and not merging this is probably ok."
+ ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
+ die "silly options will destroy your system"
+ fi
+ make CROSS="${CROSS}" install || die
+ dodir /bin
+ cp -a _install/bin/* "${D}"/bin/
+ dodir /sbin
+ cp -a _install/sbin/* "${D}"/sbin/
+ cd "${D}"
+ local symlink
+ for symlink in {bin,sbin}/* ; do
+ [[ -L ${symlink} ]] || continue
+ [[ -e ${ROOT}/${symlink} ]] \
+ && eerror "Deleting symlink ${symlink} because it exists in ${ROOT}" \
+ && rm ${symlink}
+ done
+ cd "${S}"
+ fi
+
+ dodoc AUTHORS Changelog README TODO
+
+ cd docs || die
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html *.sgml
+
+ # no man files?
+ # cd ../man && doman *.1
+
+ cd ../examples || die
+ docinto examples
+ dodoc inittab depmod.pl
+
+ cd bootfloppy || die
+ docinto bootfloppy
+ dodoc bootfloppy.txt display.txt mkdevs.sh etc/* etc/init.d/* 2>/dev/null
+
+ cd ../../ || die
+ if has buildpkg ${FEATURES} && has keepwork ${FEATURES} ; then
+ cd "${S}"
+ # this should install to the ./_install/ dir by default.
+ # we make a micro pkg of busybox that can be used for
+ # embedded systems -solar
+ if ! use make-symlinks ; then
+ make CROSS="${CROSS}" install || die
+ fi
+ cd ./_install/ \
+ && tar --no-same-owner -jcvf ${WORKDIR}/${MY_P}-${ARCH}.bz2 . \
+ && cd ..
+ fi
+
+ if use savedconfig ; then
+ einfo "Saving this build config to /etc/${PN}/${CHOST}/${PN}-${PV}-${PR}.config"
+ einfo "Read this ebuild for more info on how to take advantage of this option"
+ insinto /etc/${PN}/${CHOST}/
+ newins "${S}"/.config ${PN}-${PV}-${PR}.config
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ echo
+}
diff --git a/sys-apps/busybox/files/digest-busybox-1.01 b/sys-apps/busybox/files/digest-busybox-1.01
new file mode 100644
index 000000000000..30a9cd4a2e63
--- /dev/null
+++ b/sys-apps/busybox/files/digest-busybox-1.01
@@ -0,0 +1,2 @@
+MD5 f250842dae2854a38470ed16a46bba66 busybox-1.01.tar.bz2 954613
+MD5 af5bc43f345f102fc257787d7beacaac busybox-1.00-e2fsprogs.patch.bz2 16713