summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-08 01:41:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-08 01:41:50 +0000
commit3e0697876b971aad314a9645dfe2b5f7a5560df5 (patch)
tree8aa0cb399cf1dc7b8f7bd5b7d354d6f0c77d61ab /sys-apps/busybox
parentadd 1.0.20 with lots of fixes (diff)
downloadgentoo-2-3e0697876b971aad314a9645dfe2b5f7a5560df5.tar.gz
gentoo-2-3e0697876b971aad314a9645dfe2b5f7a5560df5.tar.bz2
gentoo-2-3e0697876b971aad314a9645dfe2b5f7a5560df5.zip
use PF instead of PVR and save config file to $PORTAGE_CONFIGROOT
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.1.3.ebuild11
-rw-r--r--sys-apps/busybox/busybox-1.2.0.ebuild11
-rw-r--r--sys-apps/busybox/busybox-1.2.1.ebuild11
3 files changed, 21 insertions, 12 deletions
diff --git a/sys-apps/busybox/busybox-1.1.3.ebuild b/sys-apps/busybox/busybox-1.1.3.ebuild
index ce3ce033a874..70b7739cb58d 100644
--- a/sys-apps/busybox/busybox-1.1.3.ebuild
+++ b/sys-apps/busybox/busybox-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.15 2006/08/07 02:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.16 2006/08/08 01:41:50 vapier Exp $
inherit eutils flag-o-matic
@@ -215,12 +215,15 @@ src_install() {
&& tar --no-same-owner -jcvf ${WORKDIR}/${MY_P}-${ARCH}.bz2 . \
&& cd ..
fi
+}
+pkg_preinst() {
if use savedconfig ; then
- einfo "Saving this build config to /etc/portage/savedconfig/${PVR}.config"
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ einfo "Saving this build config to ${config_dir}/${PF}.config"
einfo "Read this ebuild for more info on how to take advantage of this option"
- insinto /etc/portage/savedconfig
- newins "${S}"/.config ${PVR}.config
+ mkdir -p "${config_dir}"
+ cp "${S}"/.config "${config_dir}"/${PF}.config
fi
}
diff --git a/sys-apps/busybox/busybox-1.2.0.ebuild b/sys-apps/busybox/busybox-1.2.0.ebuild
index ba14b9f18f74..d95f620c3e33 100644
--- a/sys-apps/busybox/busybox-1.2.0.ebuild
+++ b/sys-apps/busybox/busybox-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.7 2006/08/07 02:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.8 2006/08/08 01:41:50 vapier Exp $
inherit eutils flag-o-matic
@@ -215,12 +215,15 @@ src_install() {
&& tar --no-same-owner -jcvf ${WORKDIR}/${MY_P}-${ARCH}.bz2 . \
&& cd ..
fi
+}
+pkg_preinst() {
if use savedconfig ; then
- einfo "Saving this build config to /etc/portage/savedconfig/${PVR}.config"
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ einfo "Saving this build config to ${config_dir}/${PF}.config"
einfo "Read this ebuild for more info on how to take advantage of this option"
- insinto /etc/portage/savedconfig
- newins "${S}"/.config ${PVR}.config
+ mkdir -p "${config_dir}"
+ cp "${S}"/.config "${config_dir}"/${PF}.config
fi
}
diff --git a/sys-apps/busybox/busybox-1.2.1.ebuild b/sys-apps/busybox/busybox-1.2.1.ebuild
index 8ad437aead88..d614d79ad266 100644
--- a/sys-apps/busybox/busybox-1.2.1.ebuild
+++ b/sys-apps/busybox/busybox-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.3 2006/08/07 02:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.4 2006/08/08 01:41:50 vapier Exp $
inherit eutils flag-o-matic
@@ -215,12 +215,15 @@ src_install() {
&& tar --no-same-owner -jcvf ${WORKDIR}/${MY_P}-${ARCH}.bz2 . \
&& cd ..
fi
+}
+pkg_preinst() {
if use savedconfig ; then
- einfo "Saving this build config to /etc/portage/savedconfig/${PVR}.config"
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ einfo "Saving this build config to ${config_dir}/${PF}.config"
einfo "Read this ebuild for more info on how to take advantage of this option"
- insinto /etc/portage/savedconfig
- newins "${S}"/.config ${PVR}.config
+ mkdir -p "${config_dir}"
+ cp "${S}"/.config "${config_dir}"/${PF}.config
fi
}