summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-09-04 20:26:16 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-09-04 20:26:16 +0000
commit7019a7f9e8c4bd676ae23da6aa87bb73b5a70cd2 (patch)
treefa12a3b344cb26f4d4a7749771af2ec2d3a6a522 /sys-apps/busybox
parentStable on sparc (diff)
downloadgentoo-2-7019a7f9e8c4bd676ae23da6aa87bb73b5a70cd2.tar.gz
gentoo-2-7019a7f9e8c4bd676ae23da6aa87bb73b5a70cd2.tar.bz2
gentoo-2-7019a7f9e8c4bd676ae23da6aa87bb73b5a70cd2.zip
Fix SELinux linking problems, bug #140615.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog7
-rw-r--r--sys-apps/busybox/busybox-1.1.3.ebuild4
-rw-r--r--sys-apps/busybox/busybox-1.2.1.ebuild4
-rw-r--r--sys-apps/busybox/files/1.2.0/busybox-libsepol.patch13
4 files changed, 25 insertions, 3 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index b3b4801daec1..ed26d2dc3739 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.104 2006/08/09 18:18:00 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.105 2006/09/04 20:26:16 pebenito Exp $
+
+ 04 Sep 2006; Chris PeBenito <pebenito@gentoo.org>
+ +files/1.1.1/busybox-libsepol.patch, +files/1.2.0/busybox-libsepol.patch,
+ busybox-1.1.3.ebuild, busybox-1.2.1.ebuild:
+ Fix SELinux linking problems, bug #140615.
09 Aug 2006; <solar@gentoo.org> busybox-1.2.1.ebuild:
- move preinst data into postinst. Add a few savedconfig examples
diff --git a/sys-apps/busybox/busybox-1.1.3.ebuild b/sys-apps/busybox/busybox-1.1.3.ebuild
index 6cec22b55215..bf2cf937b333 100644
--- a/sys-apps/busybox/busybox-1.1.3.ebuild
+++ b/sys-apps/busybox/busybox-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.19 2006/09/03 17:51:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.20 2006/09/04 20:26:16 pebenito Exp $
inherit eutils flag-o-matic
@@ -58,6 +58,8 @@ src_unpack() {
# patches go here!
epatch "${FILESDIR}"/1.1.1/bb.patch
+ # fix SELinux linking:
+ epatch "${FILESDIR}"/1.2.0/busybox-libsepol.patch
# check for a busybox config before making one of our own.
# if one exist lets return and use it.
diff --git a/sys-apps/busybox/busybox-1.2.1.ebuild b/sys-apps/busybox/busybox-1.2.1.ebuild
index c8e54e401f27..fa0f5da39dd3 100644
--- a/sys-apps/busybox/busybox-1.2.1.ebuild
+++ b/sys-apps/busybox/busybox-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.8 2006/09/03 09:01:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.9 2006/09/04 20:26:16 pebenito Exp $
inherit eutils flag-o-matic
@@ -101,6 +101,8 @@ src_unpack() {
# patches go here!
epatch "${FILESDIR}"/1.2.0/bb.patch
+ # fix SELinux linking:
+ epatch "${FILESDIR}"/1.2.0/busybox-libsepol.patch
# check for a busybox config before making one of our own.
# if one exist lets return and use it.
diff --git a/sys-apps/busybox/files/1.2.0/busybox-libsepol.patch b/sys-apps/busybox/files/1.2.0/busybox-libsepol.patch
new file mode 100644
index 000000000000..32412846f71c
--- /dev/null
+++ b/sys-apps/busybox/files/1.2.0/busybox-libsepol.patch
@@ -0,0 +1,13 @@
+Index: Rules.mak
+===================================================================
+--- Rules.mak (revision 15800)
++++ Rules.mak (working copy)
+@@ -298,7 +298,7 @@
+ endif
+
+ ifeq ($(strip $(CONFIG_SELINUX)),y)
+- LIBRARIES += -lselinux
++ LIBRARIES += -lselinux -lsepol
+ endif
+
+ ifeq ($(strip $(PREFIX)),)