summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-13 02:13:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-13 02:13:07 +0000
commit98082bcbeac77f5deb8a35d5bdbb0314887930c9 (patch)
tree9c147cb8401d797c1e8db2f5c55f21fdb461e0e4 /sys-apps/busybox
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-98082bcbeac77f5deb8a35d5bdbb0314887930c9.tar.gz
gentoo-2-98082bcbeac77f5deb8a35d5bdbb0314887930c9.tar.bz2
gentoo-2-98082bcbeac77f5deb8a35d5bdbb0314887930c9.zip
restore cross-compiling support
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.00-r1.ebuild17
-rw-r--r--sys-apps/busybox/busybox-1.00.ebuild17
-rw-r--r--sys-apps/busybox/busybox-1.00_rc3.ebuild17
3 files changed, 6 insertions, 45 deletions
diff --git a/sys-apps/busybox/busybox-1.00-r1.ebuild b/sys-apps/busybox/busybox-1.00-r1.ebuild
index c934cfadf005..e3f0d1e4f0e9 100644
--- a/sys-apps/busybox/busybox-1.00-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r1.ebuild,v 1.1 2004/12/11 14:15:53 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r1.ebuild,v 1.2 2004/12/13 02:13:07 vapier Exp $
inherit eutils
@@ -12,7 +12,6 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~mips ~arm ~amd64 ~sparc ~hppa"
IUSE="debug uclibc static savedconfig netboot make-busybox-symlinks"
-#IUSE="${IUSE} cross"
MY_PV=${PV/_/-}
@@ -95,10 +94,6 @@ src_unpack() {
busybox_config_option y FEATURE_SH_IS_ASH
busybox_config_option n FEATURE_SH_IS_NONE
- # setting the cross compiler from here would be somewhat of a
- # pain do to as we would need a multiline sed expression which
- # does not always seem to work so hot for me.
-
use static \
&& busybox_config_option y STATIC \
|| busybox_config_option n STATIC
@@ -145,15 +140,7 @@ src_unpack() {
}
busybox_set_cross_compiler() {
- return 0
- # revisit this another day.
- #if use cross ; then
- # case ${ARCH} in
- # x86*) CROSS="/usr/i386-linux-uclibc/bin/i386-uclibc-";;
- # *) ;;
- # esac
- #fi
- [ -n "${CROSS}" ] && einfo "Setting cross compiler prefix to ${CROSS}"
+ type -p ${CHOST}-gcc && export CROSS=${CHOST}-
}
src_compile() {
diff --git a/sys-apps/busybox/busybox-1.00.ebuild b/sys-apps/busybox/busybox-1.00.ebuild
index 3c797ebaef60..514bffde7032 100644
--- a/sys-apps/busybox/busybox-1.00.ebuild
+++ b/sys-apps/busybox/busybox-1.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00.ebuild,v 1.6 2004/12/12 09:09:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00.ebuild,v 1.7 2004/12/13 02:13:07 vapier Exp $
inherit eutils
@@ -12,7 +12,6 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc ~mips arm ~amd64 sparc hppa"
IUSE="debug uclibc static savedconfig netboot make-busybox-symlinks"
-#IUSE="${IUSE} cross"
MY_PV=${PV/_/-}
@@ -88,10 +87,6 @@ src_unpack() {
busybox_config_option y FEATURE_SH_IS_ASH
busybox_config_option n FEATURE_SH_IS_NONE
- # setting the cross compiler from here would be somewhat of a
- # pain do to as we would need a multiline sed expression which
- # does not always seem to work so hot for me.
-
use static \
&& busybox_config_option y STATIC \
|| busybox_config_option n STATIC
@@ -138,15 +133,7 @@ src_unpack() {
}
busybox_set_cross_compiler() {
- return 0
- # revisit this another day.
- #if use cross ; then
- # case ${ARCH} in
- # x86*) CROSS="/usr/i386-linux-uclibc/bin/i386-uclibc-";;
- # *) ;;
- # esac
- #fi
- [ -n "${CROSS}" ] && einfo "Setting cross compiler prefix to ${CROSS}"
+ type -p ${CHOST}-gcc && export CROSS=${CHOST}-
}
src_compile() {
diff --git a/sys-apps/busybox/busybox-1.00_rc3.ebuild b/sys-apps/busybox/busybox-1.00_rc3.ebuild
index f3bb578c585a..20aaedbbb019 100644
--- a/sys-apps/busybox/busybox-1.00_rc3.ebuild
+++ b/sys-apps/busybox/busybox-1.00_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_rc3.ebuild,v 1.11 2004/10/17 01:25:50 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_rc3.ebuild,v 1.12 2004/12/13 02:13:07 vapier Exp $
inherit eutils
@@ -12,7 +12,6 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc ~mips arm ~amd64 ~sparc hppa"
IUSE="debug uclibc static savedconfig netboot make-busybox-symlinks"
-#IUSE="${IUSE} cross"
MY_PV=${PV/_/-}
@@ -90,10 +89,6 @@ src_unpack() {
busybox_config_option y FEATURE_SH_IS_ASH
busybox_config_option n FEATURE_SH_IS_NONE
- # setting the cross compiler from here would be somewhat of a
- # pain do to as we would need a multiline sed expression which
- # does not always seem to work so hot for me.
-
use static \
&& busybox_config_option y STATIC \
|| busybox_config_option n STATIC
@@ -140,15 +135,7 @@ src_unpack() {
}
busybox_set_cross_compiler() {
- return 0
- # revisit this another day.
- #if use cross ; then
- # case ${ARCH} in
- # x86*) CROSS="/usr/i386-linux-uclibc/bin/i386-uclibc-";;
- # *) ;;
- # esac
- #fi
- [ -n "${CROSS}" ] && einfo "Setting cross compiler prefix to ${CROSS}"
+ type -p ${CHOST}-gcc && export CROSS=${CHOST}-
}
src_compile() {