summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-10-09 20:04:47 +0000
committerSven Vermeulen <swift@gentoo.org>2012-10-09 20:04:47 +0000
commit178f7414c741f54974e7accf4e66d7f08f695b75 (patch)
tree053e5bb5123d8d392922291e2f258ec013690a4a /sys-apps/checkpolicy
parentNew upstream SELinux utilities release (diff)
downloadgentoo-2-178f7414c741f54974e7accf4e66d7f08f695b75.tar.gz
gentoo-2-178f7414c741f54974e7accf4e66d7f08f695b75.tar.bz2
gentoo-2-178f7414c741f54974e7accf4e66d7f08f695b75.zip
New upstream SELinux utilities release
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/checkpolicy')
-rw-r--r--sys-apps/checkpolicy/ChangeLog7
-rw-r--r--sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/checkpolicy/ChangeLog b/sys-apps/checkpolicy/ChangeLog
index f68f08d27106..4d8619170366 100644
--- a/sys-apps/checkpolicy/ChangeLog
+++ b/sys-apps/checkpolicy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/checkpolicy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/ChangeLog,v 1.66 2012/05/13 13:05:19 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/ChangeLog,v 1.67 2012/10/09 20:04:47 swift Exp $
+
+*checkpolicy-2.1.11 (09 Oct 2012)
+
+ 09 Oct 2012; <swift@gentoo.org> +checkpolicy-2.1.11.ebuild:
+ Introducing new upstream version
13 May 2012; <swift@gentoo.org> -checkpolicy-2.1.0.ebuild:
Removing obsoleted ebuild
diff --git a/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild b/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild
new file mode 100644
index 000000000000..7ef246baa006
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/checkpolicy-2.1.11.ebuild,v 1.1 2012/10/09 20:04:47 swift Exp $
+
+inherit toolchain-funcs
+
+SEPOL_VER="2.1.8"
+SEMNG_VER="2.1.9"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" YACC="bison -y" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}