summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-05-09 20:31:03 +0000
committerSven Vermeulen <swift@gentoo.org>2014-05-09 20:31:03 +0000
commitda747c976b973aa6ae4ab50efc3f1cf8529b0930 (patch)
treefa614eebe9ada806342e696d27f793ae9a75e135 /sys-apps/checkpolicy
parentBump to 2.3 (diff)
downloadgentoo-2-da747c976b973aa6ae4ab50efc3f1cf8529b0930.tar.gz
gentoo-2-da747c976b973aa6ae4ab50efc3f1cf8529b0930.tar.bz2
gentoo-2-da747c976b973aa6ae4ab50efc3f1cf8529b0930.zip
Bump to 2.3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-apps/checkpolicy')
-rw-r--r--sys-apps/checkpolicy/ChangeLog7
-rw-r--r--sys-apps/checkpolicy/checkpolicy-2.3.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/checkpolicy/ChangeLog b/sys-apps/checkpolicy/ChangeLog
index 0a2b584e85b5..3adec417ffe3 100644
--- a/sys-apps/checkpolicy/ChangeLog
+++ b/sys-apps/checkpolicy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/checkpolicy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/ChangeLog,v 1.74 2014/04/28 19:42:56 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/ChangeLog,v 1.75 2014/05/09 20:31:03 swift Exp $
+
+*checkpolicy-2.3 (09 May 2014)
+
+ 09 May 2014; Sven Vermeulen <swift@gentoo.org> +checkpolicy-2.3.ebuild:
+ Bump to 2.3
*checkpolicy-2.3_rc1 (28 Apr 2014)
diff --git a/sys-apps/checkpolicy/checkpolicy-2.3.ebuild b/sys-apps/checkpolicy/checkpolicy-2.3.ebuild
new file mode 100644
index 000000000000..c0ea02c58c35
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/checkpolicy-2.3.ebuild,v 1.1 2014/05/09 20:31:03 swift Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+MY_P="${P//_/-}"
+
+SEPOL_VER="2.3"
+SEMNG_VER="2.3"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20140506/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" YACC="bison -y" || die
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}