summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2007-02-03 01:45:40 +0000
committerMichael Marineau <marineam@gentoo.org>2007-02-03 01:45:40 +0000
commitce50340cc2f1b386dcab1102cf85df99778622e3 (patch)
tree49347a283ec4d94e75115388727498c5d875bfda /sys-apps/chname/chname-1.0.ebuild
parentMask sys-apps/chname for the 2.4 profile (diff)
downloadgentoo-2-ce50340cc2f1b386dcab1102cf85df99778622e3.tar.gz
gentoo-2-ce50340cc2f1b386dcab1102cf85df99778622e3.tar.bz2
gentoo-2-ce50340cc2f1b386dcab1102cf85df99778622e3.zip
First version of chname
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-apps/chname/chname-1.0.ebuild')
-rw-r--r--sys-apps/chname/chname-1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/chname/chname-1.0.ebuild b/sys-apps/chname/chname-1.0.ebuild
new file mode 100644
index 000000000000..d60b98455ab6
--- /dev/null
+++ b/sys-apps/chname/chname-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/chname/chname-1.0.ebuild,v 1.1 2007/02/03 01:45:40 marineam Exp $
+
+DESCRIPTION="Run a command with a new system hostname."
+HOMEPAGE="http://code.google.com/p/chname"
+SRC_URI="http://chname.googlecode.com/files/chname-1.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=sys-kernel/linux-headers-2.6.16"
+RDEPEND=">=virtual/linux-sources-2.6.19"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" chname
+}
+
+src_install() {
+ dobin chname
+ doman chname.1
+}
+
+pkg_postinst() {
+ elog "Note: chname requires a running 2.6.19 kernel with CONFIG_UTS_NS=y."
+}