summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-05 00:19:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-05 00:19:36 +0000
commit25059400b1200123fe3167f097fbd09130e2fad2 (patch)
treea89978c9b6df0f3b945f59b6a23f3dbfd8f98ff1 /sys-apps/coreutils
parentPackage masking upcoming "sci-libs/charm". (diff)
downloadgentoo-2-25059400b1200123fe3167f097fbd09130e2fad2.tar.gz
gentoo-2-25059400b1200123fe3167f097fbd09130e2fad2.tar.bz2
gentoo-2-25059400b1200123fe3167f097fbd09130e2fad2.zip
Fix uname parsing of cpuinfo on alpha/ia64 and use timestyle patch from upstream.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog9
-rw-r--r--sys-apps/coreutils/coreutils-5.3.0-r2.ebuild140
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.3.0-r22
3 files changed, 150 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index ac298e86fbc3..b6a1bad6aa64 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.142 2005/09/13 00:35:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.143 2005/10/05 00:19:35 vapier Exp $
+
+*coreutils-5.3.0-r2 (05 Oct 2005)
+
+ 05 Oct 2005; Mike Frysinger <vapier@gentoo.org>
+ +coreutils-5.3.0-r2.ebuild:
+ Fix uname parsing of cpuinfo on alpha/ia64 and use timestyle patch from
+ upstream.
13 Sep 2005; Mike Frysinger <vapier@gentoo.org> coreutils-5.3.0-r1.ebuild:
Fix off-by-one issue #105639 by Michal Januszewski.
diff --git a/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild b/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild
new file mode 100644
index 000000000000..fdbe48f7bfc1
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.3.0-r2.ebuild,v 1.1 2005/10/05 00:19:35 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+PATCH_VER=1.4
+
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~seemant/distfiles/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="acl build nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ acl? ( sys-apps/acl sys-apps/attr )
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.49
+ =sys-devel/automake-1.8*
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/m4-1.4-r1
+ !elibc_uclibc? ( sys-apps/help2man )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ PATCHDIR="${WORKDIR}/patch"
+
+ EPATCH_MULTI_MSG="Applying patches from Mandrake ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/mandrake
+
+ # Apply the ACL/SELINUX patches.
+ if use selinux ; then
+ EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
+ ( cd "${PATCHDIR}" ; epatch selinux/GLUE* ) || die "glue failed"
+ elif use acl ; then
+ EPATCH_MULTI_MSG="Applying ACL patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/extra
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ tc-is-cross-compiler && touch man/*.1
+
+ ebegin "Reconfiguring configure scripts (be patient)"
+ export WANT_AUTOMAKE=1.8
+ export WANT_AUTOCONF=2.5
+ aclocal -I m4 || die "aclocal"
+ autoconf || die "autoconf"
+ automake || die "automake"
+ eend $?
+}
+
+src_compile() {
+ if ! type -p cvs > /dev/null ; then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+
+ local myconf=""
+ [[ ${USERLAND} == "GNU" ]] \
+ && myconf="${myconf} --bindir=/bin" \
+ || myconf="${myconf} --program-prefix=g"
+
+ econf \
+ --enable-largefile \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ ${myconf} \
+ || die "econf"
+
+ use static && append-ldflags -static
+ emake LDFLAGS="${LDFLAGS}" || die "emake"
+}
+
+src_test() {
+ # Non-root tests will fail if the full path isnt
+ # accessible to non-root users
+ chmod a+rx "${WORKDIR}"
+ addwrite /dev/full
+ export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ make check || die "make check failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -f "${D}"/usr/lib/charset.alias
+
+ # remove files provided by other packages
+ rm "${D}"/bin/{kill,uptime} # procps
+ rm "${D}"/bin/{groups,su} # shadow
+ rm "${D}"/bin/hostname # net-tools
+ rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
+ # provide by the man-pages package
+ rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
+ rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
+ rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
+
+ insinto /etc
+ doins "${FILESDIR}"/DIR_COLORS
+
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # move non-critical packages into /usr
+ cd "${D}"
+ dodir /usr/bin
+ mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
+ mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
+ mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
+ cd bin
+ local x
+ for x in * ; do
+ dosym /bin/${x} /usr/bin/${x}
+ done
+ fi
+
+ if ! use build ; then
+ cd "${S}"
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+ else
+ rm -r "${D}"/usr/share
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.3.0-r2 b/sys-apps/coreutils/files/digest-coreutils-5.3.0-r2
new file mode 100644
index 000000000000..1d81b49de9e8
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.3.0-r2
@@ -0,0 +1,2 @@
+MD5 903890208248639ac723d2c4988e04bd coreutils-5.3.0.tar.bz2 4473010
+MD5 633cc34b9efa96a7ed5c5092e18c1a6b coreutils-5.3.0-patches-1.4.tar.bz2 56045