summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-03-16 06:43:23 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-03-16 06:43:23 +0000
commit6256274e5e2451444044ce9c63ff07ab3aa67505 (patch)
treecee46b062ebb527f853daeeb71672ed15b01006d /sys-apps/dbus/files
parentFix for gcc 4.1. (#120910) Look for imake in the right place, fix by Octavio ... (diff)
downloadgentoo-2-6256274e5e2451444044ce9c63ff07ab3aa67505.tar.gz
gentoo-2-6256274e5e2451444044ce9c63ff07ab3aa67505.tar.bz2
gentoo-2-6256274e5e2451444044ce9c63ff07ab3aa67505.zip
Adding some necessary patches to fix QT mess.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'sys-apps/dbus/files')
-rw-r--r--sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch11
-rw-r--r--sys-apps/dbus/files/dbus-0.61-libxml-dep.patch20
-rw-r--r--sys-apps/dbus/files/dbus-0.61-qt-disabling.patch21
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch b/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch
new file mode 100644
index 000000000000..b22d525c8dc4
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch
@@ -0,0 +1,11 @@
+--- qt/Makefile.am 2006-02-16 19:04:38.000000000 -0500
++++ qt/Makefile.am.new 2006-03-15 23:39:10.000000000 -0500
+@@ -62,7 +62,7 @@
+ $(top_srcdir)/qt/qdbusserver.lo: qdbusserver.moc
+ $(top_srcdir)/qt/qdbusconnection.lo: qdbusconnection_p.moc
+
+-CLEANFILES=qdbusabstractadaptor.moc qdbusserver.moc qdbusconnection.moc
++CLEANFILES=qdbusabstractadaptor.moc qdbusserver.moc qdbusconnection_p.moc
+
+ libdbus_qt4_1_la_LIBADD= $(DBUS_QT_LIBS) $(top_builddir)/dbus/libdbus-1.la
+ libdbus_qt4_1_la_LDFLAGS= -version-info 1:0 -no-undefined
diff --git a/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch b/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch
new file mode 100644
index 000000000000..f7e122f752bb
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch
@@ -0,0 +1,20 @@
+--- configure.in 2006-02-24 11:36:29.000000000 -0500
++++ configure.in.xml 2006-03-15 23:47:31.000000000 -0500
+@@ -9,6 +9,8 @@
+
+ AM_CONFIG_HEADER(config.h)
+
++LIBXML_REQUIRED=2.6.0
++
+ # Honor aclocal flags
+ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+
+@@ -753,7 +755,7 @@
+ [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ],
+ have_expat=false)
+
+-PKG_CHECK_MODULES(LIBXML, libxml-2.0, have_libxml=true, have_libxml=false)
++PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED, have_libxml=true, have_libxml=false)
+
+ # see what we want to use
+ dbus_use_libxml=false
diff --git a/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch b/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch
new file mode 100644
index 000000000000..fc270baef346
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch
@@ -0,0 +1,21 @@
+--- dbus-0.61/configure.in.disableqt4 2006-02-28 13:33:47.000000000 +0100
++++ dbus-0.61/configure.in 2006-02-28 13:33:29.000000000 +0100
+@@ -1033,6 +1033,10 @@
+ fi
+ have_qt=no
+ else
++ if test x$enable_qt = xno; then
++ have_qt=no;
++ have_qtest=no;
++ else
+ dnl Qt4 flags
+ AC_SUBST(DBUS_QT_CFLAGS)
+ AC_SUBST(DBUS_QT_LIBS)
+@@ -1055,6 +1059,7 @@
+
+ AC_SUBST(DBUS_QTESTLIB_CFLAGS)
+ AC_SUBST(DBUS_QTESTLIB_LIBS)
++ fi
+ fi
+
+ AM_CONDITIONAL(HAVE_QT, test x$have_qt = xyes)