summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-10 21:18:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-10 21:18:06 +0000
commitfea9cd058e34497fced3b7a6289c06fa44bf6f2a (patch)
tree323e8386f7f52fb30c5c18c38b607c84172241db /sys-apps/debianutils/debianutils-1.16.7-r4.ebuild
parentmkboot fix (diff)
downloadgentoo-2-fea9cd058e34497fced3b7a6289c06fa44bf6f2a.tar.gz
gentoo-2-fea9cd058e34497fced3b7a6289c06fa44bf6f2a.tar.bz2
gentoo-2-fea9cd058e34497fced3b7a6289c06fa44bf6f2a.zip
mkboot fix
Diffstat (limited to 'sys-apps/debianutils/debianutils-1.16.7-r4.ebuild')
-rw-r--r--sys-apps/debianutils/debianutils-1.16.7-r4.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild b/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild
new file mode 100644
index 000000000000..0a9d5710eabb
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild,v 1.1 2003/12/10 21:18:04 seemant Exp $
+
+IUSE="static build"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="http://packages.debian.org/unstable/base/debianutils.html"
+SRC_URI="mirror://gentoo/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 BSD"
+KEYWORDS="x86 amd64 ppc sparc alpha mips hppa arm ia64"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="app-arch/bzip2
+ sys-apps/coreutils"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Make installkernel and mkboot more Gentoo friendly
+ # <azarah@gentoo.org> (25 Sep 2002)
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ # Patch savelog to use bzip2 compression instead of gzip
+ epatch ${FILESDIR}/${PN}-compress.patch
+
+ # Get it to work with gcc-3.3
+ # <azarah@gentoo.org> (18 May 2003)
+ epatch ${FILESDIR}/${P}-gcc33.patch
+}
+
+src_compile() {
+ if use static
+ then
+ pmake LDFLAGS=-static || die
+ else
+ pmake || die
+ fi
+}
+
+src_install() {
+ into /
+ dobin tempfile mktemp
+
+ if [ -z "`use build`" ]
+ then
+ dobin run-parts
+ insopts -m755
+ exeinto /usr/sbin
+ doexe savelog
+ dosbin installkernel
+ into /usr
+ dosbin mkboot
+
+ into /usr
+ doman mktemp.1 tempfile.1 run-parts.8 savelog.8 \
+ installkernel.8 mkboot.8
+
+ cd debian
+ dodoc changelog control copyright
+ fi
+}