summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 15:07:25 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 15:07:25 +0000
commit76d08203c8b9778c1433aa149bf8c1e7e4fa6f28 (patch)
tree3c358b96950ee11f52d7e1a6a46ca93aa9a750c9 /sys-apps/diffutils
parentAdded Makefile patch (diff)
downloadgentoo-2-76d08203c8b9778c1433aa149bf8c1e7e4fa6f28.tar.gz
gentoo-2-76d08203c8b9778c1433aa149bf8c1e7e4fa6f28.tar.bz2
gentoo-2-76d08203c8b9778c1433aa149bf8c1e7e4fa6f28.zip
Now understands USE nls
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/diffutils-2.7-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/diffutils/diffutils-2.7-r3.ebuild b/sys-apps/diffutils/diffutils-2.7-r3.ebuild
new file mode 100644
index 000000000000..525111abe20c
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.7-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.7-r3.ebuild,v 1.1 2001/02/27 15:07:25 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools to make diffs and compare files"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/diffutils/${A}
+ ftp://ftp.gnu.org/gnu/diffutils/${A}"
+
+HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static
+ fi
+
+}
+
+src_install() {
+
+ try make prefix=${D}/usr infodir=${D}/usr/share/info install
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+
+}
+
+