summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-29 02:22:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-29 02:22:44 +0000
commit5ad2d7ee5fd9bcf93ebf504023932faed5056f4e (patch)
tree0ea77ae7e6ba21d8db2f275097ab18b0594995e9 /sys-apps/dmapi
parentAdded ~sparc keyword as it was incorrectly dropped from the ebuild among othe... (diff)
downloadgentoo-2-5ad2d7ee5fd9bcf93ebf504023932faed5056f4e.tar.gz
gentoo-2-5ad2d7ee5fd9bcf93ebf504023932faed5056f4e.tar.bz2
gentoo-2-5ad2d7ee5fd9bcf93ebf504023932faed5056f4e.zip
Clean up build so that we no longer have .a or .la files in /.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/ChangeLog8
-rw-r--r--sys-apps/dmapi/dmapi-2.2.1.ebuild27
-rw-r--r--sys-apps/dmapi/files/dmapi-2.2.1-only-symlink-when-needed.patch18
3 files changed, 38 insertions, 15 deletions
diff --git a/sys-apps/dmapi/ChangeLog b/sys-apps/dmapi/ChangeLog
index 55dda933fc18..9dcc9a0ecaf9 100644
--- a/sys-apps/dmapi/ChangeLog
+++ b/sys-apps/dmapi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/dmapi
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.26 2005/04/25 06:34:09 kloeri Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.27 2005/11/29 02:22:43 vapier Exp $
+
+ 29 Nov 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/dmapi-2.2.1-only-symlink-when-needed.patch, dmapi-2.2.1.ebuild:
+ Clean up build so that we no longer have .a or .la files in /.
25 Apr 2005; Bryan Østergaard <kloeri@gentoo.org> dmapi-2.2.1.ebuild:
Stable on alpha.
diff --git a/sys-apps/dmapi/dmapi-2.2.1.ebuild b/sys-apps/dmapi/dmapi-2.2.1.ebuild
index 53af76f42248..2c97dc33e347 100644
--- a/sys-apps/dmapi/dmapi-2.2.1.ebuild
+++ b/sys-apps/dmapi/dmapi-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.1.ebuild,v 1.7 2005/07/11 00:50:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.1.ebuild,v 1.8 2005/11/29 02:22:43 vapier Exp $
inherit eutils
@@ -17,29 +17,30 @@ DEPEND="sys-fs/xfsprogs"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-only-symlink-when-needed.patch
sed -i \
-e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
- -e 's:^PKG_\(.*\)_DIR[[:space:]]*= \(.*\)$:PKG_\1_DIR = $(DESTDIR)\2:' \
- include/builddefs.in || die
+ include/builddefs.in \
+ || die "failed to update builddefs"
}
src_compile() {
use debug \
&& export DEBUG=-DDEBUG \
|| export DEBUG=-DNDEBUG
- export OPTIMIZER="${CFLAGS}"
+ export OPTIMIZER=${CFLAGS}
- # Some archs need the PLATFORM var unset
- unset PLATFORM
-
- econf \
- --libdir=/$(get_libdir) \
- --libexecdir=/usr/$(get_libdir) \
- || die
+ econf --libexecdir=/usr/$(get_libdir) || die
emake || die
}
src_install() {
- make DESTDIR=${D} install install-dev || die
+ make DIST_ROOT="${D}" install install-dev || die
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libdm.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libdm.so
}
diff --git a/sys-apps/dmapi/files/dmapi-2.2.1-only-symlink-when-needed.patch b/sys-apps/dmapi/files/dmapi-2.2.1-only-symlink-when-needed.patch
new file mode 100644
index 000000000000..387a08352e16
--- /dev/null
+++ b/sys-apps/dmapi/files/dmapi-2.2.1-only-symlink-when-needed.patch
@@ -0,0 +1,18 @@
+We dont want to generate symlinks when the libdir is the same as the
+devlibdir, otherwise we clobber the real files with broken symlinks
+
+--- include/buildmacros
++++ include/buildmacros
+@@ -102,9 +102,11 @@
+ ../$(INSTALL) -m 644 $(LIBNAME).lai $(PKG_DEVLIB_DIR)/$(LIBNAME).la ; \
+ ../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
+ ../$(INSTALL) -T so_base $(LIBNAME).lai $(PKG_LIB_DIR); \
++ if test "x$(PKG_DEVLIB_DIR)" != "x$(PKG_LIB_DIR)" ; then \
+ ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).a $(PKG_LIB_DIR)/$(LIBNAME).a; \
+ ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).la $(PKG_LIB_DIR)/$(LIBNAME).la; \
+- ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so
++ ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so; \
++ fi
+ else
+ INSTALL_LTLIB_DEV = $(INSTALL_LTLIB_STATIC)
+ endif