summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-04-09 17:23:16 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-04-09 17:23:16 +0000
commita9d3bc756f7edddaeb73a7c0c6e179c9ba7bf15c (patch)
treee65c79d84cabd5d6267b626339b5da04ff89a4ca /sys-apps/dmtcp
parentSet RESTRICT_PYTHON_ABIS. (diff)
downloadgentoo-2-a9d3bc756f7edddaeb73a7c0c6e179c9ba7bf15c.tar.gz
gentoo-2-a9d3bc756f7edddaeb73a7c0c6e179c9ba7bf15c.tar.bz2
gentoo-2-a9d3bc756f7edddaeb73a7c0c6e179c9ba7bf15c.zip
New ebuild for the Distributed MultiThreaded CheckPoint tool.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dmtcp')
-rw-r--r--sys-apps/dmtcp/ChangeLog11
-rw-r--r--sys-apps/dmtcp/dmtcp-1.2.1.ebuild77
-rw-r--r--sys-apps/dmtcp/metadata.xml12
3 files changed, 100 insertions, 0 deletions
diff --git a/sys-apps/dmtcp/ChangeLog b/sys-apps/dmtcp/ChangeLog
new file mode 100644
index 000000000000..d8286f74f95e
--- /dev/null
+++ b/sys-apps/dmtcp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/dmtcp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmtcp/ChangeLog,v 1.1 2011/04/09 17:23:16 nerdboy Exp $
+
+*dmtcp-1.2.1 (09 Apr 2011)
+
+ 09 Apr 2011; Steve Arnold <nerdboy@gentoo.org> +dmtcp-1.2.1.ebuild,
+ +metadata.xml:
+ New ebuild for the Distributed MultiThreaded CheckPoint tool. It does
+ not require any special source mods or kernel modules. See the docs...
+
diff --git a/sys-apps/dmtcp/dmtcp-1.2.1.ebuild b/sys-apps/dmtcp/dmtcp-1.2.1.ebuild
new file mode 100644
index 000000000000..59cba250b40b
--- /dev/null
+++ b/sys-apps/dmtcp/dmtcp-1.2.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmtcp/dmtcp-1.2.1.ebuild,v 1.1 2011/04/09 17:23:16 nerdboy Exp $
+
+EAPI=3
+
+inherit autotools elisp-common eutils multilib
+
+DESCRIPTION="DMTCP is the Distributed MultiThreaded Checkpointing tool."
+HOMEPAGE="http://dmtcp.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/dmtcp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug emacs fast mpi trace"
+
+RDEPEND="sys-libs/readline
+ sys-devel/patch
+ app-arch/gzip
+ sys-kernel/linux-headers
+ emacs? ( dev-lisp/clisp )
+ mpi? ( virtual/mpi )
+ || ( app-shells/dash
+ app-shells/zsh
+ app-shells/tcsh
+ )"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ sed -i -e "s|make install|\$(MAKE) install|" Makefile.in
+}
+
+src_configure() {
+ local myconf="--enable-external-socket-handling \
+ --disable-stale-socket-handling"
+
+ if use debug; then
+ use trace && myconf=" ${myconf} --enable-ptrace-support"
+ myconf=" ${myconf} --disable-pid-virtualization"
+ fi
+
+ use fast && myconf=" ${myconf} --disable-pid-virtualization \
+ --disable-external-socket-handling \
+ --enable-forked-checkpointing \
+ --enable-allocator"
+
+ use mpi && myconf=" ${myconf} --with-mpich=/usr/bin"
+
+ econf $(use_enable debug) $myconf
+}
+
+src_test() {
+ make check || die "make check failed"
+ make check1 || die "make check1 failed"
+ make check2 || die "make check2 failed"
+ make check3 || die "make check3 failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc TODO QUICK-START ${PN}/README
+
+ dodir /usr/share/${PF}/examples
+ mv "${D}"usr/$(get_libdir)/${PN}/examples "${D}"usr/share/${PF}/examples
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sys-apps/dmtcp/metadata.xml b/sys-apps/dmtcp/metadata.xml
new file mode 100644
index 000000000000..5bf615f354ca
--- /dev/null
+++ b/sys-apps/dmtcp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-tools</herd>
+<maintainer>
+<email>nerdboy@gentoo.org</email>
+</maintainer>
+<use>
+<flag name="fast">Enable experimental performance options such as mmap allocator.</flag>
+<flag name="trace">Enable ptrace support (only valid with debug enabled).</flag>
+</use>
+</pkgmetadata>