summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-22 18:03:35 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-22 18:03:35 +0000
commit5cefd8046ad33e99f69a8d4c6b49b042c983cc6a (patch)
treef477f67bb32ca64a57aadaeeeb2d29684506ba42 /sys-apps/ed
parentadded lcd_devices_graphlcd to use.mask; bug #150925 (diff)
downloadgentoo-2-5cefd8046ad33e99f69a8d4c6b49b042c983cc6a.tar.gz
gentoo-2-5cefd8046ad33e99f69a8d4c6b49b042c983cc6a.tar.bz2
gentoo-2-5cefd8046ad33e99f69a8d4c6b49b042c983cc6a.zip
Version bump #163220 by Raphael Marichez.
(Portage version: 2.1.2-r1)
Diffstat (limited to 'sys-apps/ed')
-rw-r--r--sys-apps/ed/ChangeLog10
-rw-r--r--sys-apps/ed/ed-0.4.ebuild40
-rw-r--r--sys-apps/ed/files/digest-ed-0.43
-rw-r--r--sys-apps/ed/files/ed-0.4-build.patch28
-rw-r--r--sys-apps/ed/files/ed-0.4-configure-LANG.patch22
5 files changed, 101 insertions, 2 deletions
diff --git a/sys-apps/ed/ChangeLog b/sys-apps/ed/ChangeLog
index 7d4c1be2c0f0..4117f91b1390 100644
--- a/sys-apps/ed/ChangeLog
+++ b/sys-apps/ed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/ed
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.27 2006/10/17 11:03:43 uberlord Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.28 2007/01/22 18:03:35 vapier Exp $
+
+*ed-0.4 (22 Jan 2007)
+
+ 22 Jan 2007; Mike Frysinger <vapier@gentoo.org> +files/ed-0.4-build.patch,
+ +files/ed-0.4-configure-LANG.patch, +ed-0.4.ebuild:
+ Version bump #163220 by Raphael Marichez.
17 Oct 2006; Roy Marples <uberlord@gentoo.org> ed-0.2-r6.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/sys-apps/ed/ed-0.4.ebuild b/sys-apps/ed/ed-0.4.ebuild
new file mode 100644
index 000000000000..a7f3e53a61c1
--- /dev/null
+++ b/sys-apps/ed/ed-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.4.ebuild,v 1.1 2007/01/22 18:03:35 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure-LANG.patch #126041
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+ # custom configure script ... econf wont work
+ ./configure \
+ --prefix=/ \
+ --datadir=/usr/share \
+ ${EXTRA_ECONF} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ doman doc/ed.1
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/sys-apps/ed/files/digest-ed-0.4 b/sys-apps/ed/files/digest-ed-0.4
new file mode 100644
index 000000000000..d4ffac766875
--- /dev/null
+++ b/sys-apps/ed/files/digest-ed-0.4
@@ -0,0 +1,3 @@
+MD5 b5c8606bb306671bbbb2bd708d937bcb ed-0.4.tar.bz2 54146
+RMD160 075e55f2eeaaef3376191add3acf14140134a1c4 ed-0.4.tar.bz2 54146
+SHA256 fe72662d8599acf8de465ccd571e32cecb5641c073e794f035b719286df2bdf8 ed-0.4.tar.bz2 54146
diff --git a/sys-apps/ed/files/ed-0.4-build.patch b/sys-apps/ed/files/ed-0.4-build.patch
new file mode 100644
index 000000000000..6ab4b15eaace
--- /dev/null
+++ b/sys-apps/ed/files/ed-0.4-build.patch
@@ -0,0 +1,28 @@
+--- configure
++++ configure
+@@ -36,12 +36,8 @@
+ infodir='$(datadir)/info'
+ mandir='$(datadir)/man'
+ sysconfdir='$(prefix)/etc'
+-CC=
+-CXX=
+-CPPFLAGS=
+-CFLAGS='-Wall -W -O2'
+-CXXFLAGS='-Wall -W -O2'
+-LDFLAGS=
++CFLAGS="$CFLAGS -Wall -W"
++CXXFLAGS="$CXXFLAGS -Wall -W"
+
+ # Loop over all args
+ while [ x"$1" != x ] ; do
+--- Makefile.in
++++ Makefile.in
+@@ -48,7 +48,7 @@
+ if test ! -d $(DESTDIR)$(bindir) ; then $(INSTALL) -d $(DESTDIR)$(bindir) ; fi
+ $(INSTALL_PROGRAM) ./$(progname) $(DESTDIR)$(bindir)/$(progname)
+ -rm -f $(DESTDIR)$(bindir)/r$(progname)
+- cd $(DESTDIR)$(bindir) ; ln $(progname) r$(progname)
++ cd $(DESTDIR)$(bindir) ; ln -s $(progname) r$(progname)
+
+ install-info :
+ if test ! -d $(DESTDIR)$(infodir) ; then $(INSTALL) -d $(DESTDIR)$(infodir) ; fi
diff --git a/sys-apps/ed/files/ed-0.4-configure-LANG.patch b/sys-apps/ed/files/ed-0.4-configure-LANG.patch
new file mode 100644
index 000000000000..06d0031a980b
--- /dev/null
+++ b/sys-apps/ed/files/ed-0.4-configure-LANG.patch
@@ -0,0 +1,22 @@
+--- configure
++++ configure
+@@ -14,6 +14,19 @@
+ progversion=0.4
+ srctrigger=ed.h
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval $as_var=C; export $as_var) 2>&1`"); then
++ eval $as_var=C; export $as_var
++ else
++ unset $as_var
++ fi
++done
++
+ # clear some things potentially inherited from environment.
+ srcdir=
+ prefix=/usr/local