summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-08-03 17:34:47 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-08-03 17:34:47 +0000
commit48539ec0f411d9501abea7e623cc186aece8874f (patch)
tree7cfcbf7004bfe4013e0fa00f73900baf28496d11 /sys-apps/edac-utils
parentx11-drivers/xf86-input-synaptics: bump to 1.1.3 (diff)
downloadgentoo-2-48539ec0f411d9501abea7e623cc186aece8874f.tar.gz
gentoo-2-48539ec0f411d9501abea7e623cc186aece8874f.tar.bz2
gentoo-2-48539ec0f411d9501abea7e623cc186aece8874f.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/edac-utils')
-rw-r--r--sys-apps/edac-utils/ChangeLog10
-rw-r--r--sys-apps/edac-utils/edac-utils-0.16.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/sys-apps/edac-utils/ChangeLog b/sys-apps/edac-utils/ChangeLog
index eb4e6d3a9aa5..ee876557d333 100644
--- a/sys-apps/edac-utils/ChangeLog
+++ b/sys-apps/edac-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/edac-utils
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/ChangeLog,v 1.1 2008/04/09 20:53:08 dev-zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/ChangeLog,v 1.2 2009/08/03 17:34:47 dev-zero Exp $
+
+*edac-utils-0.16 (03 Aug 2009)
+
+ 03 Aug 2009; Tiziano Müller <dev-zero@gentoo.org>
+ +edac-utils-0.16.ebuild:
+ Version bump.
*edac-utils-0.12 (09 Apr 2008)
diff --git a/sys-apps/edac-utils/edac-utils-0.16.ebuild b/sys-apps/edac-utils/edac-utils-0.16.ebuild
new file mode 100644
index 000000000000..e7749cc6bd17
--- /dev/null
+++ b/sys-apps/edac-utils/edac-utils-0.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/edac-utils/edac-utils-0.16.ebuild,v 1.1 2009/08/03 17:34:47 dev-zero Exp $
+
+EAPI="2"
+
+DESCRIPTION="Userspace helper for Linux kernel EDAC drivers"
+HOMEPAGE="http://sourceforge.net/projects/edac-utils/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="sys-fs/sysfsutils"
+RDEPEND="${DEPEND}
+ sys-apps/dmidecode"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog DISCLAIMER META NEWS README TODO
+
+ # We don't need this init.d file
+ # Modules should be loaded by adding them to /etc/conf.d/modules
+ # The rest is done via the udev-rule
+ rm -rf "${D}/etc/init.d"
+}
+
+pkg_postinst() {
+ elog "There must be an entry for your mainboard in /etc/edac/labels.db"
+ elog "in case you want nice labels in /sys/module/*_edac/"
+ elog "Run the following command to check whether such an entry is already available:"
+ elog " edac-ctl --print-labels"
+}