summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-11 04:16:14 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-11 04:16:14 +0000
commit3b06ae21289c22ae7764277180c06540fcebbfda (patch)
tree3ce092215e2769c7c0146072fca63d41640a0135 /sys-apps/eject/eject-2.1.0-r1.ebuild
parentFix modular X dependencies (bug #122234, Alexey Maximov). (diff)
downloadgentoo-2-3b06ae21289c22ae7764277180c06540fcebbfda.tar.gz
gentoo-2-3b06ae21289c22ae7764277180c06540fcebbfda.tar.bz2
gentoo-2-3b06ae21289c22ae7764277180c06540fcebbfda.zip
Fix by Stuart W. Finlayson for bug in toggle support #122256.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-apps/eject/eject-2.1.0-r1.ebuild')
-rw-r--r--sys-apps/eject/eject-2.1.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/eject/eject-2.1.0-r1.ebuild b/sys-apps/eject/eject-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..c4fa7620b680
--- /dev/null
+++ b/sys-apps/eject/eject-2.1.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.1.0-r1.ebuild,v 1.1 2006/02/11 04:16:14 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A command to eject a disc from the CD-ROM drive"
+HOMEPAGE="http://eject.sourceforge.net/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/disk-management/${P}.tar.gz
+ http://www.pobox.com/~tranter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="nls"
+
+DEPEND="!virtual/eject"
+PROVIDE="virtual/eject"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.0.13-autoclose.patch
+ epatch "${FILESDIR}"/${PN}-2.0.13-header.patch
+ epatch "${FILESDIR}"/${PN}-2.0.13-use-mountpoints.patch
+ epatch "${FILESDIR}"/${PN}-2.0.13-xmalloc.patch
+ epatch "${FILESDIR}"/${P}-regcomp-check.patch
+ epatch "${FILESDIR}"/${PN}-2.0.13-pumount.patch
+ epatch "${FILESDIR}"/${PN}-2.0.13-i18n-uclibc.patch
+ epatch "${FILESDIR}"/${P}-scsi-io-update.patch
+
+ sed -i '/^AM_CFLAGS/s:-O3::' Makefile.in
+ if ! use nls ; then
+ sed -i "s:SUBDIRS = po::" Makefile.in || die "sed nls failed"
+ fi
+
+ # Fix busted timestamps in tarball
+ touch -r aclocal.m4 configure.in
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README PORTING TODO AUTHORS NEWS PROBLEMS
+}